summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-02-23 10:20:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-02-23 10:20:07 +0000
commit2ff26dea308420a4e71fdab0704b5e49112cf864 (patch)
treeaff7a0c215127425e28128c7484b8d8f1ec7ce89 /net-analyzer/netwag/netwag-5.33.0.ebuild
parentMask dev-haskell/hdbc-* until they've been fully tested. (diff)
downloadgentoo-2-2ff26dea308420a4e71fdab0704b5e49112cf864.tar.gz
gentoo-2-2ff26dea308420a4e71fdab0704b5e49112cf864.tar.bz2
gentoo-2-2ff26dea308420a4e71fdab0704b5e49112cf864.zip
version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-analyzer/netwag/netwag-5.33.0.ebuild')
-rw-r--r--net-analyzer/netwag/netwag-5.33.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/netwag/netwag-5.33.0.ebuild b/net-analyzer/netwag/netwag-5.33.0.ebuild
new file mode 100644
index 000000000000..14827b1d9aec
--- /dev/null
+++ b/net-analyzer/netwag/netwag-5.33.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwag/netwag-5.33.0.ebuild,v 1.1 2006/02/23 10:20:07 dragonheart Exp $
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+DESCRIPTION="Tcl/tk interface to netwox (Toolbox of 217 utilities for testing Ethernet/IP networks)"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwag/"
+SRC_URI="http://www.laurentconstantin.com/common/netw/${PN}/download/v${PV/.*}/${P}-src.tgz
+ doc? (
+ http://www.laurentconstantin.com/common/netw/netwag/download/v${PV/.*}/${P}-doc_html.tgz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="doc"
+
+DEPEND="~net-analyzer/netwox-${PV}
+ >=dev-lang/tk-8"
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/src
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/usr/local:/usr:" \
+ config.dat
+
+ ./genemake || die "problem creating Makefile"
+}
+
+src_compile() {
+ cd src
+ emake || die "compile problem"
+}
+
+
+src_install() {
+ dodoc README.TXT
+ if use doc;
+ then
+ mv "${WORKDIR}"/${P}-doc_html "${D}"/usr/share/doc/${PF}/html
+ else
+ dodoc doc/{changelog.txt,credits.txt} \
+ doc/{problemreport.txt,problemusage.txt,todo.txt}
+ fi
+ cd src
+ make install DESTDIR="${D}" || die
+}