summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-05-07 19:31:28 +0000
committerMichael Januszewski <spock@gentoo.org>2008-05-07 19:31:28 +0000
commitd14df83bc0b3cc75f2521526fb5cef7c92b541c4 (patch)
treeba7c5d82bda74a681f70a94d0ecc7f261541f8e0 /net-analyzer/nmap
parentUse . instead of -, that's what all our of init scripts use. (diff)
downloadgentoo-2-d14df83bc0b3cc75f2521526fb5cef7c92b541c4.tar.gz
gentoo-2-d14df83bc0b3cc75f2521526fb5cef7c92b541c4.tar.bz2
gentoo-2-d14df83bc0b3cc75f2521526fb5cef7c92b541c4.zip
Version bump (bug #220449).
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/nmap-4.62.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index dd12bae94b27..f44a7aac0a69 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.170 2008/05/02 15:08:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.171 2008/05/07 19:31:28 spock Exp $
+
+*nmap-4.62 (07 May 2008)
+
+ 07 May 2008; Michał Januszewski <spock@gentoo.org> +nmap-4.62.ebuild:
+ Version bump (bug #220449).
02 May 2008; Raúl Porcel <armin76@gentoo.org> nmap-4.60.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/net-analyzer/nmap/nmap-4.62.ebuild b/net-analyzer/nmap/nmap-4.62.ebuild
new file mode 100644
index 000000000000..9cb08303ab0d
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.62.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.62.ebuild,v 1.1 2008/05/07 19:31:28 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version ">=dev-lang/lua-5.1.3-r1" &&
+ built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf \
+ --with-libdnet=included \
+ "${myconf}" \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}