summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 22:11:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 22:11:29 +0000
commit19367a734da2d7792927e5f90dab883856eb37a2 (patch)
tree2773628c095bca8f8b844c74e5ea197b8114e217 /net-analyzer/ns/ns-2.27-r1.ebuild
parentFix use invocation (diff)
downloadgentoo-2-19367a734da2d7792927e5f90dab883856eb37a2.tar.gz
gentoo-2-19367a734da2d7792927e5f90dab883856eb37a2.tar.bz2
gentoo-2-19367a734da2d7792927e5f90dab883856eb37a2.zip
remove unnecessary variables and function; tidy
Diffstat (limited to 'net-analyzer/ns/ns-2.27-r1.ebuild')
-rw-r--r--net-analyzer/ns/ns-2.27-r1.ebuild63
1 files changed, 25 insertions, 38 deletions
diff --git a/net-analyzer/ns/ns-2.27-r1.ebuild b/net-analyzer/ns/ns-2.27-r1.ebuild
index c074cd2a3bb4..1f8b4cd07e4e 100644
--- a/net-analyzer/ns/ns-2.27-r1.ebuild
+++ b/net-analyzer/ns/ns-2.27-r1.ebuild
@@ -1,48 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.27-r1.ebuild,v 1.2 2004/05/17 16:09:49 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.27-r1.ebuild,v 1.3 2004/06/07 22:11:29 mr_bones_ Exp $
DESCRIPTION="Network Simulator"
HOMEPAGE="http://www.isi.edu/nsnam/ns/"
SRC_URI="http://www.isi.edu/nsnam/dist/${PN}-src-${PV}.tar.gz"
+
LICENSE="BSD as-is"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc debug"
-need_tclver="8.4.4"
-valid_tclver="${need_tclver}"
-mytclver=""
-DEPEND_COMMON=">=dev-lang/tcl-${need_tclver}
- >=dev-lang/tk-${need_tclver}
+
+DEPEND_COMMON=">=dev-lang/tcl-8.4.4
+ >=dev-lang/tk-8.4.4
>=dev-tcltk/otcl-1.0.8a
>=dev-tcltk/tclcl-1.0.13b
net-libs/libpcap
debug? ( =dev-lang/perl-5* >=media-gfx/xgraph-12.1 >=dev-libs/dmalloc-4.8.2 >=dev-tcltk/tcl-debug-2.0 )"
DEPEND="doc? ( virtual/tetex virtual/ghostscript dev-tex/latex2html ) ${DEPEND_COMMON}"
RDEPEND="${DEPEND_COMMON}"
-S=${WORKDIR}/${P}
-
-findtclver() {
- # input should always be in INCREASING order
- local ACCEPTVER="8.3 8.4"
- [ -n "$*" ] && ACCEPTVER="$*"
- for i in ${ACCEPTVER}; do
- use debug && einfo "Testing TCL ${i}"
- # we support being more specific
- [ "$(#i)" = "3" ] && i="${i}*"
- has_version ">=dev-lang/tcl-${i}" && mytclver=${i}
- done
- use debug && einfo "Using TCL ${mytclver}"
- if [ -z "${mytclver}" ]; then
- die "Unable to find a suitable version of TCL"
- fi
-}
src_compile() {
local myconf
- use debug && myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" || myconf="${myconf} --with-tcldebug=no"
- myconf="${myconf} `use_with debug dmalloc`"
local mytclver=""
+ local i
+
+ use debug \
+ && myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" \
+ || myconf="${myconf} --with-tcldebug=no"
+ myconf="${myconf} $(use_with debug dmalloc)"
+
for i in 8.4 8.3; do
einfo "Testing TCL ${i}"
has_version "=dev-lang/tcl-${i}*" && mytclver=${i}
@@ -52,10 +39,10 @@ src_compile() {
myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
econf \
- ${myconf} \
- --mandir=/usr/share/man \
- --enable-stl \
- --enable-release || die "./configure failed"
+ ${myconf} \
+ --mandir=/usr/share/man \
+ --enable-stl \
+ --enable-release || die "./configure failed"
emake CCOPT="${CFLAGS}" || die
cd ${S}/indep-utils/dosdbell
@@ -67,27 +54,27 @@ src_compile() {
}
src_install() {
- dodir /usr/bin
- dodir /usr/share/man/man1
- make DESTDIR=${D} MANDEST=/usr/share/man install || die
+ dodir /usr/bin /usr/share/man/man1
+ make DESTDIR="${D}" MANDEST=/usr/share/man install \
+ || die "make install failed"
dobin nse
dodoc BASE-VERSION COPYRIGHTS FILES HOWTO-CONTRIBUTE README VERSION
dohtml CHANGES.html TODO.html
- cp -ra ${S}/ns-tutorial ${D}/usr/share/doc/${PF}
- cp -ra ${S}/tcl ${D}/usr/share/ns
+ cp -ra "${S}/ns-tutorial" "${D}/usr/share/doc/${PF}"
+ cp -ra "${S}/tcl" "${D}/usr/share/ns"
- cd ${S}/indep-utils/dosdbell
+ cd "${S}/indep-utils/dosdbell"
dobin dosdbell dosdbellasim
newdoc README README.dosdbell
- cd ${S}/indep-utils/dosreduce
+ cd "${S}/indep-utils/dosreduce"
dobin dosreduce
newdoc README README.dosreduce
- cd ${S}/indep-utils/cmu-scen-gen
+ cd "${S}/indep-utils/cmu-scen-gen"
dobin cbrgen.tcl
newdoc README README.cbrgen
- cd ${S}/indep-utils/propagation
+ cd "${S}/indep-utils/propagation"
dobin threshold
if use doc; then