summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-18 00:16:37 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-18 00:16:37 +0000
commit353c37d26cd8161667e667d01194d8ec492067f5 (patch)
tree0af4174c13e7b488af46ebd5e69aa951a93621a6 /net-analyzer/ntop/ntop-3.3.10.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-353c37d26cd8161667e667d01194d8ec492067f5.tar.gz
gentoo-2-353c37d26cd8161667e667d01194d8ec492067f5.tar.bz2
gentoo-2-353c37d26cd8161667e667d01194d8ec492067f5.zip
Add missing lua dependency (#274447).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ntop/ntop-3.3.10.ebuild')
-rw-r--r--net-analyzer/ntop/ntop-3.3.10.ebuild121
1 files changed, 0 insertions, 121 deletions
diff --git a/net-analyzer/ntop/ntop-3.3.10.ebuild b/net-analyzer/ntop/ntop-3.3.10.ebuild
deleted file mode 100644
index 079cc41c0f56..000000000000
--- a/net-analyzer/ntop/ntop-3.3.10.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.10.ebuild,v 1.1 2009/06/14 10:05:51 mrness Exp $
-
-EAPI="2"
-
-inherit eutils autotools
-
-DESCRIPTION="Network traffic analyzer with web interface"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6 ssl tcpd"
-#snmp support is disabled
-
-#snmp? ( net-analyzer/net-snmp )
-COMMON_DEPEND="sys-apps/gawk
- dev-lang/perl
- sys-libs/gdbm
- dev-libs/libevent
- net-libs/libpcap
- media-libs/gd
- media-libs/libpng
- net-analyzer/rrdtool
- ssl? ( dev-libs/openssl )
- tcpd? ( sys-apps/tcp-wrappers )
- sys-libs/zlib
- >=dev-libs/geoip-1.4.5"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/libtool-1.4"
-
-# Needed by xmldumpPlugin - couldn't get it to work
-# dev-libs/gdome2
-# >=dev-libs/glib-2"
-RDEPEND="${COMMON_DEPEND}
- media-fonts/corefonts
- media-gfx/graphviz
- net-misc/wget
- app-arch/gzip"
-
-pkg_setup() {
- # snmp doesn't compile in this release, disabled for now
- #if use snmp ; then
- # ewarn "snmp plugin is under development and upstream does not recommend"
- # ewarn "it for usage in production environment."
- # if ! use ipv6 ; then
- # echo
- # eerror "snmp plugin has compilation problems without ipv6 support."
- # eerror "For additional information see bug #121497."
- # die "snmp without ipv6 is broken"
- # else
- # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
- # echo
- # eerror "You have both ipv6 and snmp enabled."
- # eerror "This require ipv6 support in net-analyzer/net-snmp."
- # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
- # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
- # die "net-analyzer/net-snmp was build without ipv6."
- # fi
- # fi
- #fi
-
- enewgroup ntop
- enewuser ntop -1 -1 /var/lib/ntop ntop
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-external-geoip.patch
- cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
- eautoreconf
-}
-
-src_configure() {
- # force disable xmldumpPlugin
- export \
- ac_cv_header_glib_h=no \
- ac_cv_header_glibconfig_h=no \
- ac_cv_header_gdome_h=no \
- ac_cv_lib_glib_g_date_julian=no \
- ac_cv_lib_xml2_xmlCheckVersion=no \
- ac_cv_lib_gdome_gdome_di_saveDocToFile=no
-
- econf \
- $(use_enable ipv6) \
- $(use_with ssl) $(use_enable ssl sslwatchdog) \
- $(use_with tcpd tcpwrap) \
- --with-rrd-home=/usr/lib \
- --disable-snmp \
- || die "configure problem"
- # $(use_enable snmp)
-}
-
-src_install() {
- LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
- emake DESTDIR="${D}" install || die "install problem"
-
- keepdir /var/lib/ntop &&
- fowners ntop:ntop /var/lib/ntop &&
- fperms 750 /var/lib/ntop ||
- die "failed to prepare /var/lib/ntop dir"
-
- dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
-
- newinitd "${FILESDIR}"/ntop-initd ntop
- newconfd "${FILESDIR}"/ntop-confd ntop
-
- exeinto /etc/cron.monthly
- doexe "${FILESDIR}"/ntop-update-geoip-db
-}
-
-pkg_postinst() {
- elog "If this is the first time you install ntop, you need to run"
- elog "following commands before starting ntop service:"
- elog " ntop --set-admin-password"
- elog " /etc/cron.monthly/ntop-update-geoip-db"
-}