summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-09 15:41:28 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-09 15:41:28 +0000
commit842864081b4d9379ebc990fad1873efd82132b35 (patch)
treecc5966975cedf0592ba61207e52dcc9f4228bb67 /net-analyzer/ntop
parentnew unstable version, still masked. Added KEYWORDS, missing ssl support, (diff)
downloadgentoo-2-842864081b4d9379ebc990fad1873efd82132b35.tar.gz
gentoo-2-842864081b4d9379ebc990fad1873efd82132b35.tar.bz2
gentoo-2-842864081b4d9379ebc990fad1873efd82132b35.zip
quick fix for bug #4678
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog23
-rw-r--r--net-analyzer/ntop/files/digest-ntop-2.0.99_rc2-r11
-rw-r--r--net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild96
3 files changed, 106 insertions, 14 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index d1da6ef3d492..5a46e2377468 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ntop
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.3 2002/06/14 20:40:37 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.4 2002/07/09 15:41:28 blizzy Exp $
+
+*ntop-2.0.99_rc2-r1 (09 Jul 2002)
+
+ 09 Jul 2002; Maik Schreiber <blizzy@gentoo.org> :
+
+ Quick fix for bug #4678.
*ntop-2.0.99_rc2 (14 Jun 2002)
@@ -8,20 +14,9 @@
updated revision
-*ntop-2.0 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
-
-*ntop-2.0 (25 Apr 2002)
+*ntop-2.0-r1 (25 Apr 2002)
25 Apr 2002; Pete Michaleas <tutor@gentoo.org> ntop-2.0-r1.ebuild :
-
+
Included patch to fix vulnerability with syslog() call, found in
util.c.
-
diff --git a/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2-r1 b/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2-r1
new file mode 100644
index 000000000000..82665b332343
--- /dev/null
+++ b/net-analyzer/ntop/files/digest-ntop-2.0.99_rc2-r1
@@ -0,0 +1 @@
+MD5 d2eebe53b21c954abd44f8b96483bf8c ntop-2.0.99-rc2.tgz 1828895
diff --git a/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild b/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild
new file mode 100644
index 000000000000..b0411d96272f
--- /dev/null
+++ b/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild,v 1.1 2002/07/09 15:41:28 blizzy Exp $
+
+A=ntop-2.0.99-rc2.tgz
+S=${WORKDIR}/RC2/ntop
+
+DESCRIPTION="ntop is a unix tool that shows network usage like top"
+SRC_URI="http://luca.ntop.org/${A}"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="*"
+
+DEPEND="virtual/glibc sys-devel/gcc
+ >=sys-libs/gdbm-1.8.0
+ >=net-libs/libpcap-0.5.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ mysql? ( dev-db/mysql )
+ readline? ( >=sys-libs/readline-4.1 )
+ >=sys-apps/tcp-wrappers-7.6"
+# tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+# Disabling tcp-wrappers seems to be b0rken (see bug #4678),
+# so I made this a requirement for now. --blizzy
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ if [ -z "`use ssl`" ] ; then
+ myconf="--disable-ssl"
+ else
+ cp configure configure.orig
+ sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ fi
+
+ use mysql || myconf="${myconf} --disable-mysql"
+ use readline || myconf="${myconf} --disable-readline"
+# see above --blizzy
+# use tcpd || myconf="${myconf} --enable-tcpwrap"
+ myconf="${myconf} --enable-tcpwrap"
+
+ # ntop 2.0 ships with its own version of gdchart... gdchart should
+ # get its own package but ntop should be built with the version it
+ # shipped with just in case future versions are incompatible -- blocke
+
+ # compile gdchart
+ cd ../gdchart0.94c
+ ./configure || die "gdchart configure problem"
+
+ # subtree #1
+ cd gd-1.8.3/libpng-1.2.1
+ make -f scripts/makefile.linux || die "libpng compile problem"
+
+ # subtree #2
+ cd ../../zlib-1.1.4/
+ ./configure || die "zlib configure problem"
+ make || die "zlib compile problem"
+
+ # gdchart make
+ cd ../
+ make || die "gdchart compile problem"
+
+ # now ntop itself...
+ cd ../ntop
+ econf ${myconf} || die "configure problem"
+ make || die "compile problem"
+}
+
+src_install () {
+ # slight issue with man file installation
+ mv Makefile Makefile.orig
+ sed 's/man_MANS = ntop.8 intop\/intop.1//g' Makefile.orig > Makefile
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=/${D}/etc \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ DATAFILE_DIR=${D}/usr/share/ntop \
+ CONFIGFILE_DIR=${D}/etc/ntop \
+ install || die "install problem"
+
+ # fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
+ # (don't know if there is a clean way to handle it)
+
+ doman ntop-rules.8 ntop.8
+
+ dodoc AUTHORS CONTENTS COPYING ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS
+
+ dohtml ntop.html
+
+ dodir /var/lib/ntop
+}