summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-02-17 06:28:05 +0000
committerMichael Boman <mboman@gentoo.org>2004-02-17 06:28:05 +0000
commit3a089d324dae023817a971bd01128933d750fc26 (patch)
tree5452c0b2229a3e8378f4f30ea1decdf658814dc7 /net-analyzer/oinkmaster/oinkmaster-0.9.ebuild
parentpkg_postinst ${S} mis-use corrected. (Manifest recommit) (diff)
downloadgentoo-2-3a089d324dae023817a971bd01128933d750fc26.tar.gz
gentoo-2-3a089d324dae023817a971bd01128933d750fc26.tar.bz2
gentoo-2-3a089d324dae023817a971bd01128933d750fc26.zip
Initial ebuild. Closes #23499.
Diffstat (limited to 'net-analyzer/oinkmaster/oinkmaster-0.9.ebuild')
-rw-r--r--net-analyzer/oinkmaster/oinkmaster-0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/oinkmaster/oinkmaster-0.9.ebuild b/net-analyzer/oinkmaster/oinkmaster-0.9.ebuild
new file mode 100644
index 000000000000..b7a85f72951c
--- /dev/null
+++ b/net-analyzer/oinkmaster/oinkmaster-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/oinkmaster/oinkmaster-0.9.ebuild,v 1.1 2004/02/17 06:28:05 mboman Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Rule management for SNORT"
+SRC_URI="mirror://sourceforge/oinkmaster/${P}.tar.gz"
+HOMEPAGE="http://oinkmaster.sf.net/"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ net-misc/wget
+ app-arch/tar
+ app-arch/gzip"
+
+SLOT="0"
+LICENSE="BSD"
+
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-oinkmaster.conf.patch
+}
+
+src_install() {
+ dobin oinkmaster.pl contrib/addmsg.pl contrib/makesidex.pl
+ dodoc ChangeLog LICENSE README INSTALL UPGRADING contrib/README.contrib
+ insinto /etc
+ doins oinkmaster.conf
+}
+