summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-11 05:24:03 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-11 05:24:03 +0000
commit3f9d9cf518322b4caa8967294d5e868dc7faaeef (patch)
treed999151d7b6ad03c626bb9d01ccdf91a6c303fc7 /net-analyzer/pmacct
parentStable for HPPA (bug #318647). (diff)
downloadgentoo-2-3f9d9cf518322b4caa8967294d5e868dc7faaeef.tar.gz
gentoo-2-3f9d9cf518322b4caa8967294d5e868dc7faaeef.tar.bz2
gentoo-2-3f9d9cf518322b4caa8967294d5e868dc7faaeef.zip
Version bump thanks to Marcin Mirosław (bug #318843).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog7
-rw-r--r--net-analyzer/pmacct/pmacct-0.12.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 6702ed3feb3c..bc23a5dbd3a3 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.64 2010/03/01 23:39:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.65 2010/05/11 05:24:03 jer Exp $
+
+*pmacct-0.12.1 (11 May 2010)
+
+ 11 May 2010; Jeroen Roovers <jer@gentoo.org> +pmacct-0.12.1.ebuild:
+ Version bump thanks to Marcin Mirosław (bug #318843).
*pmacct-0.12.0-r1 (01 Mar 2010)
diff --git a/net-analyzer/pmacct/pmacct-0.12.1.ebuild b/net-analyzer/pmacct/pmacct-0.12.1.ebuild
new file mode 100644
index 000000000000..1726697b558b
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.12.1.ebuild,v 1.1 2010/05/11 05:24:03 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="64bit debug ipv6 mysql postgres sqlite threads ulog"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cp -av configure{,.org}
+ cp -av configure.in{,.org}
+ epatch "${FILESDIR}"/${PN}-0.12.0-gentoo.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable 64bit) \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable threads) \
+ $(use_enable ulog) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CONFIG-KEYS EXAMPLES FAQS KNOWN-BUGS README UPGRADE \
+ docs/SIGNALS docs/PLUGINS docs/INTERNALS TODO TOOLS \
+ || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}/examples/pmacctd-imt.conf.example" pmacctd.conf || \
+ die "newins failed"
+}