summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-10-27 19:40:43 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-10-27 19:40:43 +0000
commitee1b337cb056a93d064b7a7d9336ef74bef4cdfa (patch)
tree6dc209b8612be8596914659dd9f91ae7350f57cf /net-analyzer/pnp4nagios
parentMask gcc-4.{3,4} on Darwin, as it doesn't compile for a while now (diff)
downloadgentoo-2-ee1b337cb056a93d064b7a7d9336ef74bef4cdfa.tar.gz
gentoo-2-ee1b337cb056a93d064b7a7d9336ef74bef4cdfa.tar.bz2
gentoo-2-ee1b337cb056a93d064b7a7d9336ef74bef4cdfa.zip
Version bump (#290758)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog8
-rw-r--r--net-analyzer/pnp4nagios/files/npcd37
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.4.14.ebuild (renamed from net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild)20
3 files changed, 54 insertions, 11 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index 525c1557bdf5..04c80c658ed9 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.11 2009/03/18 22:23:26 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.12 2009/10/27 19:40:42 dertobi123 Exp $
+
+*pnp4nagios-0.4.14 (27 Oct 2009)
+
+ 27 Oct 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ -pnp4nagios-0.4.13.ebuild, +pnp4nagios-0.4.14.ebuild, +files/npcd:
+ Version bump (#290758)
18 Mar 2009; Brent Baude <ranger@gentoo.org> pnp4nagios-0.4.12.ebuild:
Marking pnp4nagios-0.4.12 ppc stable for bug 256177
diff --git a/net-analyzer/pnp4nagios/files/npcd b/net-analyzer/pnp4nagios/files/npcd
new file mode 100644
index 000000000000..72f24b953bb6
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/npcd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/files/npcd,v 1.1 2009/10/27 19:40:43 dertobi123 Exp $
+
+opts="${opts} reload"
+
+depend() {
+ need net nagios
+}
+
+start() {
+ ebegin "Starting npcd"
+ start-stop-daemon --start --exec /usr/bin/npcd \
+ -- -f /etc/pnp/npcd.cfg \
+ -d
+ eend $? "Failed to Start npcd"
+}
+
+stop() {
+ ebegin "Stopping npcd"
+ start-stop-daemon --stop --quiet -n npcd
+ eend $? "Failed to Stop npcd"
+}
+
+reload() {
+ ebegin "Reloading npcd"
+ kill -HUP `pgrep npcd`
+ eend $? "Failed to reload npcd"
+}
+
+restart() {
+ ebegin "Restarting npcd"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart npcd"
+}
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.4.14.ebuild
index 4d52e4b1d096..af2bf9f679f2 100644
--- a/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.4.14.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.4.13.ebuild,v 1.2 2009/03/04 21:17:54 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.4.14.ebuild,v 1.1 2009/10/27 19:40:42 dertobi123 Exp $
-inherit confutils
+EAPI="2"
MY_P=pnp-${PV}
@@ -16,30 +16,30 @@ SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-DEPEND=">=dev-lang/php-4.3
+DEPEND=">=dev-lang/php-4.3[gd-external,pcre,xml,zlib]
>=net-analyzer/rrdtool-1.2
net-analyzer/nagios-core"
RDEPEND="${DEPEND}
virtual/perl-Getopt-Long
virtual/perl-Time-HiRes"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- confutils_require_built_with_all dev-lang/php gd pcre xml zlib
-}
-
-src_compile() {
+src_configure() {
econf \
--sysconfdir=/etc/pnp \
--datarootdir=/usr/share/pnp \
--with-perfdata-dir=/var/nagios/perfdata \
--with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+}
+
+src_compile() {
emake all || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" fullinstall || die "emake install failed"
+ emake DESTDIR="${D}" install install-config || die "emake install failed"
+ doinitd "${FILESDIR}/npcd"
}
pkg_postinst() {