summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:06:30 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:06:30 +0000
commit8eb0e647d7b845521c8b39e3e2e3f59d759132b7 (patch)
tree06f2b2c321dff4f96685c3d3e48738aa67225a6a /net-analyzer/scanlogd
parentChanged econf||die to econf (diff)
downloadgentoo-2-8eb0e647d7b845521c8b39e3e2e3f59d759132b7.tar.gz
gentoo-2-8eb0e647d7b845521c8b39e3e2e3f59d759132b7.tar.bz2
gentoo-2-8eb0e647d7b845521c8b39e3e2e3f59d759132b7.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-analyzer/scanlogd')
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.ebuild
index 4ddc870baad0..85c01e18c543 100644
--- a/net-analyzer/scanlogd/scanlogd-2.2.ebuild
+++ b/net-analyzer/scanlogd/scanlogd-2.2.ebuild
@@ -1,32 +1,29 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.ebuild,v 1.6 2002/10/04 05:59:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.ebuild,v 1.7 2002/11/30 02:01:44 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Scanlogd- detects and logs TCP port scans"
SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
-HOMEPAGE="http://www.openwall.com/scanlogd"
-
-DEPEND="virtual/glibc"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc"
+
src_compile() {
make linux || die
}
-src_install() {
- mkdir -p ${D}usr/sbin
- cp scanlogd ${D}usr/sbin || die
-
+src_install() {
+ dosbin scanlogd
doman scanlogd.8
exeinto /etc/init.d ; newexe ${FILESDIR}/scanlogd.rc scanlogd
}
-pkg_postinst () {
+pkg_postinst() {
einfo "Before you can run scanlogd you need to create the user "
einfo "scanlog by running the following command"
einfo "adduser -s /bin/false scanlogd"