summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2011-09-20 21:56:45 +0000
committerMike Auty <ikelos@gentoo.org>2011-09-20 21:56:45 +0000
commit9a6497a1cc6187860e7d2fc4f87feb3255d9a6e4 (patch)
tree1b88a65698ef7625e6357765e6402eb0b9fce872 /net-analyzer/scapy
parentUse correct pkg-config rather than hardcoded `pkg-config` #383861#1 by Tony V... (diff)
downloadgentoo-2-9a6497a1cc6187860e7d2fc4f87feb3255d9a6e4.tar.gz
gentoo-2-9a6497a1cc6187860e7d2fc4f87feb3255d9a6e4.tar.bz2
gentoo-2-9a6497a1cc6187860e7d2fc4f87feb3255d9a6e4.zip
Add in a patch from Scott. Fixes bug 383739.
(Portage version: 2.2.0_alpha58/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/scapy')
-rw-r--r--net-analyzer/scapy/ChangeLog8
-rw-r--r--net-analyzer/scapy/files/scapy-2.2.0-fix-sendpfast.patch12
-rw-r--r--net-analyzer/scapy/scapy-2.2.0-r1.ebuild38
3 files changed, 57 insertions, 1 deletions
diff --git a/net-analyzer/scapy/ChangeLog b/net-analyzer/scapy/ChangeLog
index 8749c3d1b6db..68549a2e14b6 100644
--- a/net-analyzer/scapy/ChangeLog
+++ b/net-analyzer/scapy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/scapy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.32 2011/04/19 11:39:14 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.33 2011/09/20 21:56:45 ikelos Exp $
+
+*scapy-2.2.0-r1 (20 Sep 2011)
+
+ 20 Sep 2011; Mike Auty <ikelos@gentoo.org> +scapy-2.2.0-r1.ebuild,
+ +files/scapy-2.2.0-fix-sendpfast.patch:
+ Add in a patch from Scott. Fixes bug 383739.
19 Apr 2011; Thomas Kahle <tomka@gentoo.org> scapy-2.1.0.ebuild:
x86 stable per bug 359829
diff --git a/net-analyzer/scapy/files/scapy-2.2.0-fix-sendpfast.patch b/net-analyzer/scapy/files/scapy-2.2.0-fix-sendpfast.patch
new file mode 100644
index 000000000000..e10f97353d71
--- /dev/null
+++ b/net-analyzer/scapy/files/scapy-2.2.0-fix-sendpfast.patch
@@ -0,0 +1,12 @@
+diff -ru a/scapy-2.2.0/scapy/sendrecv.py b/scapy-2.2.0/scapy/sendrecv.py
+--- a/scapy-2.2.0/scapy/sendrecv.py 2010-08-11 11:09:51.000000000 +1200
++++ b/scapy-2.2.0/scapy/sendrecv.py 2011-09-20 11:22:26.776978191 +1200
+@@ -13,7 +13,7 @@
+ import arch
+ from config import conf
+ from packet import Gen
+-from utils import warning,get_temp_file,PcapReader
++from utils import warning,get_temp_file,PcapReader,wrpcap
+ import plist
+ from error import log_runtime,log_interactive
+ from base_classes import SetGen
diff --git a/net-analyzer/scapy/scapy-2.2.0-r1.ebuild b/net-analyzer/scapy/scapy-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..8748b47da7fc
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.2.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/scapy-2.2.0-r1.ebuild,v 1.1 2011/09/20 21:56:45 ikelos Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils distutils
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://www.secdev.org/projects/scapy/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick visual tcpreplay"
+
+DEPEND=""
+RDEPEND="net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py )
+ pyx? ( dev-python/pyx )
+ crypt? ( dev-python/pycrypto )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] ) )
+ visual? ( dev-python/visual )
+ tcpreplay? ( net-analyzer/tcpreplay )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-sendpfast.patch
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}