summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-24 02:05:49 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-24 02:05:49 +0000
commit2a17ed8feec57d8a038b7bb63738a3e7a8877b07 (patch)
tree8e69dfe8d06a4ed711d6d9ce1df593331840708d /net-analyzer/scli
parentversion bump - bug #395559 with patch from Peter Fox (diff)
downloadgentoo-2-2a17ed8feec57d8a038b7bb63738a3e7a8877b07.tar.gz
gentoo-2-2a17ed8feec57d8a038b7bb63738a3e7a8877b07.tar.bz2
gentoo-2-2a17ed8feec57d8a038b7bb63738a3e7a8877b07.zip
Use append-cppflags not append-flags. Use $AR instead of harcoded ar by Vicente Olivert Riera (bug #436008).
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/scli')
-rw-r--r--net-analyzer/scli/ChangeLog8
-rw-r--r--net-analyzer/scli/scli-0.4.0-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/net-analyzer/scli/ChangeLog b/net-analyzer/scli/ChangeLog
index 2d06f828634a..3220ea4bc8b2 100644
--- a/net-analyzer/scli/ChangeLog
+++ b/net-analyzer/scli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/scli
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scli/ChangeLog,v 1.14 2012/09/23 19:08:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scli/ChangeLog,v 1.15 2012/09/24 02:05:49 jer Exp $
+
+*scli-0.4.0-r1 (24 Sep 2012)
+
+ 24 Sep 2012; Jeroen Roovers <jer@gentoo.org> +scli-0.4.0-r1.ebuild:
+ Use append-cppflags not append-flags. Use $AR instead of harcoded ar by
+ Vicente Olivert Riera (bug #436008).
23 Sep 2012; Agostino Sarubbo <ago@gentoo.org> scli-0.4.0.ebuild:
Stable for amd64, wrt bug #409541
diff --git a/net-analyzer/scli/scli-0.4.0-r1.ebuild b/net-analyzer/scli/scli-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..6cf55f5052f6
--- /dev/null
+++ b/net-analyzer/scli/scli-0.4.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scli/scli-0.4.0-r1.ebuild,v 1.1 2012/09/24 02:05:49 jer Exp $
+
+EAPI=4
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="SNMP Command Line Interface"
+HOMEPAGE="http://www.ibr.cs.tu-bs.de/projects/scli/"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/gnet
+ net-libs/gsnmp
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+ debug? ( dev-libs/dmalloc )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( README AUTHORS NEWS TODO ChangeLog PORTING )
+
+src_prepare() {
+ sed -i stub/Makefile.in proc/Makefile.in \
+ -e '/^AR = ar/d' || die
+}
+
+src_configure() {
+ append-cppflags -I/usr/include/libxml2
+ export AR=$(tc-getAR)
+ econf \
+ --enable-warnings \
+ $(use_enable debug dmalloc)
+}