summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:59:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:59:41 +0000
commit6824f4cd2f56a3c5400ac9570098943dd6b9ecd6 (patch)
tree6a482dd1bc7d7c72b641a335bcf03438f291e0ce /net-analyzer/slurm/files
parentAdd patch to fix build with --as-needed by Kevin Pyle, closes bug #247930. Al... (diff)
downloadgentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.tar.gz
gentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.tar.bz2
gentoo-2-6824f4cd2f56a3c5400ac9570098943dd6b9ecd6.zip
Add patch to fix build with --as-needed by Kevin Pyle, closes bug #247937.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/slurm/files')
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
new file mode 100644
index 000000000000..43a91176acea
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
@@ -0,0 +1,45 @@
+--- a/configure.in 2004-09-28 09:34:56.000000000 -0500
++++ b/configure.in 2009-02-14 12:42:52.000000000 -0600
+@@ -40,41 +40,15 @@
+ fi
+ AC_DEFINE(OSTYPE, ["${OSTYPE}"], [The operating system to build for])
+
+-for cursespath in /usr/include/ncurses.h /usr/local/include/ncurses.h /usr/local/include/ncurses/ncurses.h /opt/include/ncurses.h /opt/include/curses.h /usr/include/curses.h /usr/local/include/curses.h /dev/null
+-do
+- test -f "${cursespath}" && break
+-done
+-case ${cursespath} in
+- /usr/include/*)
+- CFLAGS="$CFLAGS -I/usr/include"
+- LDFLAGS=""
+- ;;
+- /usr/local/include/ncurses/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include/ncurses"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /usr/local/include/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /opt/include/*)
+- CFLAGS="${CFLAGS} -I/opt/include"
+- LDFLAGS="-L/opt/lib"
+- SOLLDFLAGS="-R/opt/lib"
+- ;;
+-esac
+ # add Slowlaris -R and libraries to LDFLAGS
+ if test ${OSTYPE} = "solaris" ; then
+ LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
+ fi
+
+-AC_CHECK_LIB(fridge, vanilla_coke, echo "WTF?!", echo "Warning: No vanilla coke found in fridge.";echo "We highly suggest that you rectify this situation immediatly.")
+ ncurses_support="no"
+ curses_support="no"
+ color_support="no"
+-AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes", AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES"; ncurses_support="yes"; echo "NO TRANSPARENCY SUPPORT in this ncurses lib", AC_CHECK_LIB(curses, initscr, LDFLAGS="$LDFLAGS -lcurses"; CFLAGS="$CFLAGS -D_HAVE_CURSES"; curses_support="yes"; echo "NO TRANSPARENCY SUPPORT in curses lib")))
++AC_CHECK_LIB(ncurses, use_default_colors, LIBS="-lncurses $LIBS"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes")
+
+ # disable color support on Solaris for now
+ if test ${OSTYPE} = "solaris" ; then