summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-06-04 11:48:45 +0000
committerJeroen Roovers <jer@gentoo.org>2012-06-04 11:48:45 +0000
commit86eeaca24c020c3eb86dc7834159e901f56ae688 (patch)
tree04c886c4edad8dec935c7b665538803a0d61bbe7 /net-analyzer/slurm/files
parentInclude fix for gcc47, #413937 (diff)
downloadgentoo-2-86eeaca24c020c3eb86dc7834159e901f56ae688.tar.gz
gentoo-2-86eeaca24c020c3eb86dc7834159e901f56ae688.tar.bz2
gentoo-2-86eeaca24c020c3eb86dc7834159e901f56ae688.zip
Clean up patch. Fix one more buffer overflow.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/slurm/files')
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch4
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-overflow.patch12
2 files changed, 10 insertions, 6 deletions
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
index 43a91176acea..e61687b37fe8 100644
--- a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
+++ b/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
@@ -1,5 +1,5 @@
---- a/configure.in 2004-09-28 09:34:56.000000000 -0500
-+++ b/configure.in 2009-02-14 12:42:52.000000000 -0600
+--- a/configure.in
++++ b/configure.in
@@ -40,41 +40,15 @@
fi
AC_DEFINE(OSTYPE, ["${OSTYPE}"], [The operating system to build for])
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch b/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch
index d2f787c827e8..f9adc1d9bf71 100644
--- a/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch
+++ b/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch
@@ -1,6 +1,6 @@
---- src/linux.c.org 2003-09-06 12:44:50.000000000 +0200
-+++ src/linux.c 2011-08-01 04:44:06.622205852 +0200
-@@ -68,8 +68,8 @@
+--- a/src/linux.c
++++ b/src/linux.c
+@@ -68,11 +68,11 @@
/* do not parse the first two lines as they only contain static garbage */
fseek(proc_net_dev, 0, SEEK_SET);
@@ -10,4 +10,8 @@
+ fgets(buffer, BUFSIZE-1, proc_net_dev);
interfacefound = 0;
- while (fgets(buffer, BUFSIZ-1, proc_net_dev) != NULL)
+- while (fgets(buffer, BUFSIZ-1, proc_net_dev) != NULL)
++ while (fgets(buffer, BUFSIZE-1, proc_net_dev) != NULL)
+ {
+ /* find the device name and substitute ':' with '\0' */
+ ptr = buffer;