summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-24 14:41:11 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-24 14:41:11 +0000
commit7d6a94fc780bf4ab37af8721069bce49959a9ad9 (patch)
tree74710f34333d05a882c4613dbb8a7d37801bccc0 /net-analyzer/snort
parentunmask 0.13.1 x86 (diff)
downloadgentoo-2-7d6a94fc780bf4ab37af8721069bce49959a9ad9.tar.gz
gentoo-2-7d6a94fc780bf4ab37af8721069bce49959a9ad9.tar.bz2
gentoo-2-7d6a94fc780bf4ab37af8721069bce49959a9ad9.zip
Version bump, fixed for bugs #6822 and #7299.
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog12
-rw-r--r--net-analyzer/snort/files/digest-snort-1.9.01
-rw-r--r--net-analyzer/snort/files/snort-1.9.0-gentoo.diff12
-rw-r--r--net-analyzer/snort/files/snort.confd8
-rw-r--r--net-analyzer/snort/snort-1.9.0.ebuild103
5 files changed, 132 insertions, 4 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index bfab850d1886..102284741542 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,9 +1,19 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.5 2002/08/30 16:19:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.6 2002/10/24 14:41:11 aliz Exp $
+
+*snort-1.9.0 (24 Oct 2002)
+
+ 24 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Found by Torgeir Hansen <torgeir@trenger.ro> in #8925.
+ Added support for specifying listening interface. Closes #6822.
+ Addes support for snmp, closes #7299.
*snort-1.8.7 (23 Jul 2002)
+ 24 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> files/snort.confd :
+ Added support for specifying listening interface. Closes #6822.
+
30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> snort-1.8.7.ebuild :
/var/log/snort now has a .keep in it. Closes bug #7271 by
diff --git a/net-analyzer/snort/files/digest-snort-1.9.0 b/net-analyzer/snort/files/digest-snort-1.9.0
new file mode 100644
index 000000000000..a9d90a940a06
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-1.9.0
@@ -0,0 +1 @@
+MD5 bcd3cbd0e6982345871d02fe60444c5c snort-1.9.0.tar.gz 1866556
diff --git a/net-analyzer/snort/files/snort-1.9.0-gentoo.diff b/net-analyzer/snort/files/snort-1.9.0-gentoo.diff
new file mode 100644
index 000000000000..29eee963f9fa
--- /dev/null
+++ b/net-analyzer/snort/files/snort-1.9.0-gentoo.diff
@@ -0,0 +1,12 @@
+--- configure 2002-10-24 13:59:23.000000000 +0000
++++ configure 2002-10-24 14:00:24.000000000 +0000
+@@ -3304,7 +3304,7 @@
+ else
+ echo "$ac_t""yes" 1>&6
+ LDFLAGS="${LDFLAGS} -L${SNMP_LIB_DIR} "
+- CPPFLAGS="${CPPFLAGS} -I${SNMP_INC_DIR} -DENABLE_SNMP"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_SNMP"
+ LIBS="${LIBS} -lnetsnmp"
+ fi
+ fi
+
diff --git a/net-analyzer/snort/files/snort.confd b/net-analyzer/snort/files/snort.confd
index 07734e1db780..fe7961b930b8 100644
--- a/net-analyzer/snort/files/snort.confd
+++ b/net-analyzer/snort/files/snort.confd
@@ -1,8 +1,10 @@
# Config file for /etc/init.d/snort
-# Make sure this matches your IFACE
-PIDFILE=/var/run/snort_eth0.pid
+# This tell snort which interface to listen on (any for every interface)
+IFACE=eth0
+# Make sure this matches your IFACE
+PIDFILE=/var/run/snort_$IFACE.pid
# You probably don't want to change this, but in case you do
LOGDIR="/var/log/snort"
@@ -11,4 +13,4 @@ LOGDIR="/var/log/snort"
CONF=/etc/snort/snort.conf
# This pulls in the options above
-SNORT_OPTS="-D -u snort -dev -l $LOGDIR -c $CONF"
+SNORT_OPTS="-D -u snort -i $IFACE -dev -l $LOGDIR -c $CONF"
diff --git a/net-analyzer/snort/snort-1.9.0.ebuild b/net-analyzer/snort/snort-1.9.0.ebuild
new file mode 100644
index 000000000000..96988bd04e5f
--- /dev/null
+++ b/net-analyzer/snort/snort-1.9.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.0.ebuild,v 1.1 2002/10/24 14:41:11 aliz Exp $
+
+IUSE="ssl postgres mysql snmp"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
+SRC_URI="http://www.snort.org/dl/${P}.tar.gz"
+HOMEPAGE="http://www.snort.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.6.2-r1
+ >=net-libs/libnet-1.0.2a
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ snmp? ( >=net-analyzer/net-snmp-5.0 )"
+
+RDEPEND="virtual/glibc
+ sys-devel/perl
+ >=net-libs/libpcap-0.6.2-r1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+
+ use postgres && myconf="${myconf} --with-postgresql" \
+ || myconf="${myconf} --without-postgresql"
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+ use ssl && myconf="${myconf} --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+ use snmp && myconf="${myconf} --with-snmp" \
+ || myconf="${myconf} --without-snmp"
+
+
+ ./configure \
+ --prefix=/usr \
+ --without-odbc \
+ --without-oracle \
+ --enable-pthreads \
+ --enable-flexresp \
+ --enable-smbalerts \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodir /var/log/snort
+ touch ${D}/var/log/snort/.keep
+
+ insinto /usr/lib/snort/bin
+ doins contrib/{create_mysql,snortlog,*.pl}
+
+ dodoc COPYING LICENSE doc/*
+ docinto contrib ; dodoc contrib/*
+
+ insinto /etc/snort
+ doins etc/classification.config rules/*.rules
+ newins etc/snort.conf snort.conf.distrib
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/snort.rc6 snort
+ insinto /etc/conf.d ; newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postinst() {
+
+ if ! grep -q ^snort: /etc/group ; then
+ groupadd snort || die "problem adding group snort"
+ fi
+ if ! grep -q ^snort: /etc/passwd ; then
+ useradd -g snort -s /dev/null -d /var/log/snort -c "snort" snort
+ assert "problem adding user snort"
+ fi
+ usermod -c "snort" snort || die "usermod problem"
+ usermod -d "/var/log/snort" snort || die "usermod problem"
+ usermod -g "snort" snort || die "usermod problem"
+ usermod -s "/dev/null" snort || die "usermod problem"
+ echo "ignore any message about CREATE_HOME above..."
+
+ chown snort.snort /var/log/snort
+ chmod 0770 /var/log/snort
+}