summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-14 17:59:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-14 17:59:01 +0000
commit98a01a4d131bd5953cb9f614fbf96b3fc9b97d4e (patch)
treea81612e98e2914f3fbed8576c94dd5fcd4d55797 /net-analyzer/snort
parentadd libgd and libpng to dependencies; fixes #46469 (Manifest recommit) (diff)
downloadgentoo-2-98a01a4d131bd5953cb9f614fbf96b3fc9b97d4e.tar.gz
gentoo-2-98a01a4d131bd5953cb9f614fbf96b3fc9b97d4e.tar.bz2
gentoo-2-98a01a4d131bd5953cb9f614fbf96b3fc9b97d4e.zip
added patch, fixes #47229
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog5
-rw-r--r--net-analyzer/snort/files/2.1.2-libnet-1.0.patch57
-rw-r--r--net-analyzer/snort/snort-1.9.1-r3.ebuild4
-rw-r--r--net-analyzer/snort/snort-2.0.5-r2.ebuild4
4 files changed, 65 insertions, 5 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index c8679e3b40cd..2a064ab1d785 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.38 2004/04/06 11:00:31 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.39 2004/04/14 17:59:00 squinky86 Exp $
+
+ 14 Apr 2004; Jon Hood <squinky86@gentoo.org> files/2.1.2-libnet-1.0.patch:
+ added patch, fixes #47229
06 Apr 2004; Joshua Brindle <method@gentoo.org> snort-2.1.1.ebuild,
snort-2.1.2.ebuild:
diff --git a/net-analyzer/snort/files/2.1.2-libnet-1.0.patch b/net-analyzer/snort/files/2.1.2-libnet-1.0.patch
new file mode 100644
index 000000000000..c26fa717ba1c
--- /dev/null
+++ b/net-analyzer/snort/files/2.1.2-libnet-1.0.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2003-08-19 01:19:05.948824752 -0400
++++ configure 2003-08-19 01:19:06.212784624 -0400
+@@ -6376 +6376 @@
+- CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-1.0-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-1.0-config --libs`"
+@@ -6382 +6382 @@
+- if test `libnet-config --cflags | wc -c` = "1"; then
++ if test `libnet-1.0-config --cflags | wc -c` = "1"; then
+@@ -6387,3 +6387,3 @@
+- if test `libnet-config --libs | wc -c` = "1"; then
+- { echo "$as_me:$LINENO: WARNING: libnet-config --libs is broken on your system. If you" >&5
+-echo "$as_me: WARNING: libnet-config --libs is broken on your system. If you" >&2;}
++ if test `libnet-1.0-config --libs | wc -c` = "1"; then
++ { echo "$as_me:$LINENO: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&5
++echo "$as_me: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&2;}
+@@ -6395 +6395 @@
+- LIBS="${LIBS} -lnet"
++ LIBS="${LIBS} -lnet-1.0"
+@@ -6400 +6400 @@
+-for ac_header in libnet.h
++for ac_header in libnet-1.0.h
+@@ -6533 +6533 @@
+- libnet_dir=`libnet-config --cflags | cut -dI -f2`
++ libnet_dir=`libnet-1.0-config --cflags | cut -dI -f2`
+@@ -6538 +6538 @@
+- if test -r $i/libnet.h; then
++ if test -r $i/libnet-1.0.h; then
+@@ -6544 +6544 @@
+- if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++ if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet-1.0.h | grep -v 1.0.2a >/dev/null"; then
+@@ -6555 +6555 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6574 +6574 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6587,2 +6587,2 @@
+-echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet" >&5
+-echo $ECHO_N "checking for libnet_build_ip in -lnet... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet-1.0" >&5
++echo $ECHO_N "checking for libnet_build_ip in -lnet-1.0... $ECHO_C" >&6
+@@ -6593 +6593 @@
+-LIBS="-lnet $LIBS"
++LIBS="-lnet-1.0 $LIBS"
+@@ -6647 +6647 @@
+- LIBS="-lnet $LIBS"
++ LIBS="-lnet-1.0 $LIBS"
+--- src/detection-plugins/sp_react.c.orig 2003-08-19 01:19:06.106800736 -0400
++++ src/detection-plugins/sp_react.c 2003-08-19 01:19:06.220783408 -0400
+@@ -56 +56 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- src/detection-plugins/sp_respond.c.orig 2003-08-19 01:19:06.111799976 -0400
++++ src/detection-plugins/sp_respond.c 2003-08-19 01:19:06.225782648 -0400
+@@ -33 +33 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/snort/snort-1.9.1-r3.ebuild b/net-analyzer/snort/snort-1.9.1-r3.ebuild
index ff4e6f73ea1c..e1c3b8fba1dc 100644
--- a/net-analyzer/snort/snort-1.9.1-r3.ebuild
+++ b/net-analyzer/snort/snort-1.9.1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1-r3.ebuild,v 1.6 2003/12/08 07:45:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1-r3.ebuild,v 1.7 2004/04/14 17:59:00 squinky86 Exp $
inherit eutils
diff --git a/net-analyzer/snort/snort-2.0.5-r2.ebuild b/net-analyzer/snort/snort-2.0.5-r2.ebuild
index 7f3ad9b6b905..33cd8d968732 100644
--- a/net-analyzer/snort/snort-2.0.5-r2.ebuild
+++ b/net-analyzer/snort/snort-2.0.5-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.5-r2.ebuild,v 1.2 2003/12/20 16:48:53 mboman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.5-r2.ebuild,v 1.3 2004/04/14 17:59:00 squinky86 Exp $
inherit eutils