summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commitaa6a19ea25bbed130cef956ef1bd6005cd95bd7e (patch)
tree22f7a92ee079fc4d76db2128cc7ee5a31a028184 /net-analyzer/tcpstat
parentUpdate (diff)
downloadgentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.gz
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.bz2
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.zip
dependencie, fhs and use fixes
Diffstat (limited to 'net-analyzer/tcpstat')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.3.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.3.ebuild b/net-analyzer/tcpstat/tcpstat-1.3.ebuild
index fcaf22d2e7b9..1c59d1d7c983 100644
--- a/net-analyzer/tcpstat/tcpstat-1.3.ebuild
+++ b/net-analyzer/tcpstat/tcpstat-1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.3.ebuild,v 1.4 2000/11/02 08:31:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.3.ebuild,v 1.5 2001/05/29 17:28:19 achim Exp $
P=tcpstat-1.3
A=${P}.tar.gz
@@ -10,12 +10,16 @@ DESCRIPTION="Reports network interface statistics"
SRC_URI="http://www.frenchfries.net/paul/tcpstat/${A}"
HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=net-libs/libpcap-0.5.2"
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.5.2
+ berkdb? ( <sys-libs/db-2 )"
+
+RDEPEND="virtual/glibc
+ >=net-libs/libpcap-0.5.2
+ berkdb? ( <sys-libs/db-2 )"
src_compile() {
- cd ${S}
try ./configure --prefix=/usr --host=${CHOST}
try make
@@ -23,9 +27,10 @@ src_compile() {
src_install () {
- cd ${S}
try make DESTDIR=${D} install
- prepman
+ if [ "`use berkdb`" ] ; then
+ dobin src/tcpprof
+ fi
dodoc AUTHORS ChangeLog COPYING LICENSE NEWS README*
}