summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-12-17 16:40:17 +0000
committerCédric Krier <cedk@gentoo.org>2006-12-17 16:40:17 +0000
commit1139a9a438fb65064228c35f7016d0341600e0af (patch)
tree9f4d6a705a95cfe9bcdc2dbb7102957a5ec415bd /net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
parentStable on ppc wrt bug #156969. (diff)
downloadgentoo-2-1139a9a438fb65064228c35f7016d0341600e0af.tar.gz
gentoo-2-1139a9a438fb65064228c35f7016d0341600e0af.tar.bz2
gentoo-2-1139a9a438fb65064228c35f7016d0341600e0af.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild')
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
new file mode 100644
index 000000000000..570242e9214e
--- /dev/null
+++ b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild,v 1.1 2006/12/17 16:40:17 cedk Exp $
+
+inherit eutils autotools
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="A traceroute-like utility that sends packets based on protocol"
+HOMEPAGE="http://traceproto.sourceforge.net/"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ncurses"
+
+RDEPEND=">=net-libs/libnet-1.1.0
+ net-libs/libpcap
+ ncurses? ( sys-libs/ncurses )
+ debug? ( dev-libs/dmalloc )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug dmalloc) \
+ $(use_enable ncurses) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}