summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-08 01:41:16 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-08 01:41:16 +0000
commit0c8efda5e9c7db00f86bee043aa49511d9a5912e (patch)
treeb523629477093042a20be63f25194d3d86475129 /net-analyzer
parentfixes bgo#486746 (diff)
downloadgentoo-2-0c8efda5e9c7db00f86bee043aa49511d9a5912e.tar.gz
gentoo-2-0c8efda5e9c7db00f86bee043aa49511d9a5912e.tar.bz2
gentoo-2-0c8efda5e9c7db00f86bee043aa49511d9a5912e.zip
Version bump (bug #503792).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog10
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.10.6-gtk-deprecated-warnings.patch25
-rw-r--r--net-analyzer/wireshark/wireshark-1.10.6.ebuild226
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.13.ebuild216
4 files changed, 476 insertions, 1 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index f51eca28f173..afec3eeedea1 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.589 2014/03/01 22:26:46 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.590 2014/03/08 01:41:16 jer Exp $
+
+*wireshark-1.10.6 (08 Mar 2014)
+*wireshark-1.8.13 (08 Mar 2014)
+
+ 08 Mar 2014; Jeroen Roovers <jer@gentoo.org> +wireshark-1.8.13.ebuild,
+ +wireshark-1.10.6.ebuild,
+ +files/wireshark-1.10.6-gtk-deprecated-warnings.patch:
+ Version bump (bug #503792).
01 Mar 2014; Michał Górny <mgorny@gentoo.org> wireshark-1.10.5.ebuild,
wireshark-1.8.12.ebuild:
diff --git a/net-analyzer/wireshark/files/wireshark-1.10.6-gtk-deprecated-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.10.6-gtk-deprecated-warnings.patch
new file mode 100644
index 000000000000..728a6f44bfc7
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.10.6-gtk-deprecated-warnings.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1387,22 +1387,6 @@
+ wireshark_SUBDIRS="codecs ui/gtk"
+ # Don't use GLIB_CFLAGS
+ AM_PATH_GLIB_2_0($GLIB_MIN_VERSION, , AC_MSG_ERROR(GLib $GLIB_MIN_VERSION or later distribution not found.), gthread gmodule)
+-
+- CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
+- CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
+- if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
+- ## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
+- ## The deprecations in Gtk 3.10 will not be fixed ...
+- CPPFLAGS="-DGDK_DISABLE_DEPRECATION_WARNINGS $CPPFLAGS"
+- else
+- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
+- fi
+- CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
+- if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
+- # Enable GSEAL when building with GTK > 2.20
+- # (Versions prior to 2.22 lacked some necessary accessors.)
+- CPPFLAGS="-DGSEAL_ENABLE $CPPFLAGS"
+- fi
+ fi
+
+ #
diff --git a/net-analyzer/wireshark/wireshark-1.10.6.ebuild b/net-analyzer/wireshark/wireshark-1.10.6.ebuild
new file mode 100644
index 000000000000..d12e211d1fce
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-1.10.6.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.10.6.ebuild,v 1.1 2014/03/08 01:41:16 jer Exp $
+
+EAPI=5
+inherit autotools eutils fcaps user
+
+[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+SRC_URI="http://www.wireshark.org/download/src/all-versions/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="
+ adns +caps crypt doc doc-pdf geoip +gtk2 gtk3 ipv6 kerberos libadns lua
+ +netlink +pcap portaudio qt4 selinux smi ssl zlib
+"
+REQUIRED_USE="
+ ?? ( gtk2 gtk3 qt4 )
+ ssl? ( crypt )
+"
+
+GTK_COMMON_DEPEND="
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ netlink? ( dev-libs/libnl )
+ adns? ( !libadns? ( >=net-dns/c-ares-1.5 ) )
+ crypt? ( dev-libs/libgcrypt:0= )
+ caps? ( sys-libs/libcap )
+ geoip? ( dev-libs/geoip )
+ gtk2? (
+ ${GTK_COMMON_DEPEND}
+ >=x11-libs/gtk+-2.4.0:2
+ )
+ gtk3? (
+ ${GTK_COMMON_DEPEND}
+ x11-libs/gtk+:3
+ )
+ kerberos? ( virtual/krb5 )
+ libadns? ( net-libs/adns )
+ lua? ( >=dev-lang/lua-5.1 )
+ pcap? ( net-libs/libpcap[-netlink] )
+ portaudio? ( media-libs/portaudio )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-misc/xdg-utils
+ )
+ selinux? ( sec-policy/selinux-wireshark )
+ smi? ( net-libs/libsmi )
+ ssl? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ app-text/asciidoc
+ dev-libs/libxml2
+ dev-libs/libxslt
+ doc-pdf? ( dev-java/fop )
+ www-client/lynx
+ )
+ >=virtual/perl-Pod-Simple-3.170.0
+ sys-devel/bison
+ sys-devel/flex
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
+ "${FILESDIR}"/${PN}-1.10.1-oldlibs.patch \
+ "${FILESDIR}"/${PN}-1.10.6-gtk-deprecated-warnings.patch
+
+ sed -i -e 's|SvnVersion|GitVersion|g' docbook/*.xml || die
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use adns; then
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --with-c-ares" )
+ fi
+ else
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --without-c-ares" )
+ fi
+ fi
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case $(krb5-config --libs) in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Enable wireshark binary with any supported GUI toolkit (bug #473188)
+ if use gtk2 || use gtk3 || use qt4 ; then
+ myconf+=( "--enable-wireshark" )
+ else
+ myconf+=( "--disable-wireshark" )
+ fi
+
+ # Hack around inability to disable doxygen/fop doc generation
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+ use doc-pdf || export ac_cv_prog_HAVE_FOP=false
+
+ # dumpcap requires libcap, setuid-install requires dumpcap
+ # --disable-profile-build bugs #215806, #292991, #479602
+ econf \
+ $(use pcap && use_enable !caps setuid-install) \
+ $(use pcap && use_enable caps setcap-install) \
+ $(use_enable ipv6) \
+ $(use_with caps libcap) \
+ $(use_with crypt gcrypt) \
+ $(use_with geoip) \
+ $(use_with kerberos krb5) \
+ $(use_with lua) \
+ $(use_with netlink libnl) \
+ $(use_with pcap dumpcap-group wireshark) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(use_with qt4 qt) \
+ $(use_with smi libsmi) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ $(usex gtk3 --with-gtk3=yes --with-gtk3=no) \
+ --disable-extra-gcc-checks \
+ --disable-profile-build \
+ --disable-usr-local \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake -j1 -C docbook
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
+ if use doc-pdf; then
+ insinto /usr/share/doc/${PF}/pdf/
+ doins docbook/{{developer,user}-guide,release-notes}-{a4,us}.pdf
+ fi
+ fi
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
+ doc/{randpkt.txt,README*}
+
+ # install headers
+ local wsheader
+ for wsheader in $( echo $(< debian/wireshark-dev.header-files ) ); do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk2 || use gtk3 || use qt4; then
+ local c d
+ for c in hi lo; do
+ for d in 16 32 48; do
+ insinto /usr/share/icons/${c}color/${d}x${d}/apps
+ newins image/${c}${d}-app-wireshark.png wireshark.png
+ done
+ done
+ domenu wireshark.desktop
+ fi
+
+ use pcap && chmod o-x "${ED}"/usr/bin/dumpcap #357237
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use pcap; then
+ fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To run wireshark as normal user you have to add yourself to"
+ ewarn "the wireshark group. This security measure ensures that only trusted"
+ ewarn "users are allowed to sniff your traffic."
+}
diff --git a/net-analyzer/wireshark/wireshark-1.8.13.ebuild b/net-analyzer/wireshark/wireshark-1.8.13.ebuild
new file mode 100644
index 000000000000..cf429fbc94fa
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-1.8.13.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.13.ebuild,v 1.1 2014/03/08 01:41:16 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit autotools eutils fcaps flag-o-matic python-single-r1 user
+
+[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+SRC_URI="http://www.wireshark.org/download/src/all-versions/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="
+ adns +caps crypt doc doc-pdf geoip gtk ipv6 kerberos libadns lua +pcap
+ portaudio python selinux smi ssl zlib
+"
+REQUIRED_USE="
+ ssl? ( crypt )
+"
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ adns? ( !libadns? ( >=net-dns/c-ares-1.5 ) )
+ caps? ( sys-libs/libcap )
+ crypt? ( dev-libs/libgcrypt:0= )
+ geoip? ( dev-libs/geoip )
+ gtk? (
+ >=x11-libs/gtk+-2.4.0:2
+ dev-libs/atk
+ x11-libs/pango
+ x11-misc/xdg-utils
+ )
+ kerberos? ( virtual/krb5 )
+ libadns? ( net-libs/adns )
+ lua? ( <dev-lang/lua-5.2 )
+ pcap? ( net-libs/libpcap )
+ portaudio? ( media-libs/portaudio )
+ python? ( ${PYTHON_DEPS} )
+ selinux? ( sec-policy/selinux-wireshark )
+ smi? ( net-libs/libsmi )
+ ssl? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxml2
+ dev-libs/libxslt
+ doc-pdf? ( dev-java/fop )
+ )
+ >=virtual/perl-Pod-Simple-3.170.0
+ sys-devel/bison
+ sys-devel/flex
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if ! use gtk; then
+ ewarn "USE=-gtk disables gtk-based gui called wireshark."
+ ewarn "Only command line utils will be built available"
+ fi
+
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
+ "${FILESDIR}"/${PN}-1.8.12-gtk-deprecated-warnings.patch
+
+ sed -i -e '/^Icon/s|.png||g' ${PN}.desktop || die
+
+ sed -i -e 's|SvnVersion|GitVersion|g' docbook/*.xml || die
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use adns; then
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --with-c-ares" )
+ fi
+ else
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --without-c-ares" )
+ fi
+ fi
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case `krb5-config --libs` in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Hack around inability to disable doxygen/fop doc generation
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+ use doc-pdf || export ac_cv_prog_HAVE_FOP=false
+
+ # dumpcap requires libcap, setuid-install requires dumpcap
+ # --disable-profile-build bugs #215806, #292991, #479602
+ econf \
+ $(use pcap && use_enable !caps setuid-install) \
+ $(use pcap && use_enable caps setcap-install) \
+ $(use_enable gtk wireshark) \
+ $(use_enable ipv6) \
+ $(use_with crypt gcrypt) \
+ $(use_with caps libcap) \
+ $(use_with geoip) \
+ $(use_with kerberos krb5) \
+ $(use_with lua) \
+ $(use_with pcap dumpcap-group wireshark) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(use_with python) \
+ $(use_with smi libsmi) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ --disable-extra-gcc-checks \
+ --disable-profile-build \
+ --disable-usr-local \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake -j1 -C docbook
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
+ if use doc-pdf; then
+ insinto /usr/share/doc/${PF}/pdf/
+ doins docbook/{{developer,user}-guide,release-notes}-{a4,us}.pdf
+ fi
+ fi
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
+ doc/{randpkt.txt,README*}
+
+ # install headers
+ local wsheader
+ for wsheader in $( echo $(< debian/wireshark-dev.header-files ) ); do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk; then
+ for c in hi lo; do
+ for d in 16 32 48; do
+ insinto /usr/share/icons/${c}color/${d}x${d}/apps
+ newins image/${c}${d}-app-wireshark.png wireshark.png
+ done
+ done
+ domenu wireshark.desktop
+ fi
+
+ use pcap && chmod o-x "${ED}"/usr/bin/dumpcap #357237
+
+ if use python; then
+ python_optimize "${ED}"/usr/lib*/wireshark/python
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use pcap; then
+ fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To run wireshark as normal user you have to add yourself to"
+ ewarn "the wireshark group. This security measure ensures that only trusted"
+ ewarn "users are allowed to sniff your traffic."
+}