summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-06-07 16:42:54 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-06-07 16:42:54 +0000
commit0d93fcfb88fc6d12abb8b40d925aa0ce22de0989 (patch)
tree13909a7314e8d56867e5b7957e58d004994fd12e /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-0d93fcfb88fc6d12abb8b40d925aa0ce22de0989.tar.gz
gentoo-2-0d93fcfb88fc6d12abb8b40d925aa0ce22de0989.tar.bz2
gentoo-2-0d93fcfb88fc6d12abb8b40d925aa0ce22de0989.zip
1.2.6 version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-1.2.6.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 9df6af43da23..6df4d0cf71a9 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.42 2008/02/05 10:54:20 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.43 2008/06/07 16:42:54 vanquirius Exp $
+
+*httping-1.2.6 (07 Jun 2008)
+
+ 07 Jun 2008; Marcelo Goes <vanquirius@gentoo.org> +httping-1.2.6.ebuild:
+ 1.2.6 version bump.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> httping-1.2.4.ebuild:
Stable on ppc64
diff --git a/net-analyzer/httping/httping-1.2.6.ebuild b/net-analyzer/httping/httping-1.2.6.ebuild
new file mode 100644
index 000000000000..fbd5c3c8cece
--- /dev/null
+++ b/net-analyzer/httping/httping-1.2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.6.ebuild,v 1.1 2008/06/07 16:42:54 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local makefile
+ use ssl || makefile="-f Makefile.nossl"
+ emake CC="$(tc-getCC)" ${makefile} || die "emake failed"
+}
+
+src_install() {
+ dobin httping || die "dobin failed"
+ doman httping.1 || die "doman failed"
+ dodoc readme.txt || die "dodoc failed"
+}