summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2014-10-18 13:58:39 +0000
committerAgostino Sarubbo <ago@gentoo.org>2014-10-18 13:58:39 +0000
commit14324e942e998194586fde06c1e32d8a179d5c23 (patch)
tree20dfef15b02bbce74c7880fe5123d4db51844386 /net-analyzer
parentStable for x86, wrt bug #525474 (diff)
downloadgentoo-2-14324e942e998194586fde06c1e32d8a179d5c23.tar.gz
gentoo-2-14324e942e998194586fde06c1e32d8a179d5c23.tar.bz2
gentoo-2-14324e942e998194586fde06c1e32d8a179d5c23.zip
Version bump to 0.8.1 wrt bug #525580
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ChangeLog7
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index 0604d9e5bf02..3b1922351a0e 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.151 2014/02/23 16:19:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.152 2014/10/18 13:58:39 ago Exp $
+
+*ettercap-0.8.1 (18 Oct 2014)
+
+ 18 Oct 2014; Agostino Sarubbo <ago@gentoo.org> +ettercap-0.8.1.ebuild:
+ Version bump to 0.8.1 wrt bug #525580
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org> ettercap-0.8.0-r1.ebuild:
Fix compilation on ppc, thanks to upstream author Gianfranco Costamagna, wrt
diff --git a/net-analyzer/ettercap/ettercap-0.8.1.ebuild b/net-analyzer/ettercap/ettercap-0.8.1.ebuild
new file mode 100644
index 000000000000..03976c665bf5
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-0.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.8.1.ebuild,v 1.1 2014/10/18 13:58:39 ago Exp $
+
+EAPI=5
+
+CMAKE_MIN_VERSION=2.8
+
+inherit cmake-utils
+
+DESCRIPTION="A suite for man in the middle attacks"
+HOMEPAGE="https://github.com/Ettercap/ettercap"
+SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" #mirror does not work
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ipv6 ncurses +plugins"
+
+RDEPEND="dev-libs/libpcre
+ dev-libs/openssl
+ net-libs/libnet:1.1
+ >=net-libs/libpcap-0.8.1
+ sys-libs/zlib
+ gtk? (
+ >=dev-libs/atk-1.2.4
+ >=dev-libs/glib-2.2.2:2
+ media-libs/freetype
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.2.2:2
+ >=x11-libs/pango-1.2.3
+ )
+ ncurses? ( >=sys-libs/ncurses-5.3 )
+ plugins? (
+ >=net-misc/curl-7.26.0
+ sys-devel/libtool
+ )"
+
+DEPEND="${RDEPEND}
+ app-text/ghostscript-gpl
+ sys-devel/flex
+ virtual/yacc"
+
+src_prepare() {
+ sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable ncurses CURSES)
+ $(cmake-utils_use_enable gtk)
+ $(cmake-utils_use_enable plugins)
+ $(cmake-utils_use_enable ipv6)
+ -DENABLE_SSL=ON
+ -DINSTALL_SYSCONFDIR="${EROOT}"etc
+ )
+ cmake-utils_src_configure
+}