summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-17 19:41:25 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-17 19:41:25 +0000
commit247bb4e28666bc63ebc4e809c3c6d8c3461f5bf2 (patch)
tree89a88afee667a84581a428a286b52d6cd13d4d1d /net-analyzer
parentstable on sparc, bug #226639 (diff)
downloadgentoo-2-247bb4e28666bc63ebc4e809c3c6d8c3461f5bf2.tar.gz
gentoo-2-247bb4e28666bc63ebc4e809c3c6d8c3461f5bf2.tar.bz2
gentoo-2-247bb4e28666bc63ebc4e809c3c6d8c3461f5bf2.zip
rrdtool bump
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog7
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.2.15-mem-usage.patch133
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.2.15-no-man.patch26
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.15-r3.ebuild125
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.3.0.ebuild86
5 files changed, 92 insertions, 285 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 4aaa13a2f823..e6d3e5fde919 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.143 2008/05/12 15:57:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.144 2008/06/17 19:41:25 hanno Exp $
+
+*rrdtool-1.3.0 (17 Jun 2008)
+
+ 17 Jun 2008; Hanno Boeck <hanno@gentoo.org> +rrdtool-1.3.0.ebuild:
+ Version bump, ebuild submitted by Fabian Fingerle.
12 May 2008; Markus Rothe <corsair@gentoo.org> rrdtool-1.2.27-r1.ebuild:
Stable on ppc64
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.2.15-mem-usage.patch b/net-analyzer/rrdtool/files/rrdtool-1.2.15-mem-usage.patch
deleted file mode 100644
index e6f2f7d3761f..000000000000
--- a/net-analyzer/rrdtool/files/rrdtool-1.2.15-mem-usage.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-diff -ru rrdtool-1.2.15~/src/rrd_graph.c rrdtool-1.2.15/src/rrd_graph.c
---- rrdtool-1.2.15~/src/rrd_graph.c 2007-01-09 23:40:14.000000000 +0100
-+++ rrdtool-1.2.15/src/rrd_graph.c 2007-01-09 23:48:03.000000000 +0100
-@@ -1060,8 +1060,9 @@
- ** relevant for min and max
- */
- if (finite(paintval) && im->gdes[ii].gf != GF_TICK ) {
-- if (isnan(minval) || paintval < minval)
-- minval = paintval;
-+ if ((isnan(minval) || paintval < minval ) &&
-+ ! (im->logarithmic && paintval <= 0.0))
-+ minval = paintval;
- if (isnan(maxval) || paintval > maxval)
- maxval = paintval;
- }
-@@ -1710,6 +1711,35 @@
- return mnt;
- }
-
-+static int AlmostEqual2sComplement (float A, float B, int maxUlps)
-+{
-+
-+ int aInt = *(int*)&A;
-+ int bInt = *(int*)&B;
-+ int intDiff;
-+ /* Make sure maxUlps is non-negative and small enough that the
-+ default NAN won't compare as equal to anything. */
-+
-+ /* assert(maxUlps > 0 && maxUlps < 4 * 1024 * 1024); */
-+
-+ /* Make aInt lexicographically ordered as a twos-complement int */
-+
-+ if (aInt < 0)
-+ aInt = 0x80000000l - aInt;
-+
-+ /* Make bInt lexicographically ordered as a twos-complement int */
-+
-+ if (bInt < 0)
-+ bInt = 0x80000000l - bInt;
-+
-+ intDiff = abs(aInt - bInt);
-+
-+ if (intDiff <= maxUlps)
-+ return 1;
-+
-+ return 0;
-+}
-+
- /* logaritmic horizontal grid */
- int
- horizontal_log_grid(image_desc_t *im)
-@@ -1719,7 +1749,9 @@
- {1.0, 5.0, 10., 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0},
- {1.0, 2.0, 5.0, 7.0, 10., 0.0, 0.0, 0.0, 0.0, 0.0},
- {1.0, 2.0, 4.0, 6.0, 8.0, 10., 0.0, 0.0, 0.0, 0.0},
-- {1.0, 2.0, 3.0, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.}};
-+ {1.0, 2.0, 3.0, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.},
-+ {0,0,0,0,0, 0,0,0,0,0} /* last line */ };
-+
-
- int i, j, val_exp, min_exp;
- double nex; /* number of decades in data */
-@@ -1728,7 +1760,7 @@
- int mid = -1; /* row in yloglab for major grid */
- double mspac; /* smallest major grid spacing (pixels) */
- int flab; /* first value in yloglab to use */
-- double value, tmp;
-+ double value, tmp, pre_value;
- double X0,X1,Y0;
- char graph_label[100];
-
-@@ -1747,11 +1779,11 @@
- mid++;
- for(i = 0; yloglab[mid][i + 1] < 10.0; i++);
- mspac = logscale * log10(10.0 / yloglab[mid][i]);
-- } while(mspac > 2 * im->text_prop[TEXT_PROP_LEGEND].size && mid < 5);
-+ } while(mspac > 2 * im->text_prop[TEXT_PROP_LEGEND].size && yloglab[mid][0] > 0);
- if(mid) mid--;
-
- /* find first value in yloglab */
-- for(flab = 0; frexp10(im->minval, &tmp) > yloglab[mid][flab]; flab++);
-+ for(flab = 0; yloglab[mid][flab] < 10 && frexp10(im->minval, &tmp) > yloglab[mid][flab] ; flab++);
- if(yloglab[mid][flab] == 10.0) {
- tmp += 1.0;
- flab = 0;
-@@ -1763,8 +1795,12 @@
- X1=im->xorigin+im->xsize;
-
- /* draw grid */
-+ pre_value = DNAN;
- while(1) {
- value = yloglab[mid][flab] * pow(10.0, val_exp);
-+ if ( AlmostEqual2sComplement(value,pre_value,4) ) break; /* it seems we are not converging */
-+
-+ pre_value = value;
-
- Y0 = ytr(im, value);
- if(Y0 <= im->yorigin - im->ysize) break;
-@@ -2484,34 +2520,6 @@
- /* yes we are loosing precision by doing tos with floats instead of doubles
- but it seems more stable this way. */
-
--static int AlmostEqual2sComplement (float A, float B, int maxUlps)
--{
--
-- int aInt = *(int*)&A;
-- int bInt = *(int*)&B;
-- int intDiff;
-- /* Make sure maxUlps is non-negative and small enough that the
-- default NAN won't compare as equal to anything. */
--
-- /* assert(maxUlps > 0 && maxUlps < 4 * 1024 * 1024); */
--
-- /* Make aInt lexicographically ordered as a twos-complement int */
--
-- if (aInt < 0)
-- aInt = 0x80000000l - aInt;
--
-- /* Make bInt lexicographically ordered as a twos-complement int */
--
-- if (bInt < 0)
-- bInt = 0x80000000l - bInt;
--
-- intDiff = abs(aInt - bInt);
--
-- if (intDiff <= maxUlps)
-- return 1;
--
-- return 0;
--}
-
- /* draw that picture thing ... */
- int
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.2.15-no-man.patch b/net-analyzer/rrdtool/files/rrdtool-1.2.15-no-man.patch
deleted file mode 100644
index 73b0761f1cb7..000000000000
--- a/net-analyzer/rrdtool/files/rrdtool-1.2.15-no-man.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: rrdtool-1.2.15/Makefile.am
-===================================================================
---- rrdtool-1.2.15.orig/Makefile.am
-+++ rrdtool-1.2.15/Makefile.am
-@@ -2,7 +2,7 @@
- RSYNC = rsync --rsh=ssh
-
- # build the following subdirectories
--SUBDIRS = src bindings doc examples
-+SUBDIRS = src bindings examples
-
- # the following files are not mentioned in any other Makefile
- EXTRA_DIST = COPYRIGHT CHANGES NT-BUILD-TIPS.txt TODO CONTRIBUTORS THREADS \
-Index: rrdtool-1.2.15/Makefile.in
-===================================================================
---- rrdtool-1.2.15.orig/Makefile.in
-+++ rrdtool-1.2.15/Makefile.in
-@@ -227,7 +227,7 @@ target_vendor = @target_vendor@
- RSYNC = rsync --rsh=ssh
-
- # build the following subdirectories
--SUBDIRS = src bindings doc examples
-+SUBDIRS = src bindings examples
- EXTRA_DIST = COPYRIGHT CHANGES NT-BUILD-TIPS.txt TODO CONTRIBUTORS THREADS \
- rrdtool.spec confignt/config.h favicon.ico
-
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.15-r3.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.15-r3.ebuild
deleted file mode 100644
index 7dba009afd76..000000000000
--- a/net-analyzer/rrdtool/rrdtool-1.2.15-r3.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.15-r3.ebuild,v 1.10 2008/03/23 13:03:58 pva Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit perl-module flag-o-matic eutils multilib autotools
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
-SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/${PN}/pub/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
-IUSE="doc perl python rrdcgi tcl uclibc"
-
-RDEPEND="tcl? ( dev-lang/tcl )
- >=sys-libs/zlib-1.2.1
- >=media-libs/freetype-2.1.5
- >=media-libs/libart_lgpl-2.3.16
- >=media-libs/libpng-1.2.5
- rrdcgi? ( >=dev-libs/cgilib-0.5 )"
-
-DEPEND="${RDEPEND}
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- sys-apps/gawk"
-
-TCLVER=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's:<rrd_\(.*\)>:"../../src/rrd_\1":g' \
- bindings/tcl/tclrrd.c || die "sed failed"
- sed -i -e 's:-lrrd_private:-ltcl -lrrd:' \
- bindings/tcl/Makefile.* || die "sed failed"
- sed -i -e 's:python_PROGRAMS:pyexec_PROGRAMS:' \
- bindings/python/Makefile.* || die "sed failed"
- sed -i -e 's:\$TCL_PACKAGE_PATH:${TCL_PACKAGE_PATH%% *}:' \
- configure.ac
- epatch "${FILESDIR}"/${P}-newstyle-resize.patch
- use uclibc && epatch "${FILESDIR}"/${P}-no-man.patch
- epatch "${FILESDIR}"/${P}-mem-usage.patch
- eautoreconf
-}
-
-pkg_setup() {
- use perl && perl-module_pkg_setup
-}
-
-src_compile() {
- filter-mfpmath sse
- filter-flags -ffast-math
-
- local myconf
- myconf="--datadir=/usr/share --enable-shared"
-
- if use tcl ; then
- myconf="${myconf} --with-tcllib=/usr/$(get_libdir)"
- else
- myconf="${myconf} --disable-tcl"
- fi
-
- use python || myconf="${myconf} --disable-python"
-
- if use perl ; then
- econf ${myconf} \
- $(use_enable rrdcgi) \
- --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || \
- die "econf failed"
- else
- econf ${myconf} \
- $(use_enable rrdcgi) \
- --disable-perl || die "econf failed"
- fi
-
- make || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- rm -fr "${D}"/usr/examples
- rm -fr "${D}"/usr/shared
-
- if use doc ; then
- dohtml doc/*.html
- dodoc doc/*.pod
- dodoc doc/*.txt
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- insinto /usr/share/doc/${PF}/contrib
- doins contrib/*
- fi
-
- if use perl ; then
- perlinfo
- mytargets="site-perl-install"
- perl-module_src_install || die
-
- # remove duplicate installation into /usr/lib/perl
- rm -Rf "${D}"/usr/lib/perl
- fi
-
- dodoc CONTRIBUTORS README TODO
-}
-
-pkg_preinst() {
- use perl && perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- use perl && perl-module_pkg_postinst
-}
-
-pkg_prerm() {
- use perl && perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- use perl && perl-module_pkg_postrm
-}
diff --git a/net-analyzer/rrdtool/rrdtool-1.3.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.3.0.ebuild
new file mode 100644
index 000000000000..7803205c6759
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.3.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.3.0.ebuild,v 1.1 2008/06/17 19:41:25 hanno Exp $
+
+inherit flag-o-matic multilib perl-module
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc perl python ruby rrdcgi tcl"
+
+RDEPEND="tcl? ( dev-lang/tcl )
+ >=sys-libs/zlib-1.2.1
+ >=media-libs/freetype-2.1.5
+ >=media-libs/libpng-1.2.5
+ rrdcgi? ( >=dev-libs/cgilib-0.5 )
+ ruby? ( !dev-ruby/ruby-rrd )
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby )
+ sys-apps/gawk"
+TCLVER=""
+
+HTMLDOC_DIR="${PF}/html"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo svg; then
+ eerror "This package requires x11-libs/cairo compiled with svn support."
+ die "Please reemerge x11-libs/cairo with USE=\"svg\"."
+ fi
+ use perl && perl-module_pkg_setup
+}
+
+src_compile() {
+ filter-mfpmath sse
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=/usr/share/doc/${PF}
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib /usr/$(get_libdir)) \
+ $(use_enable python) || die "econf failed."
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/{html,txt}
+ fi
+
+ use tcl && dosym tclrrd${PV}.so /usr/lib/tclrrd.so
+ use perl && fixlocalpod
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_preinst() {
+ use perl && perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}