summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-13 20:13:39 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-13 20:13:39 +0000
commit393819cd7db434213f75dfc619cb600b449467a6 (patch)
tree64e527b53f07b8a1a705d981dbb3d7ad70f249d2 /net-analyzer
parentAdd 2.6.26-r2, remove 2.6.26. (diff)
downloadgentoo-2-393819cd7db434213f75dfc619cb600b449467a6.tar.gz
gentoo-2-393819cd7db434213f75dfc619cb600b449467a6.tar.bz2
gentoo-2-393819cd7db434213f75dfc619cb600b449467a6.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/nmap-4.76.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 6186857f6fa3..ad9a87ef6294 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.185 2008/09/10 19:43:46 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.186 2008/09/13 20:13:39 spock Exp $
+
+*nmap-4.76 (13 Sep 2008)
+
+ 13 Sep 2008; Michał Januszewski <spock@gentoo.org> +nmap-4.76.ebuild:
+ Version bump.
10 Sep 2008; Michał Januszewski <spock@gentoo.org> -nmap-4.62.ebuild,
-nmap-4.65.ebuild:
diff --git a/net-analyzer/nmap/nmap-4.76.ebuild b/net-analyzer/nmap/nmap-4.76.ebuild
new file mode 100644
index 000000000000..d2b1928b8912
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.76.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.76.ebuild,v 1.1 2008/09/13 20:13:39 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-4.75-include.patch"
+ epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
+}
+
+src_compile() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version ">=dev-lang/lua-5.1.3-r1" &&
+ built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf \
+ --with-libdnet=included \
+ "${myconf}" \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake || die
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}