summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2002-06-21 00:37:38 +0000
committerPhil Bordelon <sunflare@gentoo.org>2002-06-21 00:37:38 +0000
commit517489e6c98e19f5f2926f2bca8241ef8240c256 (patch)
treeb6b298c4894344258729f4160b227a4543a4008d /net-analyzer
parentBumped the version of ethereal to 0.9.4. (diff)
downloadgentoo-2-517489e6c98e19f5f2926f2bca8241ef8240c256.tar.gz
gentoo-2-517489e6c98e19f5f2926f2bca8241ef8240c256.tar.bz2
gentoo-2-517489e6c98e19f5f2926f2bca8241ef8240c256.zip
Doing the ethereal-0.9.4 commit for real this time. Really.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.4.ebuild61
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.41
-rw-r--r--net-analyzer/ethereal/files/ethereal-0.9.4-gentoo.patch25
3 files changed, 87 insertions, 0 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.9.4.ebuild b/net-analyzer/ethereal/ethereal-0.9.4.ebuild
new file mode 100644
index 000000000000..8fdc3bb6aad2
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.9.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.3-r1.ebuild,v 1.2 2002/05/23 06:50:15 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A commercial-quality network protocol analyzer"
+SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
+HOMEPAGE="http://www.ethereal.com/"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ =dev-libs/glib-1.2*
+ snmp? ( >=net-analyzer/ucd-snmp-4.1.2 )
+ X? ( virtual/x11 =x11-libs/gtk+-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-devel/bison
+ sys-devel/flex
+ >=net-libs/libpcap-0.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch configure < ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="${myconf} --disable-ethereal"
+ use ssl || myconf="${myconf} --without-ssl"
+ use snmp || myconf="${myconf} --disable-snmp"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-pcap \
+ --enable-zlib \
+ --enable-ipv6 \
+ --includedir="" \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/ethereal \
+ --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/lib/ethereal/plugins/${PV}
+
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc/ethereal \
+ plugindir=${D}/usr/lib/ethereal/plugins/${PV} || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.4 b/net-analyzer/ethereal/files/digest-ethereal-0.9.4
new file mode 100644
index 000000000000..aacde0ec7056
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.9.4
@@ -0,0 +1 @@
+MD5 42e999daa659820ee93aaaa39ea1e9ea ethereal-0.9.4.tar.gz 3278908
diff --git a/net-analyzer/ethereal/files/ethereal-0.9.4-gentoo.patch b/net-analyzer/ethereal/files/ethereal-0.9.4-gentoo.patch
new file mode 100644
index 000000000000..4ebc35e44902
--- /dev/null
+++ b/net-analyzer/ethereal/files/ethereal-0.9.4-gentoo.patch
@@ -0,0 +1,25 @@
+--- configure Tue May 28 21:37:39 2002
++++ configure.new Tue May 28 21:39:23 2002
+@@ -3352,14 +3352,14 @@
+ echo $ac_n "checking for extraneous pcap header directories""... $ac_c" 1>&6
+ echo "configure:3354: checking for extraneous pcap header directories" >&5
+ found_pcap_dir=""
+- for pcap_dir in /usr/include/pcap /usr/local/include/pcap $prefix/include
+- do
+- if test -d $pcap_dir ; then
+- CFLAGS="$CFLAGS -I$pcap_dir"
+- CPPFLAGS="$CPPFLAGS -I$pcap_dir"
+- found_pcap_dir=" $found_pcap_dir -I$pcap_dir"
+- fi
+- done
++# for pcap_dir in /usr/include/pcap /usr/local/include/pcap $prefix/include
++# do
++# if test -d $pcap_dir ; then
++# CFLAGS="$CFLAGS -I$pcap_dir"
++# CPPFLAGS="$CPPFLAGS -I$pcap_dir"
++# found_pcap_dir=" $found_pcap_dir -I$pcap_dir"
++# fi
++# done
+
+ if test "$found_pcap_dir" != "" ; then
+ echo "$ac_t""found --$found_pcap_dir added to CFLAGS" 1>&6