summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-25 22:22:58 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-25 22:22:58 +0000
commit561e7add11d3322248784cff72593972716db25b (patch)
tree5f02032e20a704a54810814bca08a5d88ef20533 /net-analyzer
parentBug #292598: Update the vda patch for quota bug. (diff)
downloadgentoo-2-561e7add11d3322248784cff72593972716db25b.tar.gz
gentoo-2-561e7add11d3322248784cff72593972716db25b.tar.bz2
gentoo-2-561e7add11d3322248784cff72593972716db25b.zip
Remove IUSE=mmap. Add IUSE="threads ulog" thanks to Marcin Mirosław (bug #306641). Replace broken sed script with something that both respects CFLAGS and does not remove vital -DEFINES. Install UPGRADE doc.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/ChangeLog8
-rw-r--r--net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch20
-rw-r--r--net-analyzer/pmacct/metadata.xml5
-rw-r--r--net-analyzer/pmacct/pmacct-0.12.0.ebuild28
4 files changed, 47 insertions, 14 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index e24a8ac84664..21bff072ba38 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.62 2010/02/23 16:01:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.63 2010/02/25 22:22:57 jer Exp $
+
+ 25 Feb 2010; Jeroen Roovers <jer@gentoo.org> pmacct-0.12.0.ebuild,
+ +files/pmacct-0.12.0-gentoo.patch, metadata.xml:
+ Remove IUSE=mmap. Add IUSE="threads ulog" thanks to Marcin Mirosław (bug
+ #306641). Replace broken sed script with something that both respects
+ CFLAGS and does not remove vital -DEFINES. Install UPGRADE doc.
*pmacct-0.12.0 (23 Feb 2010)
diff --git a/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch b/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch
new file mode 100644
index 000000000000..a367d98ceb6a
--- /dev/null
+++ b/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch
@@ -0,0 +1,20 @@
+--- configure.org 2010-02-16 13:06:04.000000000 +0100
++++ configure 2010-02-25 22:57:08.000000000 +0100
+@@ -1103,7 +1103,7 @@
+ echo $ac_n "checking whether to enable debugging compiler options""... $ac_c" 1>&6
+ echo "configure:1105: checking whether to enable debugging compiler options" >&5
+ # Check whether --enable-debug or --disable-debug was given.
+-if test "${enable_debug+set}" = set; then
++if test "${enable_debug+set}" = TODO_THIS_WILL_NEVER_BE_TRUE; then
+ enableval="$enable_debug"
+ echo "$ac_t""yes" 1>&6
+ tmp_CFLAGS=`echo $CFLAGS | sed 's/O2/O0/g'`
+@@ -1114,7 +1114,7 @@
+ #CFLAGS="$CFLAGS -Wcast-align -Wcast-qual -Wnested-externs"
+ #CFLAGS="$CFLAGS -Wshadow -Wbad-function-cast -Wwrite-strings"
+ echo "$ac_t""no" 1>&6
+-
++ CFLAGS="$ac_save_CFLAGS"
+ fi
+
+
diff --git a/net-analyzer/pmacct/metadata.xml b/net-analyzer/pmacct/metadata.xml
index 11fd26cae895..14e80e44aab4 100644
--- a/net-analyzer/pmacct/metadata.xml
+++ b/net-analyzer/pmacct/metadata.xml
@@ -3,5 +3,8 @@
<pkgmetadata>
<herd>netmon</herd>
<longdescription>A network tool to gather ip traffic informations</longdescription>
-<use><flag name='64bit'>Use 64bit counters instead of 32bit ones</flag></use>
+<use>
+ <flag name='64bit'>Use 64bit counters instead of 32bit ones</flag>
+ <flag name='ulog'>Enable ULOG support</flag>
+</use>
</pkgmetadata>
diff --git a/net-analyzer/pmacct/pmacct-0.12.0.ebuild b/net-analyzer/pmacct/pmacct-0.12.0.ebuild
index 5380e1d65040..e77c3586dc8a 100644
--- a/net-analyzer/pmacct/pmacct-0.12.0.ebuild
+++ b/net-analyzer/pmacct/pmacct-0.12.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.12.0.ebuild,v 1.1 2010/02/23 16:01:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.12.0.ebuild,v 1.2 2010/02/25 22:22:57 jer Exp $
EAPI="2"
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="A network tool to gather ip traffic informations"
HOMEPAGE="http://www.pmacct.net/"
@@ -13,7 +13,7 @@ SRC_URI="http://www.pmacct.net/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="64bit debug ipv6 mmap mysql postgres sqlite"
+IUSE="64bit debug ipv6 mysql postgres sqlite threads ulog"
RDEPEND="net-libs/libpcap
mysql? ( virtual/mysql )
@@ -22,25 +22,29 @@ RDEPEND="net-libs/libpcap
DEPEND="${RDEPEND}"
src_prepare() {
- sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+ cp -av configure{,.org}
+ cp -av configure.in{,.org}
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_configure() {
tc-export CC
econf \
+ $(use_enable 64bit) \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
$(use_enable mysql) \
$(use_enable postgres pgsql) \
- $(use_enable mmap) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_enable 64bit) \
- $(use_enable sqlite sqlite3)
+ $(use_enable threads) \
+ $(use_enable ulog) \
+ || die "econf failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
- docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CONFIG-KEYS EXAMPLES FAQS KNOWN-BUGS README UPGRADE \
+ docs/SIGNALS docs/PLUGINS docs/INTERNALS TODO TOOLS \
+ || die "dodoc failed"
for dirname in examples sql; do
docinto ${dirname}