summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-07-01 04:23:33 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-07-01 04:23:33 +0000
commit57c959a4bb344eded260e456e23171133693fa5d (patch)
tree224e11b46ff416fc4deed5f354205021766ed72b /net-analyzer
parentremoved stray kdm-3.5.2-r1.ebuild.orig ended up in manifest. Thanks to Bread ... (diff)
downloadgentoo-2-57c959a4bb344eded260e456e23171133693fa5d.tar.gz
gentoo-2-57c959a4bb344eded260e456e23171133693fa5d.tar.bz2
gentoo-2-57c959a4bb344eded260e456e23171133693fa5d.zip
0.10.3 version bump for bug 137670. Thanks to Wolfram Schlich <wschlich at gentoo dot org>.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/ChangeLog9
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.10.22
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.10.33
-rw-r--r--net-analyzer/pmacct/pmacct-0.10.3.ebuild54
4 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index d327b55fb039..f837fdf3c6e9 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.41 2006/06/03 22:14:35 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.42 2006/07/01 04:23:33 vanquirius Exp $
+
+*pmacct-0.10.3 (01 Jul 2006)
+
+ 01 Jul 2006; Marcelo Goes <vanquirius@gentoo.org> -pmacct-0.10.1.ebuild,
+ +pmacct-0.10.3.ebuild:
+ 0.10.3 version bump for bug 137670. Thanks to Wolfram Schlich <wschlich at
+ gentoo dot org>.
*pmacct-0.10.2 (03 Jun 2006)
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.10.2 b/net-analyzer/pmacct/files/digest-pmacct-0.10.2
index 07c09887fbae..0ac5e28b2878 100644
--- a/net-analyzer/pmacct/files/digest-pmacct-0.10.2
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.10.2
@@ -1 +1,3 @@
MD5 8ddd4a4ce248efe162378c47a16f43e2 pmacct-0.10.2.tar.gz 345607
+RMD160 e112eaeee2312a475a3a4544f7dad6860aab6b60 pmacct-0.10.2.tar.gz 345607
+SHA256 2f703ab51df74a63ee93683d5cb16d3e0da34fe1174c6ebf7b9ba27d7db8f579 pmacct-0.10.2.tar.gz 345607
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.10.3 b/net-analyzer/pmacct/files/digest-pmacct-0.10.3
new file mode 100644
index 000000000000..dc830209483a
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.10.3
@@ -0,0 +1,3 @@
+MD5 0be1ffd9d4bda73575caa3240abbf4cb pmacct-0.10.3.tar.gz 351478
+RMD160 ededa1217453c0d4310db6979825a699577a6395 pmacct-0.10.3.tar.gz 351478
+SHA256 f4756d54e1192bc542602f14c600e64126dfda13a1d1f1948365f1d72a3c7042 pmacct-0.10.3.tar.gz 351478
diff --git a/net-analyzer/pmacct/pmacct-0.10.3.ebuild b/net-analyzer/pmacct/pmacct-0.10.3.ebuild
new file mode 100644
index 000000000000..84528a9c55e1
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.10.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.10.3.ebuild,v 1.1 2006/07/01 04:23:33 vanquirius Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}