summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-07-09 19:39:21 +0000
committerRick Farina <zerochaos@gentoo.org>2012-07-09 19:39:21 +0000
commit64cbb987212901d110c27ed826c5d9521dcde328 (patch)
tree87364dbfa379f580dcce70207c957651e7ed8aa5 /net-analyzer
parentpackage.use.mask changes related to the addition of USE=btbb to wireshark (diff)
downloadgentoo-2-64cbb987212901d110c27ed826c5d9521dcde328.tar.gz
gentoo-2-64cbb987212901d110c27ed826c5d9521dcde328.tar.bz2
gentoo-2-64cbb987212901d110c27ed826c5d9521dcde328.zip
add in support for third-party-plugins, starting with btbb
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/metadata.xml7
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.0.ebuild13
3 files changed, 22 insertions, 4 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 87af3a17a2b6..b2b3d2b311f4 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.357 2012/06/27 21:11:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.358 2012/07/09 19:39:21 zerochaos Exp $
+
+ 09 Jul 2012; Rick Farina <zerochaos@gentoo.org> metadata.xml,
+ wireshark-1.8.0.ebuild:
+ add in support for third-party-plugins, starting with btbb
27 Jun 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.0.ebuild,
files/wireshark-1.8.0-underlinking.patch:
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index d334ff256aaf..e20ab9e07086 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -6,6 +6,11 @@
<email>pva@gentoo.org</email>
<name>Peter Volkov</name>
</maintainer>
+<maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ <description>Excessive wireshark user and enthusiast</description>
+</maintainer>
<longdescription>
Wireshark is the world's foremost network protocol analyzer, and is the de
facto (and often de jure) standard across many industries and educational
@@ -30,9 +35,11 @@
</longdescription>
<use>
<flag name='ares'>Use GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
+<flag name='btbb'>Use <pkg>net-libs/libbtbb</pkg> (and appropriate hardware) to sniff bluetooth baseband</flag>
<flag name='doc-pdf'>Build documentation in pdf format (US and a4 paper sizes)</flag>
<flag name='gcrypt'>Use GNU crypto library (<pkg>dev-libs/libgcrypt</pkg>) to decrypt ipsec traffic</flag>
<flag name='pcap'>Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
<flag name='smi'>Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
+<flag name='third-party-plugins'>Build plugins from third party sources</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-1.8.0.ebuild b/net-analyzer/wireshark/wireshark-1.8.0.ebuild
index a85b443870c9..ad9b7e4c997e 100644
--- a/net-analyzer/wireshark/wireshark-1.8.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.0.ebuild,v 1.5 2012/06/27 21:11:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.0.ebuild,v 1.6 2012/07/09 19:39:21 zerochaos Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -14,8 +14,10 @@ SRC_URI="http://www.wireshark.org/download/src/all-versions/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="adns ares doc doc-pdf gtk ipv6 lua gcrypt geoip kerberos
-profile +pcap portaudio python +caps selinux smi ssl zlib"
+IUSE="adns ares btbb doc doc-pdf gtk ipv6 lua gcrypt geoip kerberos
+third-party-plugins profile +pcap portaudio python +caps selinux smi ssl zlib"
+
+REQUIRED_USE="btbb? ( third-party-plugins )"
RDEPEND=">=dev-libs/glib-2.14:2
zlib? ( sys-libs/zlib
@@ -35,6 +37,7 @@ RDEPEND=">=dev-libs/glib-2.14:2
!ares? ( adns? ( net-libs/adns ) )
geoip? ( dev-libs/geoip )
lua? ( >=dev-lang/lua-5.1 )
+ btbb? ( >=net-libs/libbtbb-0.8-r1 )
selinux? ( sec-policy/selinux-wireshark )"
DEPEND="${RDEPEND}
@@ -104,6 +107,10 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-underlinking.patch
+ if use btbb; then
+ cp -r "${EROOT}/usr/share/libbtbb/wireshark/." "${S}/" || die
+ epatch "${S}/plugins/btbb/wireshark-1.8-btbb.patch"
+ fi
eautoreconf
}