summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-24 15:01:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-24 15:01:19 +0000
commit6b216db8693b0579d66e13837f8f4decbe9020d5 (patch)
tree4069252801dfef3c092e592ad591f0fe39012731 /net-analyzer
parentAdded ebuild for cofoja, a framework for contract based classes. Dependency o... (diff)
downloadgentoo-2-6b216db8693b0579d66e13837f8f4decbe9020d5.tar.gz
gentoo-2-6b216db8693b0579d66e13837f8f4decbe9020d5.tar.bz2
gentoo-2-6b216db8693b0579d66e13837f8f4decbe9020d5.zip
Version bump. Bug #491854 thanks to Nikoli <nikoli@gmx.us>
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/goaccess/ChangeLog7
-rw-r--r--net-analyzer/goaccess/goaccess-0.6.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-analyzer/goaccess/ChangeLog b/net-analyzer/goaccess/ChangeLog
index e2e476fb7c5b..1f5344206ec5 100644
--- a/net-analyzer/goaccess/ChangeLog
+++ b/net-analyzer/goaccess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/goaccess
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/ChangeLog,v 1.5 2013/10/13 10:23:35 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/ChangeLog,v 1.6 2013/11/24 15:01:19 hwoarang Exp $
+
+*goaccess-0.6.1 (24 Nov 2013)
+
+ 24 Nov 2013; Markos Chandras <hwoarang@gentoo.org> +goaccess-0.6.1.ebuild:
+ Version bump. Bug #491854 thanks to Nikoli <nikoli@gmx.us>
13 Oct 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Updated Nikoli's e-mail address for easier automatic assignment.
diff --git a/net-analyzer/goaccess/goaccess-0.6.1.ebuild b/net-analyzer/goaccess/goaccess-0.6.1.ebuild
new file mode 100644
index 000000000000..3a36b14b7104
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/goaccess-0.6.1.ebuild,v 1.1 2013/11/24 15:01:18 hwoarang Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A real-time Apache log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.prosoftcorp.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="geoip unicode"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # respect CFLAGS, bug #451806
+ sed -i -e '/AM_CFLAGS/s/-g//' Makefile.am || die 'sed failed'
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # configure does not properly recognise '--disable-something'
+ local myeconfargs=(
+ $(usex geoip '--enable-geoip' '' '' '')
+ $(usex unicode '--enable-utf8' '' '' '')
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile CFLAGS="${CFLAGS}"
+}