summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-26 19:52:00 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-26 19:52:00 +0000
commit77feb33d99a521cbdcd2dd94d41259968790347b (patch)
tree8c6dcb78b65dff06353d917dd21dc905a83137d6 /net-analyzer
parentfix typo in error: could should be could not (diff)
downloadgentoo-2-77feb33d99a521cbdcd2dd94d41259968790347b.tar.gz
gentoo-2-77feb33d99a521cbdcd2dd94d41259968790347b.tar.bz2
gentoo-2-77feb33d99a521cbdcd2dd94d41259968790347b.zip
Split out the "nessus" ebuild to the individual nessues componets to allow pieces to build and install properly. "nessus" is still an installable ebuild, it just pulls in the individual components. nessus-libraries is the first of those components.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nessus-libraries/ChangeLog13
-rw-r--r--net-analyzer/nessus-libraries/files/digest-nessus-libraries-1.2.31
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-1.2.3.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/nessus-libraries/ChangeLog b/net-analyzer/nessus-libraries/ChangeLog
new file mode 100644
index 000000000000..1a9596f60f62
--- /dev/null
+++ b/net-analyzer/nessus-libraries/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-misc/nessus-libraries
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/ChangeLog,v 1.1 2002/07/26 19:52:00 raker Exp $
+
+*nessus-libraries-1.2.3 (26 Jul 2002)
+
+ 26 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ nessus-libraries-1.2.3.ebuild, files/digest-nessus-libraries-1.2.3 :
+
+ Split out the "nessus" ebuild to the individual nessues componets
+ to allow pieces to build and install properly. "nessus" is still
+ an installable ebuild, it just pulls in the individual components.
+ nessus-libraries is the first of those components.
diff --git a/net-analyzer/nessus-libraries/files/digest-nessus-libraries-1.2.3 b/net-analyzer/nessus-libraries/files/digest-nessus-libraries-1.2.3
new file mode 100644
index 000000000000..a43db1fa6f62
--- /dev/null
+++ b/net-analyzer/nessus-libraries/files/digest-nessus-libraries-1.2.3
@@ -0,0 +1 @@
+MD5 5330ad95523390c843615611a6aea9b9 nessus-libraries-1.2.3.tar.gz 411328
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-1.2.3.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-1.2.3.ebuild
new file mode 100644
index 000000000000..e5f1d378ac91
--- /dev/null
+++ b/net-analyzer/nessus-libraries/nessus-libraries-1.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2000-2002 Achim Gottinger
+# Distributed under the GPL by Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-1.2.3.ebuild,v 1.1 2002/07/26 19:52:00 raker Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
+HOMEPAGE="http://www.nessus.org/"
+
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-1.2.3/src/${P}.tar.gz"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+
+src_compile() {
+
+ use ssl && myconf="--with-ssl=/usr/lib" \
+ || myconf="--without-ssl"
+
+ econf \
+ ${myconf} || die "configure failed"
+
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/state \
+ mandir=${D}/usr/share/man \
+ install || die "make install failed"
+
+ cd ${S}
+ docinto nessus-libraries
+ dodoc README*
+
+}