summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-19 11:12:38 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-19 11:12:38 +0000
commit7bd0decce54d4b27472b953e201c0ce04c5d3481 (patch)
tree714c86d89064dd86c5c46c0c8f1863a2126518d0 /net-analyzer
parentfixed bug #437128 (diff)
downloadgentoo-2-7bd0decce54d4b27472b953e201c0ce04c5d3481.tar.gz
gentoo-2-7bd0decce54d4b27472b953e201c0ce04c5d3481.tar.bz2
gentoo-2-7bd0decce54d4b27472b953e201c0ce04c5d3481.zip
Fix --help segmentation fault by Behzat (bug #439390 comment #11).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog8
-rw-r--r--net-analyzer/httping/files/httping-1.5.5-help.patch20
-rw-r--r--net-analyzer/httping/httping-1.5.5-r1.ebuild43
3 files changed, 70 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 6e5c92fd8b4b..2b0e7bdb4572 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.86 2012/11/04 19:53:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.87 2012/11/19 11:12:37 jer Exp $
+
+*httping-1.5.5-r1 (19 Nov 2012)
+
+ 19 Nov 2012; Jeroen Roovers <jer@gentoo.org> +httping-1.5.5-r1.ebuild,
+ +files/httping-1.5.5-help.patch:
+ Fix --help segmentation fault by Behzat (bug #439390 comment #11).
04 Nov 2012; Agostino Sarubbo <ago@gentoo.org> httping-1.5.5.ebuild:
Stable for amd64, wrt bug #439390
diff --git a/net-analyzer/httping/files/httping-1.5.5-help.patch b/net-analyzer/httping/files/httping-1.5.5-help.patch
new file mode 100644
index 000000000000..4066f6fe922c
--- /dev/null
+++ b/net-analyzer/httping/files/httping-1.5.5-help.patch
@@ -0,0 +1,20 @@
+--- a/main.c
++++ b/main.c
+@@ -148,7 +148,7 @@
+ fprintf(stderr, "--persistent-connections -Q\n");
+ fprintf(stderr, "--no-cache -Z\n");
+ fprintf(stderr, "--version -V\n");
+- fprintf(stderr, "--help -h\n");
++ fprintf(stderr, "--help -H\n");
+ }
+
+ void emit_error()
+@@ -306,7 +306,7 @@
+ {"password", 1, NULL, 'P' },
+ {"cookie", 1, NULL, 'C' },
+ {"version", 0, NULL, 'V' },
+- {"help", 0, NULL, 'h' },
++ {"help", 0, NULL, 'H' },
+ {NULL, 0, NULL, 0 }
+ };
+
diff --git a/net-analyzer/httping/httping-1.5.5-r1.ebuild b/net-analyzer/httping/httping-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..6aa2fa88c92a
--- /dev/null
+++ b/net-analyzer/httping/httping-1.5.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.5-r1.ebuild,v 1.1 2012/11/19 11:12:38 jer Exp $
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.5-help.patch
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}