summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-03-27 19:47:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-03-27 19:47:42 +0000
commit9253c2ee3479731687fcc7177b838dfaa2df5df0 (patch)
tree999f5ad4250ef5a52d32fc18d4f9924520109214 /net-analyzer
parentbup (diff)
downloadgentoo-2-9253c2ee3479731687fcc7177b838dfaa2df5df0.tar.gz
gentoo-2-9253c2ee3479731687fcc7177b838dfaa2df5df0.tar.bz2
gentoo-2-9253c2ee3479731687fcc7177b838dfaa2df5df0.zip
bup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/ChangeLog9
-rw-r--r--net-analyzer/icinga2/icinga2-2.2.1-r2.ebuild155
-rw-r--r--net-analyzer/icinga2/icinga2-2.2.3-r1.ebuild153
-rw-r--r--net-analyzer/icinga2/icinga2-2.2.4.ebuild156
-rw-r--r--net-analyzer/icinga2/icinga2-2.3.2.ebuild157
-rw-r--r--net-analyzer/icinga2/icinga2-2.3.3.ebuild (renamed from net-analyzer/icinga2/icinga2-2.3.2-r1.ebuild)6
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild30
7 files changed, 26 insertions, 640 deletions
diff --git a/net-analyzer/icinga2/ChangeLog b/net-analyzer/icinga2/ChangeLog
index 3014bfb2bc61..d524990e1ec3 100644
--- a/net-analyzer/icinga2/ChangeLog
+++ b/net-analyzer/icinga2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/icinga2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.33 2015/03/25 18:53:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.34 2015/03/27 19:47:42 prometheanfire Exp $
+
+*icinga2-2.3.3 (27 Mar 2015)
+
+ 27 Mar 2015; Matthew Thode <prometheanfire@gentoo.org> +icinga2-2.3.3.ebuild,
+ -icinga2-2.2.1-r2.ebuild, -icinga2-2.2.3-r1.ebuild, -icinga2-2.2.4.ebuild,
+ -icinga2-2.3.2-r1.ebuild, -icinga2-2.3.2.ebuild, icinga2-9999.ebuild:
+ bup
*icinga2-2.3.2-r1 (25 Mar 2015)
diff --git a/net-analyzer/icinga2/icinga2-2.2.1-r2.ebuild b/net-analyzer/icinga2/icinga2-2.2.1-r2.ebuild
deleted file mode 100644
index 86534fac8d34..000000000000
--- a/net-analyzer/icinga2/icinga2-2.2.1-r2.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.2.1-r2.ebuild,v 1.3 2015/01/13 04:42:58 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-inherit depend.apache distutils-r1 eutils cmake-utils toolchain-funcs user versionator systemd
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-#PV=$(replace_version_separator 3 '-')
-SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-#S="${WORKDIR}/${PN}-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres classicui nano-syntax +plugins +vim-syntax"
-
-DEPEND="dev-util/cmake
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-libs/openssl
- >=dev-libs/boost-1.41
- sys-devel/bison
- >=sys-devel/flex-2.5.35
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
-
-RDEPEND="${DEPEND}
- plugins? ( net-analyzer/nagios-plugins )
- classicui? ( net-analyzer/icinga[web] )"
-
-REQUIRED_USE="|| ( mysql postgres )"
-
-want_apache2
-
-pkg_setup() {
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_prepare() {
-# epatch "${FILESDIR}/${P}-create_var_cache.patch"
- epatch_user
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- )
- if use postgres; then
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=OFF
- )
- fi
- if use mysql; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd $BUILDDIR
-
- #if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
-
- emake DESTDIR="${D}" install
- #fi
-
- cd "${WORKDIR}"/icinga2-${PV}
- if ! declare -p DOCS >/dev/null 2>&1 ; then
- local d
- for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
- FAQ CREDITS CHANGELOG ; do
- [[ -s "${d}" ]] && dodoc "${d}"
- done
- elif declare -p DOCS | grep -q "^declare -a " ; then
- dodoc "${DOCS[@]}"
- else
- dodoc ${DOCS}
- fi
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/upgrade/0.0.11.sql mysql-upgrade-1.12.0.sql
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/upgrade/0.0.11.sql pgsql-upgrade-1.12.0.sql
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}var/run" || die "failed to remove /var/run"
- rm -r "${D}var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r tools/syntax/vim/ftdetect
- doins -r tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
- elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
-}
diff --git a/net-analyzer/icinga2/icinga2-2.2.3-r1.ebuild b/net-analyzer/icinga2/icinga2-2.2.3-r1.ebuild
deleted file mode 100644
index 7b04319dce9e..000000000000
--- a/net-analyzer/icinga2/icinga2-2.2.3-r1.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.2.3-r1.ebuild,v 1.1 2015/01/29 05:51:25 prometheanfire Exp $
-
-EAPI=5
-inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-#PV=$(replace_version_separator 3 '-')
-SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-#S="${WORKDIR}/${PN}-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres classicui nano-syntax +plugins +vim-syntax"
-
-DEPEND="dev-util/cmake
- dev-libs/openssl
- >=dev-libs/boost-1.41
- sys-devel/bison
- >=sys-devel/flex-2.5.35
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
-
-RDEPEND="${DEPEND}
- plugins? ( net-analyzer/nagios-plugins )
- classicui? ( net-analyzer/icinga[web] )"
-
-REQUIRED_USE="|| ( mysql postgres )"
-
-want_apache2
-
-pkg_setup() {
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_prepare() {
-# epatch "${FILESDIR}/${P}-create_var_cache.patch"
- epatch_user
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- )
- if use postgres; then
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=OFF
- )
- fi
- if use mysql; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd $BUILDDIR
-
- #if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
-
- emake DESTDIR="${D}" install
- #fi
-
- cd "${WORKDIR}"/icinga2-${PV}
- if ! declare -p DOCS >/dev/null 2>&1 ; then
- local d
- for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
- FAQ CREDITS CHANGELOG ; do
- [[ -s "${d}" ]] && dodoc "${d}"
- done
- elif declare -p DOCS | grep -q "^declare -a " ; then
- dodoc "${DOCS[@]}"
- else
- dodoc ${DOCS}
- fi
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/upgrade/0.0.11.sql mysql-upgrade-1.12.0.sql
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/upgrade/0.0.11.sql pgsql-upgrade-1.12.0.sql
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}var/run" || die "failed to remove /var/run"
- rm -r "${D}var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r tools/syntax/vim/ftdetect
- doins -r tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
- elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
-}
diff --git a/net-analyzer/icinga2/icinga2-2.2.4.ebuild b/net-analyzer/icinga2/icinga2-2.2.4.ebuild
deleted file mode 100644
index bffdb4026921..000000000000
--- a/net-analyzer/icinga2/icinga2-2.2.4.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.2.4.ebuild,v 1.1 2015/03/03 19:22:46 prometheanfire Exp $
-
-EAPI=5
-inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-#PV=$(replace_version_separator 3 '-')
-SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-#S="${WORKDIR}/${PN}-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres classicui nano-syntax +plugins +vim-syntax"
-
-DEPEND="dev-util/cmake
- dev-libs/openssl
- >=dev-libs/boost-1.41
- sys-devel/bison
- >=sys-devel/flex-2.5.35
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
-
-RDEPEND="${DEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- classicui? ( net-analyzer/icinga[web] )"
-
-REQUIRED_USE="|| ( mysql postgres )"
-
-want_apache2
-
-pkg_setup() {
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_prepare() {
-# epatch "${FILESDIR}/${P}-create_var_cache.patch"
- epatch_user
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- )
- if use postgres; then
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=OFF
- )
- fi
- if use mysql; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd $BUILDDIR
-
- #if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
-
- emake DESTDIR="${D}" install
- #fi
-
- cd "${WORKDIR}"/icinga2-${PV}
- if ! declare -p DOCS >/dev/null 2>&1 ; then
- local d
- for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
- FAQ CREDITS CHANGELOG ; do
- [[ -s "${d}" ]] && dodoc "${d}"
- done
- elif declare -p DOCS | grep -q "^declare -a " ; then
- dodoc "${DOCS[@]}"
- else
- dodoc ${DOCS}
- fi
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/upgrade/0.0.11.sql mysql-upgrade-1.12.0.sql
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/upgrade/0.0.11.sql pgsql-upgrade-1.12.0.sql
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}var/run" || die "failed to remove /var/run"
- rm -r "${D}var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r tools/syntax/vim/ftdetect
- doins -r tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
- elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
-}
diff --git a/net-analyzer/icinga2/icinga2-2.3.2.ebuild b/net-analyzer/icinga2/icinga2-2.3.2.ebuild
deleted file mode 100644
index e792798068ec..000000000000
--- a/net-analyzer/icinga2/icinga2-2.3.2.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.3.2.ebuild,v 1.2 2015/03/13 21:09:51 prometheanfire Exp $
-
-EAPI=5
-inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-#PV=$(replace_version_separator 3 '-')
-SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-#S="${WORKDIR}/${PN}-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres classicui nano-syntax +plugins +vim-syntax"
-
-DEPEND="dev-util/cmake
- dev-libs/openssl
- >=dev-libs/boost-1.41
- sys-devel/bison
- >=sys-devel/flex-2.5.35
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
-
-RDEPEND="${DEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- classicui? ( net-analyzer/icinga[web] )"
-
-REQUIRED_USE="|| ( mysql postgres )"
-
-want_apache2
-
-pkg_setup() {
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_prepare() {
-# epatch "${FILESDIR}/${P}-create_var_cache.patch"
- epatch_user
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- )
- if use postgres; then
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=OFF
- )
- fi
- if use mysql; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd $BUILDDIR
-
- #if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
-
- emake DESTDIR="${D}" install
- #fi
-
- cd "${WORKDIR}"/icinga2-${PV}
- if ! declare -p DOCS >/dev/null 2>&1 ; then
- local d
- for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
- FAQ CREDITS CHANGELOG ; do
- [[ -s "${d}" ]] && dodoc "${d}"
- done
- elif declare -p DOCS | grep -q "^declare -a " ; then
- dodoc "${DOCS[@]}"
- else
- dodoc ${DOCS}
- fi
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/upgrade/0.0.11.sql mysql-upgrade-1.12.0.sql
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/upgrade/0.0.11.sql pgsql-upgrade-1.12.0.sql
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}var/run" || die "failed to remove /var/run"
- rm -r "${D}var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r tools/syntax/vim/ftdetect
- doins -r tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
- elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
-}
diff --git a/net-analyzer/icinga2/icinga2-2.3.2-r1.ebuild b/net-analyzer/icinga2/icinga2-2.3.3.ebuild
index acd469cb5dd8..e3106c3d8658 100644
--- a/net-analyzer/icinga2/icinga2-2.3.2-r1.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.3.3.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.3.2-r1.ebuild,v 1.1 2015/03/25 18:53:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.3.3.ebuild,v 1.1 2015/03/27 19:47:42 prometheanfire Exp $
EAPI=5
-inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
+inherit cmake-utils depend.apache eutils systemd toolchain-funcs user versionator
DESCRIPTION="Distributed, general purpose, network monitoring engine"
HOMEPAGE="http://icinga.org/icinga2"
-#PV=$(replace_version_separator 3 '-')
SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-#S="${WORKDIR}/${PN}-${PV}"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index 6b49940de276..2a33b289347c 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-9999.ebuild,v 1.4 2015/03/13 21:11:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-9999.ebuild,v 1.5 2015/03/27 19:47:42 prometheanfire Exp $
EAPI=5
inherit cmake-utils depend.apache eutils git-2 systemd toolchain-funcs user versionator
-DESCRIPTION="Distributed, general purpose, network monitoring engine."
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
HOMEPAGE="http://icinga.org/icinga2"
EGIT_REPO_URI="http://github.com/Icinga/icinga2.git"
EGIT_BRANCH="master"
@@ -13,24 +13,26 @@ EGIT_BRANCH="master"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="+mysql postgres classicui nano-syntax +plugins +vim-syntax"
-
-DEPEND="dev-util/cmake
- dev-libs/openssl
- >=dev-libs/boost-1.41
- sys-devel/bison
- >=sys-devel/flex-2.5.35
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
-
-RDEPEND="${DEPEND}
+IUSE="+mysql postgres classicui minimal nano-syntax +plugins +vim-syntax"
+
+DEPEND="
+ dev-util/cmake
+ dev-libs/openssl
+ >=dev-libs/boost-1.41
+ sys-devel/bison
+ >=sys-devel/flex-2.5.35
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+
+RDEPEND="
+ ${DEPEND}
plugins? ( || (
net-analyzer/monitoring-plugins
net-analyzer/nagios-plugins
) )
classicui? ( net-analyzer/icinga[web] )"
-REQUIRED_USE="|| ( mysql postgres )"
+REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
want_apache2