summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-28 10:16:27 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-28 10:16:27 +0000
commita03b2d624c533890edfba428087d0d978af249fe (patch)
tree672b39d6ac25a31e927779b8cd2b8791449e8fdf /net-analyzer
parentVersion bump, added ~amd64, added eautoreconf run due to maintainer mode, mig... (diff)
downloadgentoo-2-a03b2d624c533890edfba428087d0d978af249fe.tar.gz
gentoo-2-a03b2d624c533890edfba428087d0d978af249fe.tar.bz2
gentoo-2-a03b2d624c533890edfba428087d0d978af249fe.zip
Revbump for nagios-3, fix quotation
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/ChangeLog10
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/net-analyzer/nagios-sap-ccms-plugin/ChangeLog b/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
index bb95b0b8000f..1ec87eb084b3 100644
--- a/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
+++ b/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-sap-ccms-plugin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/ChangeLog,v 1.4 2007/06/30 16:39:48 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/ChangeLog,v 1.5 2008/06/28 10:16:27 dertobi123 Exp $
+
+*nagios-sap-ccms-plugin-0.7.3-r1 (28 Jun 2008)
+
+ 28 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-sap-ccms-plugin-0.7.3-r1.ebuild:
+ Revbump for nagios-3, fix quotation
30 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org>
nagios-sap-ccms-plugin-0.7.3.ebuild:
diff --git a/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..5501d700cf04
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild,v 1.1 2008/06/28 10:16:27 dertobi123 Exp $
+
+inherit eutils
+
+MY_P="sap-ccms-plugin-${PV}"
+
+DESCRIPTION="Nagios plugin that provides an interface to SAP CCMS
+Infrastructure"
+HOMEPAGE="http://sourceforge.net/projects/nagios-sap-ccms/"
+SRC_URI="mirror://sourceforge/nagios-sap-ccms/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-analyzer/nagios-core"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ cd "${S}/src"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/src"
+ exeinto /usr/$(get_libdir)/nagios/plugins
+
+ for file in {check_sap{,_cons,_instance,_instance_cons,_mult_no_thr,_multiple,_system,_system_cons},create_cfg,sap_change_thr}
+ do
+ doexe ${file}
+ done
+
+ chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
+
+ dolib.so sap_moni.so
+ cd "${S}/config"
+
+ dodir /etc/sapmon
+ insinto /etc/sapmon
+ doins "${S}"/config/*
+}
+
+pkg_postinst() {
+ elog "Have a look at /etc/sapmon for configuring ${PN}"
+ elog "Further information can be found at"
+ elog "http://nagios-sap-ccms.sourceforge.net/"
+}