summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-01-21 18:03:06 +0000
committerPeter Volkov <pva@gentoo.org>2007-01-21 18:03:06 +0000
commitabc9fb9330382406a81426023fecbf6841f61c08 (patch)
tree51bc3bb328e1356f45bf9bf72c45eb34cc2f251f /net-analyzer
parentAdd ~x86-fbsd keyword (see the various bugs for netbeans 5.5-r2). (diff)
downloadgentoo-2-abc9fb9330382406a81426023fecbf6841f61c08.tar.gz
gentoo-2-abc9fb9330382406a81426023fecbf6841f61c08.tar.bz2
gentoo-2-abc9fb9330382406a81426023fecbf6841f61c08.zip
Version bump.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j.ebuild89
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j3
3 files changed, 98 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 51339cc5ac07..58f508ff4bbe 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.83 2007/01/16 00:36:30 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.84 2007/01/21 18:03:06 pva Exp $
+
+*cacti-0.8.6j (21 Jan 2007)
+
+ 21 Jan 2007; <pva@gentoo.org> +cacti-0.8.6j.ebuild:
+ Version bump.
16 Jan 2007; Jason Wever <weeve@gentoo.org> cacti-0.8.6i-r1.ebuild:
Stable on SPARC wrt security bug #159278.
diff --git a/net-analyzer/cacti/cacti-0.8.6j.ebuild b/net-analyzer/cacti/cacti-0.8.6j.ebuild
new file mode 100644
index 000000000000..2edae940e89c
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6j.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j.ebuild,v 1.1 2007/01/21 18:03:06 pva Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=0
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES=""
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+# alpha doesn't have lighttpd keyworded yet
+# sparc doesn't have a stable keyword for lighttpd yet
+RDEPEND="!alpha? ( !sparc? ( !apache? ( !apache2? ( www-servers/lighttpd ) ) ) )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ require_php_with_use cli mysql xml
+ elif [ $PHP_VERSION = 4 ] ; then
+ require_php_with_use cli mysql xml expat
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j b/net-analyzer/cacti/files/digest-cacti-0.8.6j
new file mode 100644
index 000000000000..1ebe752b6910
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6j
@@ -0,0 +1,3 @@
+MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
+RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
+SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337