summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-09 07:05:54 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-09 07:05:54 +0000
commitb5450c0d21ebda57ab1a32ae2a5f6f6f4378584b (patch)
tree299ab9879401842cd86fec5fddc57ea74893fd43 /net-analyzer
parentremoved LDFLAGS from krb5-config -> bug #184668 (diff)
downloadgentoo-2-b5450c0d21ebda57ab1a32ae2a5f6f6f4378584b.tar.gz
gentoo-2-b5450c0d21ebda57ab1a32ae2a5f6f6f4378584b.tar.bz2
gentoo-2-b5450c0d21ebda57ab1a32ae2a5f6f6f4378584b.zip
Version bump (bug #237121).
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog8
-rw-r--r--net-analyzer/nmap/files/nmap-4.75-include.patch13
-rw-r--r--net-analyzer/nmap/nmap-4.75.ebuild68
3 files changed, 88 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 886e832e33f0..03bbce5f5608 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.182 2008/08/30 21:23:40 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.183 2008/09/09 07:05:53 spock Exp $
+
+*nmap-4.75 (09 Sep 2008)
+
+ 09 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ +files/nmap-4.75-include.patch, +nmap-4.75.ebuild:
+ Version bump (bug #237121).
30 Aug 2008; Michał Januszewski <spock@gentoo.org>
+files/nmap-4.68-concurrent-make-fix.patch, nmap-4.68.ebuild:
diff --git a/net-analyzer/nmap/files/nmap-4.75-include.patch b/net-analyzer/nmap/files/nmap-4.75-include.patch
new file mode 100644
index 000000000000..d8105ce78bb4
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-4.75-include.patch
@@ -0,0 +1,13 @@
+diff -Naurp nmap-4.75-orig/nmap_dns.h nmap-4.75/nmap_dns.h
+--- nmap-4.75-orig/nmap_dns.h 2008-09-09 08:51:59.000000000 +0200
++++ nmap-4.75/nmap_dns.h 2008-09-09 08:52:19.000000000 +0200
+@@ -95,6 +95,9 @@
+ * *
+ ***************************************************************************/
+
++#include <list>
++#include <string>
++
+ class Target;
+
+ void nmap_mass_rdns(Target ** targets, int num_targets);
diff --git a/net-analyzer/nmap/nmap-4.75.ebuild b/net-analyzer/nmap/nmap-4.75.ebuild
new file mode 100644
index 000000000000..98c75ebd68b1
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.75.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.75.ebuild,v 1.1 2008/09/09 07:05:53 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-include.patch"
+}
+
+src_compile() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version ">=dev-lang/lua-5.1.3-r1" &&
+ built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf \
+ --with-libdnet=included \
+ "${myconf}" \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake || die
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}