summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-07-08 19:32:44 +0000
committerHanno Böck <hanno@gentoo.org>2013-07-08 19:32:44 +0000
commitcb933e6ec6aa9613b6ed7de733fd66fb87f0499b (patch)
tree5853e570576b95e94329b87246257fc209d184f0 /net-analyzer
parentCleanup. (diff)
downloadgentoo-2-cb933e6ec6aa9613b6ed7de733fd66fb87f0499b.tar.gz
gentoo-2-cb933e6ec6aa9613b6ed7de733fd66fb87f0499b.tar.bz2
gentoo-2-cb933e6ec6aa9613b6ed7de733fd66fb87f0499b.zip
openvas-manager bump
(Portage version: 2.1.12.12/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openvas-manager/ChangeLog7
-rw-r--r--net-analyzer/openvas-manager/openvas-manager-4.0.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-analyzer/openvas-manager/ChangeLog b/net-analyzer/openvas-manager/ChangeLog
index 0920a3434999..d30b49359fc2 100644
--- a/net-analyzer/openvas-manager/ChangeLog
+++ b/net-analyzer/openvas-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/openvas-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-manager/ChangeLog,v 1.3 2013/07/01 10:23:42 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-manager/ChangeLog,v 1.4 2013/07/08 19:32:44 hanno Exp $
+
+*openvas-manager-4.0.2 (08 Jul 2013)
+
+ 08 Jul 2013; Hanno Boeck <hanno@gentoo.org> +openvas-manager-4.0.2.ebuild:
+ Bump.
*openvas-manager-4.0.1 (01 Jul 2013)
diff --git a/net-analyzer/openvas-manager/openvas-manager-4.0.2.ebuild b/net-analyzer/openvas-manager/openvas-manager-4.0.2.ebuild
new file mode 100644
index 000000000000..c1c150e59dc0
--- /dev/null
+++ b/net-analyzer/openvas-manager/openvas-manager-4.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-manager/openvas-manager-4.0.2.ebuild,v 1.1 2013/07/08 19:32:44 hanno Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A remote security scanner for Linux (openvas-manager)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1381/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-6.0.0
+ >=dev-db/sqlite-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/cmake"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README TODO || die "dodoc failed"
+ doinitd "${FILESDIR}"/openvasmd || die
+}
+
+pkg_postinst() {
+ elog "To allow openvasmd to work, you need to"
+ elog "1. create a client certificate with openvas-mkcert-client -n om -i"
+ elog "2. create an openvasmd database with openvasmd --rebuild"
+}