summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetre Rodan <kaiowas@gentoo.org>2005-07-19 12:22:08 +0000
committerPetre Rodan <kaiowas@gentoo.org>2005-07-19 12:22:08 +0000
commite41c13e07ee06ba6e8fbf739422d67e0dc04cf73 (patch)
tree0deda18b108e4becc6ce32da525a6d2dc2ace480 /net-analyzer
parent64 bit fixes (diff)
downloadgentoo-2-e41c13e07ee06ba6e8fbf739422d67e0dc04cf73.tar.gz
gentoo-2-e41c13e07ee06ba6e8fbf739422d67e0dc04cf73.tar.bz2
gentoo-2-e41c13e07ee06ba6e8fbf739422d67e0dc04cf73.zip
fix for #83429. fifo.patch should be part of the next upstream version
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog8
-rw-r--r--net-analyzer/ethereal/Manifest3
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.11-r1.ebuild119
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.10.11-r11
-rw-r--r--net-analyzer/ethereal/files/fifo.patch27
5 files changed, 157 insertions, 1 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index dae3ef05a622..566d7dd5ac52 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.125 2005/06/13 19:14:37 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.126 2005/07/19 12:22:08 kaiowas Exp $
+
+*ethereal-0.10.11-r1 (19 Jul 2005)
+
+ 19 Jul 2005; petre rodan <kaiowas@gentoo.org> +files/fifo.patch,
+ +ethereal-0.10.11-r1.ebuild:
+ fix for #83429. fifo.patch should be part of the next upstream version
13 Jun 2005; Simon Stelling <blubb@gentoo.org> ethereal-0.10.11.ebuild:
replacing -Os with -O too, fixes bug 91660
diff --git a/net-analyzer/ethereal/Manifest b/net-analyzer/ethereal/Manifest
index a4fddb76c399..0e0e71b830a0 100644
--- a/net-analyzer/ethereal/Manifest
+++ b/net-analyzer/ethereal/Manifest
@@ -1,4 +1,7 @@
MD5 0b0b0b93a2e1b6e2f80da2efb8dd95bc ChangeLog 9345
MD5 c197a642ecd8faf1ac997c497a965b3b ethereal-0.10.11.ebuild 3478
MD5 17a9be2cf8cb9f24e7e5b398392483b4 metadata.xml 224
+MD5 9a0c151aca2031d46aff661281890a48 ethereal-0.10.11-r1.ebuild 3675
MD5 5f6da5f1fabdf39da22bbb5ea224fab1 files/digest-ethereal-0.10.11 70
+MD5 a4d5fb3621ed4e86f311718f1447a870 files/fifo.patch 1138
+MD5 5f6da5f1fabdf39da22bbb5ea224fab1 files/digest-ethereal-0.10.11-r1 70
diff --git a/net-analyzer/ethereal/ethereal-0.10.11-r1.ebuild b/net-analyzer/ethereal/ethereal-0.10.11-r1.ebuild
new file mode 100644
index 000000000000..3cf7339067de
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.10.11-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.11-r1.ebuild,v 1.1 2005/07/19 12:22:08 kaiowas Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="A commercial-quality network protocol analyzer"
+HOMEPAGE="http://www.ethereal.com/"
+SRC_URI="http://www.ethereal.com/distribution/${P}.tar.bz2"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64 ~ppc64"
+IUSE="adns gtk ipv6 snmp ssl gtk2 kerberos"
+
+# if --disable-gtk2 is not passed to configure it will try to build with glib-2.0.
+# --disable-ethereal do not have an influence.
+
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ snmp? ( >=net-analyzer/net-snmp-5.1.1 )
+ >=dev-util/pkgconfig-0.15.0
+ gtk? ( gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ x11-libs/pango
+ dev-libs/atk )
+ !gtk? ( =dev-libs/glib-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6e )
+ virtual/libpcap
+ >=dev-libs/libpcre-4.2
+ adns? ( net-libs/adns )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+
+ # this makes life easy
+ EPATCH_OPTS="-d ${S}"
+
+ EPATCH_SINGLE_MSG="Adding patch to allow use of fifo files as input" \
+ epatch ${FILESDIR}/fifo.patch
+}
+
+src_compile() {
+
+ replace-flags -O? -O
+
+ # Fix gcc-3.4 segfault #49238
+ #[ "`gcc-version`" == "3.4" ] && append-flags -fno-unroll-loops
+
+ local myconf
+
+ if use gtk; then
+ myconf="${myconf} $(use_enable gtk2)"
+ else
+ myconf="${myconf} --disable-gtk2"
+
+ # the asn1 plugin needs gtk
+ sed -i -e '/plugins.asn1/d' Makefile.in || die "sed failed"
+ sed -i -e '/^SUBDIRS/s/asn1//' plugins/Makefile.in || die "sed failed"
+ fi
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable ipv6) \
+ $(use_with adns) \
+ $(use_with kerberos krb5) \
+ $(use_with snmp net-snmp) \
+ --without-ucd-snmp \
+ --enable-dftest \
+ --enable-randpkt \
+ --sysconfdir=/etc/ethereal \
+ --enable-editcap \
+ --enable-capinfos \
+ --enable-text2pcap \
+ --enable-dftest \
+ --enable-randpkt \
+ ${myconf} || die "bad ./configure"
+
+ # fixes an access violation caused by libnetsnmp - see bug 79068
+ use snmp && export MIBDIRS="${D}/usr/share/snmp/mibs"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/lib/ethereal/plugins/${PV}
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog INSTALL.* NEWS README*
+
+ insinto /usr/share/icons/hicolor/16x16/apps
+ newins ${S}/image/hi16-app-ethereal.png ethereal.png
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins ${S}/image/hi32-app-ethereal.png ethereal.png
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins ${S}/image/hi48-app-ethereal.png ethereal.png
+ make_desktop_entry ethereal "Ethereal" ethereal
+}
+
+pkg_postinst() {
+ ewarn "Due to a history of security flaws in this piece of software, it may contain more flaws."
+ ewarn "To protect yourself against malicious damage due to potential flaws in this product we recommend"
+ ewarn "you take the following security precautions when running ethereal in an untrusted environment:"
+ ewarn "do no run any longer than you need to;"
+ ewarn "use in a root jail - prefereably one that has been hardened with grsec like rootjail protections;"
+ ewarn "use a hardened operating system;"
+ ewarn "do not listen to addition interfaces;"
+ ewarn "if possible, run behind a firewall;"
+ ewarn "take a capture with tcpdump and analyze the contents offline running ethereal as a the least priviledged user; and"
+ ewarn "subscribe to ethereal's announce list to be notified of newly discovered vulnerabilities."
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.10.11-r1 b/net-analyzer/ethereal/files/digest-ethereal-0.10.11-r1
new file mode 100644
index 000000000000..2203e1000983
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.10.11-r1
@@ -0,0 +1 @@
+MD5 03aa7fe2cbef9aa0654637cdc60e0458 ethereal-0.10.11.tar.bz2 5964016
diff --git a/net-analyzer/ethereal/files/fifo.patch b/net-analyzer/ethereal/files/fifo.patch
new file mode 100644
index 000000000000..a7ec4937409c
--- /dev/null
+++ b/net-analyzer/ethereal/files/fifo.patch
@@ -0,0 +1,27 @@
+--- capture_loop.c 2005-07-16 14:44:28.000000000 +0300
++++ capture_loop.c 2005-07-16 14:31:19.000000000 +0300
+@@ -157,6 +157,7 @@
+ gboolean from_cap_pipe; /* TRUE if we are capturing data from a capture pipe */
+ #ifndef _WIN32
+ struct pcap_hdr cap_pipe_hdr;
++ struct pcaprec_modified_hdr cap_pipe_rechdr;
+ int cap_pipe_fd; /* the file descriptor of the capture pipe */
+ gboolean cap_pipe_modified; /* TRUE if data in the pipe uses modified pcap headers */
+ gboolean cap_pipe_byte_swapped; /* TRUE if data in the pipe is byte swapped */
+@@ -889,7 +890,6 @@
+ fd_set set1;
+ struct timeval timeout;
+ int sel_ret;
+- struct pcaprec_modified_hdr rechdr;
+ guchar pcap_data[WTAP_MAX_PACKET_SIZE];
+ #endif
+
+@@ -916,7 +916,7 @@
+ /*
+ * "select()" says we can read from the pipe without blocking
+ */
+- inpkts = cap_pipe_dispatch(ld->cap_pipe_fd, ld, &ld->cap_pipe_hdr, &rechdr, pcap_data,
++ inpkts = cap_pipe_dispatch(ld->cap_pipe_fd, ld, &ld->cap_pipe_hdr, &ld->cap_pipe_rechdr, pcap_data,
+ errmsg, errmsg_len);
+ if (inpkts < 0) {
+ ld->go = FALSE;