summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-25 11:21:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-25 11:21:59 +0000
commite56f03cbba36c3f6c18525d797475f6235877d8d (patch)
treedeb96aed606d57c7c42d1a311558176daedd3582 /net-analyzer
parentmedia-gfx/hugin: RevBump to trigger rebuild (diff)
downloadgentoo-2-e56f03cbba36c3f6c18525d797475f6235877d8d.tar.gz
gentoo-2-e56f03cbba36c3f6c18525d797475f6235877d8d.tar.bz2
gentoo-2-e56f03cbba36c3f6c18525d797475f6235877d8d.zip
net-analyzer/zmap: Add release version
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zmap/ChangeLog8
-rw-r--r--net-analyzer/zmap/files/zmap-1.1.0-out-of-src.patch45
-rw-r--r--net-analyzer/zmap/zmap-1.1.0.ebuild43
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild18
4 files changed, 108 insertions, 6 deletions
diff --git a/net-analyzer/zmap/ChangeLog b/net-analyzer/zmap/ChangeLog
index edacebb85894..8944632024da 100644
--- a/net-analyzer/zmap/ChangeLog
+++ b/net-analyzer/zmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/zmap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zmap/ChangeLog,v 1.1 2013/09/20 16:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zmap/ChangeLog,v 1.2 2013/11/25 11:21:59 jlec Exp $
+
+*zmap-1.1.0 (25 Nov 2013)
+
+ 25 Nov 2013; Justin Lecher <jlec@gentoo.org> +zmap-1.1.0.ebuild,
+ zmap-9999.ebuild, +files/zmap-1.1.0-out-of-src.patch:
+ Add release version
*zmap-9999 (20 Sep 2013)
diff --git a/net-analyzer/zmap/files/zmap-1.1.0-out-of-src.patch b/net-analyzer/zmap/files/zmap-1.1.0-out-of-src.patch
new file mode 100644
index 000000000000..38f39efd0a33
--- /dev/null
+++ b/net-analyzer/zmap/files/zmap-1.1.0-out-of-src.patch
@@ -0,0 +1,45 @@
+ CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 4 ++--
+ zmap_conf_install.cmake.in | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bea62ab..0378f44 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -67,4 +67,4 @@ add_subdirectory(src)
+ FILE(GLOB CONF_FILES RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}/conf" "conf/*")
+ message(STATUS "${CONF_FILES}")
+ configure_file(zmap_conf_install.cmake.in zmap_conf_install.cmake)
+-install(SCRIPT zmap_conf_install.cmake)
++install(SCRIPT "${CMAKE_CURRENT_BINARY_DIR}/zmap_conf_install.cmake")
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 6e51f12..2c1ae5a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -75,11 +75,11 @@ add_custom_command(OUTPUT zopt.h
+ )
+
+ add_custom_command(OUTPUT lexer.c
+- COMMAND flex -o "${CMAKE_CURRENT_BINARY_DIR}/lexer.c" --header-file="${CMAKE_CURRENT_BINARY_DIR}/lexer.h" lexer.l
++ COMMAND flex -o "${CMAKE_CURRENT_BINARY_DIR}/lexer.c" --header-file="${CMAKE_CURRENT_BINARY_DIR}/lexer.h" "${CMAKE_CURRENT_SOURCE_DIR}/lexer.l"
+ )
+
+ add_custom_command(OUTPUT parser.c
+- COMMAND byacc -d -o parser.c parser.y
++ COMMAND byacc -d -o "${CMAKE_CURRENT_BINARY_DIR}/parser.c" "${CMAKE_CURRENT_SOURCE_DIR}/parser.y"
+ )
+
+ add_executable(zmap ${SOURCES})
+diff --git a/zmap_conf_install.cmake.in b/zmap_conf_install.cmake.in
+index 358a97d..aba7a60 100644
+--- a/zmap_conf_install.cmake.in
++++ b/zmap_conf_install.cmake.in
+@@ -1,6 +1,6 @@
+ foreach(conf_file ${CONF_FILES})
+ message(STATUS "${conf_file}")
+ if(NOT EXISTS "/etc/zmap/${conf_file}")
+- file(INSTALL "conf/${conf_file}" DESTINATION "/etc/zmap")
++ file(INSTALL "${CMAKE_CURRENT_SOURCE_DIR}/conf/${conf_file}" DESTINATION "/etc/zmap")
+ endif()
+ endforeach()
diff --git a/net-analyzer/zmap/zmap-1.1.0.ebuild b/net-analyzer/zmap/zmap-1.1.0.ebuild
new file mode 100644
index 000000000000..43ac9a430d29
--- /dev/null
+++ b/net-analyzer/zmap/zmap-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zmap/zmap-1.1.0.ebuild,v 1.1 2013/11/25 11:21:59 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils fcaps
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="json redis"
+
+RDEPEND="
+ dev-libs/gmp
+ net-libs/libpcap
+ json? ( dev-libs/json-c )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-devel/flex
+ virtual/yacc
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-out-of-src.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
+ $(cmake-utils_use_with json)
+ $(cmake-utils_use_with redis)
+ )
+ cmake-utils_src_configure
+}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
index e98ac35185e2..55e540edcf90 100644
--- a/net-analyzer/zmap/zmap-9999.ebuild
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zmap/zmap-9999.ebuild,v 1.1 2013/09/20 16:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zmap/zmap-9999.ebuild,v 1.2 2013/11/25 11:21:59 jlec Exp $
EAPI=5
-inherit cmake-utils git-2
+inherit cmake-utils git-r3
DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
HOMEPAGE="https://zmap.io/"
@@ -22,15 +22,23 @@ RDEPEND="
json? ( dev-libs/json-c )
redis? ( dev-libs/hiredis )"
DEPEND="${RDEPEND}
- dev-util/gengetopt"
+ dev-util/gengetopt
+ sys-devel/flex
+ virtual/yacc
+"
-PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
-EPATCH_OPTS="-p1"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-out-of-src.patch
+)
src_configure() {
local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
$(cmake-utils_use_with json)
$(cmake-utils_use_with redis)
)
cmake-utils_src_configure
}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )