summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2014-06-19 13:38:01 +0000
committerHanno Böck <hanno@gentoo.org>2014-06-19 13:38:01 +0000
commite6e3a067e1585c91bb435c4bf1fdde07fe1c6f63 (patch)
tree4bdb60d546ef7d553f3e408d47dc840761fa30e2 /net-analyzer
parentVersion bump alpha (diff)
downloadgentoo-2-e6e3a067e1585c91bb435c4bf1fdde07fe1c6f63.tar.gz
gentoo-2-e6e3a067e1585c91bb435c4bf1fdde07fe1c6f63.tar.bz2
gentoo-2-e6e3a067e1585c91bb435c4bf1fdde07fe1c6f63.zip
Bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog10
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
index 56a4c9f99493..1e439aa0c028 100644
--- a/net-analyzer/greenbone-security-assistant/ChangeLog
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/greenbone-security-assistant
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.6 2013/11/10 18:36:29 hanno Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.7 2014/06/19 13:38:01 hanno Exp $
+
+*greenbone-security-assistant-5.0.1 (19 Jun 2014)
+
+ 19 Jun 2014; Hanno Boeck <hanno@gentoo.org>
+ +greenbone-security-assistant-5.0.1.ebuild:
+ Bump.
*greenbone-security-assistant-4.0.2 (10 Nov 2013)
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.1.ebuild
new file mode 100644
index 000000000000..357daeb400b5
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.1.ebuild,v 1.1 2014/06/19 13:38:01 hanno Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1675/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-7.0.2
+ dev-libs/libxslt
+ net-libs/libmicrohttpd[messages]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog CHANGES README"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}"/gsad
+}