summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-03-29 22:02:35 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-03-29 22:02:35 +0000
commit267d169d3064194269cacf7954c19d96dc2a2f14 (patch)
tree0e3ea642555b135601bb0ef7ddacbfd1b47472ba /net-dialup/capisuite
parentUpdated chappa-patch. 4.62-r1 stable on x86. Removed spooldir warning. (diff)
downloadgentoo-2-267d169d3064194269cacf7954c19d96dc2a2f14.tar.gz
gentoo-2-267d169d3064194269cacf7954c19d96dc2a2f14.tar.bz2
gentoo-2-267d169d3064194269cacf7954c19d96dc2a2f14.zip
Fix capisuite to enable compilation with capi4k-utils-20050322 thanks to Stefan Briesenick
(Portage version: 1.585-cvs)
Diffstat (limited to 'net-dialup/capisuite')
-rw-r--r--net-dialup/capisuite/ChangeLog7
-rw-r--r--net-dialup/capisuite/capisuite-0.4.5.ebuild13
-rw-r--r--net-dialup/capisuite/files/capisuite-0.4.5-capiv3.patch29
3 files changed, 43 insertions, 6 deletions
diff --git a/net-dialup/capisuite/ChangeLog b/net-dialup/capisuite/ChangeLog
index 6ea37b23c2d3..7d1cde55a4eb 100644
--- a/net-dialup/capisuite/ChangeLog
+++ b/net-dialup/capisuite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/capisuite
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.14 2005/02/06 11:11:09 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.15 2005/03/29 22:02:35 genstef Exp $
+
+ 29 Mar 2005; Stefan Schweizer <genstef@gentoo.org>
+ +files/capisuite-0.4.5-capiv3.patch, capisuite-0.4.5.ebuild:
+ Fix capisuite to enable compilation with capi4k-utils-20050322 thanks to
+ Stefan Briesenick
06 Feb 2005; Alin Nastac <mrness@gentoo.org> capisuite-0.4.5.ebuild:
Mark stable on x86.
diff --git a/net-dialup/capisuite/capisuite-0.4.5.ebuild b/net-dialup/capisuite/capisuite-0.4.5.ebuild
index 76f72db07379..7bb602f12d7b 100644
--- a/net-dialup/capisuite/capisuite-0.4.5.ebuild
+++ b/net-dialup/capisuite/capisuite-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5.ebuild,v 1.2 2005/02/06 11:11:09 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5.ebuild,v 1.3 2005/03/29 22:02:35 genstef Exp $
inherit eutils
@@ -29,23 +29,26 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.patch
epatch ${FILESDIR}/${PN}-fax-compatibility.patch
+ # apply CAPI V3 patch conditionally
+ grep 2>/dev/null -q CAPI_LIBRARY_V2 /usr/include/capiutils.h \
+ && epatch ${FILESDIR}/${P}-capiv3.patch
}
src_compile() {
econf --localstatedir=/var \
- --with-docdir=/usr/share/doc/${P} || die "econf failed."
+ --with-docdir=/usr/share/doc/${PF} || die "econf failed."
emake || die "parallel make failed."
}
src_install() {
emake DESTDIR=${D} install || die "install failed."
- exeinto /etc/init.d
- doexe ${FILESDIR}/capisuite
+ dodir /etc/init.d
+ doinitd ${FILESDIR}/capisuite
keepdir /var/spool/capisuite/{done,failed,sendq,users}
- dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
exeinto /etc/cron.daily
doexe capisuite.cron
diff --git a/net-dialup/capisuite/files/capisuite-0.4.5-capiv3.patch b/net-dialup/capisuite/files/capisuite-0.4.5-capiv3.patch
new file mode 100644
index 000000000000..d319221a6e94
--- /dev/null
+++ b/net-dialup/capisuite/files/capisuite-0.4.5-capiv3.patch
@@ -0,0 +1,29 @@
+--- src/backend/capi.cpp.orig 2004-11-28 14:35:25.000000000 +0100
++++ src/backend/capi.cpp 2005-03-22 00:18:14.000000000 +0100
+@@ -148,7 +148,7 @@
+ << " CIPValue 0x" << CIPValue << ", B1proto 0x" << B1protocol << ", B2proto 0x" << B2protocol <<", B3proto 0x" << B3protocol << endl;
+ }
+ unsigned info=CONNECT_REQ(&CMSG, applId, messageNumber, controller, CIPValue, calledPartyNumber, callingPartyNumber, NULL, NULL,
+- B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration, NULL, NULL, NULL, NULL, NULL, NULL, NULL);
++ B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);
+ if (debug_level >= 2) {
+ debug << prefix() << "info: " << info << endl;
+ }
+@@ -181,7 +181,7 @@
+
+ if (debug_level >= 2) debug << prefix() << ">SELECT_B_PROTOCOL_REQ: ApplId 0x" << hex << applId << ", MsgNr 0x" << messageNumber << ", PLCI 0x" << plci
+ << ", B1protocol " << B1protocol << ", B2protocol " << B2protocol << ", B3protocol " << B3protocol << endl;
+- unsigned info=SELECT_B_PROTOCOL_REQ(&CMSG, applId, messageNumber++, plci, B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration);
++ unsigned info=SELECT_B_PROTOCOL_REQ(&CMSG, applId, messageNumber++, plci, B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration, NULL);
+ if (debug_level >= 2)
+ debug << prefix() << "info: " << info << endl;
+
+@@ -295,7 +295,7 @@
+ << reject << ", B1proto 0x" << B1protocol << ", B2proto 0x" << B2protocol << ", B3proto 0x" << B3protocol << endl;
+
+ _cmsg new_message;
+- unsigned info=CONNECT_RESP(&new_message, applId, messageNumber, plci, reject, B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration, NULL, NULL, NULL, NULL, NULL, NULL, NULL);
++ unsigned info=CONNECT_RESP(&new_message, applId, messageNumber, plci, reject, B1protocol, B2protocol, B3protocol, B1configuration, B2configuration, B3configuration, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL);
+ if (debug_level >= 2)
+ debug << prefix() << "info: " << info << endl;
+