summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-03-12 09:46:50 +0000
committerAlin Năstac <mrness@gentoo.org>2006-03-12 09:46:50 +0000
commitc7332660b5b2b037f9797559c14f3cdf9289c13f (patch)
tree4d081b93367fd52219ec21ac6da823637db95eb0 /net-dialup/cistronradius/cistronradius-1.6.8.ebuild
parentFix building with newer gcc versions and cleanup implicit warnings that hate ... (diff)
downloadgentoo-2-c7332660b5b2b037f9797559c14f3cdf9289c13f.tar.gz
gentoo-2-c7332660b5b2b037f9797559c14f3cdf9289c13f.tar.bz2
gentoo-2-c7332660b5b2b037f9797559c14f3cdf9289c13f.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup/cistronradius/cistronradius-1.6.8.ebuild')
-rw-r--r--net-dialup/cistronradius/cistronradius-1.6.8.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-dialup/cistronradius/cistronradius-1.6.8.ebuild b/net-dialup/cistronradius/cistronradius-1.6.8.ebuild
new file mode 100644
index 000000000000..465a07a51879
--- /dev/null
+++ b/net-dialup/cistronradius/cistronradius-1.6.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/cistronradius/cistronradius-1.6.8.ebuild,v 1.1 2006/03/12 09:46:50 mrness Exp $
+
+DESCRIPTION="An authentication and accounting server for terminal servers that speak the RADIUS protocol."
+SRC_URI="ftp://ftp.radius.cistron.nl/pub/radius/radiusd-cistron-${PV}.tar.gz"
+HOMEPAGE="http://www.radius.cistron.nl/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 -*"
+
+DEPEND="!net-dialup/freeradius
+ !net-dialup/gnuradius"
+
+S="${WORKDIR}/radiusd-cistron-${PV}/src"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s:/usr/local:/usr:g" \
+ -e "s:-Wall -g:${CFLAGS}:g" Makefile
+ sed -i -e "s:SHAREDIR/::g" ../raddb/dictionary
+ mv checkrad.pl checkrad
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ exeinto /usr/sbin
+ doexe "${S}/checkrad"
+ doexe "${S}/radiusd"
+ doexe "${S}/radrelay"
+ dodir /usr/bin
+ exeinto /usr/bin
+ doexe "${S}/radclient"
+ doexe "${S}/radlast"
+ doexe "${S}/radtest"
+ doexe "${S}/radwho"
+ doexe "${S}/radzap"
+
+ newinitd "${FILESDIR}/cistronradius.rc" cistronradius
+
+ cd "${S}/.."
+ dodir /etc/raddb
+ insinto /etc/raddb
+ doins raddb/*
+ dodoc COPYRIGHT README doc/{ChangeLog,FAQ.txt,README*}
+ doman doc/{*.1,*.8,*.5rad,*.8rad}
+}