summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-02-10 08:15:52 +0000
committerAlin Năstac <mrness@gentoo.org>2007-02-10 08:15:52 +0000
commitaf20a36f7d10e2b10a58f20fa35547cd062a720f (patch)
tree7e2ffb0f7b67e2448d28a2bd62df0bd2d4ba3491 /net-dialup/hcfpcimodem
parentbump + ~amd64 (diff)
downloadgentoo-2-af20a36f7d10e2b10a58f20fa35547cd062a720f.tar.gz
gentoo-2-af20a36f7d10e2b10a58f20fa35547cd062a720f.tar.bz2
gentoo-2-af20a36f7d10e2b10a58f20fa35547cd062a720f.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-dialup/hcfpcimodem')
-rw-r--r--net-dialup/hcfpcimodem/ChangeLog9
-rw-r--r--net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.116
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild74
3 files changed, 87 insertions, 2 deletions
diff --git a/net-dialup/hcfpcimodem/ChangeLog b/net-dialup/hcfpcimodem/ChangeLog
index ac4564a35a0b..d0196959728c 100644
--- a/net-dialup/hcfpcimodem/ChangeLog
+++ b/net-dialup/hcfpcimodem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/hcfpcimodem
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.26 2006/09/22 19:16:26 mrness Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.27 2007/02/10 08:15:52 mrness Exp $
+
+*hcfpcimodem-1.11 (10 Feb 2007)
+
+ 10 Feb 2007; Alin Năstac <mrness@gentoo.org> +hcfpcimodem-1.11.ebuild:
+ Version bump.
22 Sep 2006; Alin Nastac <mrness@gentoo.org>
-files/hcfpcimodem-1.08-upstream-20051215.patch, -hcfpcimodem-1.08.ebuild,
diff --git a/net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11 b/net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11
new file mode 100644
index 000000000000..7992acbf0db7
--- /dev/null
+++ b/net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11
@@ -0,0 +1,6 @@
+MD5 e6d8fea8f5f641d7bb4dfb33c6f478e7 100498D_RM_HxF_Released.pdf 718949
+RMD160 be9df1ae492bcce46775c0325cd438b91213bf7a 100498D_RM_HxF_Released.pdf 718949
+SHA256 e05385b094ac97f13aabc9432ba7478c0acf12862b3c4da097272435d43f6ac1 100498D_RM_HxF_Released.pdf 718949
+MD5 6bb1a6ea10bbf8d971222104071f8291 hcfpcimodem-1.11full.tar.gz 677772
+RMD160 b1cc280c6511176c215b33124098072f7449eb5d hcfpcimodem-1.11full.tar.gz 677772
+SHA256 a1c8f8a2d6818d3f1c2da0372383be0e68c887b610f3f8135f640e136dc3e0fe hcfpcimodem-1.11full.tar.gz 677772
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild
new file mode 100644
index 000000000000..81104cdb2e6e
--- /dev/null
+++ b/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild,v 1.1 2007/02/10 08:15:52 mrness Exp $
+
+inherit eutils linux-info
+
+#The document is the same as in hsfmodem, even if it has a different URL
+MY_DOC="100498D_RM_HxF_Released.pdf"
+
+DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
+HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
+ doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
+
+LICENSE="Conexant"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ app-arch/cpio"
+
+S="${WORKDIR}/${P}full"
+
+QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ MOD_N="hcfpci"
+ # Check to see if module is inserted into kernel, otherwise, build fails
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror
+ eerror "Module is in use by the kernel!!!"
+ eerror "Attempting to unload..."
+ eerror
+
+ # Unloading module...
+ ${MOD_N}stop
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror "Failed to unload modules from kernel!!!"
+ eerror "Please manualy remove the module from the kernel and emerge again."
+ eerror
+ die
+ fi
+ einfo "Successfuly removed module from memory. Resuming emerge."
+ einfo
+ fi
+}
+
+src_compile() {
+ emake all || die "make failed"
+}
+
+pkg_preinst() {
+ local NVMDIR="${ROOT}/etc/${PN}/nvm"
+ if [ -d "${NVMDIR}" ]; then
+ einfo "Cleaning ${NVMDIR}..."
+ rm -rf "${NVMDIR}"
+ eend
+ fi
+}
+
+src_install () {
+ make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+
+ use doc && dodoc "${DISTDIR}/${MY_DOC}"
+}
+
+pkg_postinst() {
+ einfo "To complete the installation and configuration of your HCF modem,"
+ einfo "please run hcfpciconfig."
+}
+