summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-10 23:32:37 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-10 23:32:37 +0000
commit2ea5a00cabed210ee41e0467f3973eb4256b8032 (patch)
tree7b80679700d6c9347a9c19eceb0232c3720cad05 /net-dialup/komport
parentStable on x86 and amd64. (diff)
downloadgentoo-2-2ea5a00cabed210ee41e0467f3973eb4256b8032.tar.gz
gentoo-2-2ea5a00cabed210ee41e0467f3973eb4256b8032.tar.bz2
gentoo-2-2ea5a00cabed210ee41e0467f3973eb4256b8032.zip
Get rid of invalid aRts dependency. Compile with GCC 4.3, bug #251438. Desktop file fix.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-dialup/komport')
-rw-r--r--net-dialup/komport/ChangeLog12
-rw-r--r--net-dialup/komport/files/komport-0.5.9-desktop-file.diff19
-rw-r--r--net-dialup/komport/files/komport-0.5.9-gcc43.diff29
-rw-r--r--net-dialup/komport/komport-0.5.9-r1.ebuild24
4 files changed, 82 insertions, 2 deletions
diff --git a/net-dialup/komport/ChangeLog b/net-dialup/komport/ChangeLog
index 1b25496ebe5f..1a245a2cbc3e 100644
--- a/net-dialup/komport/ChangeLog
+++ b/net-dialup/komport/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dialup/komport
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/komport/ChangeLog,v 1.9 2007/04/14 11:30:20 mrness Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/komport/ChangeLog,v 1.10 2009/02/10 23:32:37 carlo Exp $
+
+*komport-0.5.9-r1 (10 Feb 2009)
+
+ 10 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +files/komport-0.5.9-desktop-file.diff, +files/komport-0.5.9-gcc43.diff,
+ +komport-0.5.9-r1.ebuild:
+ Get rid of invalid aRts dependency. Compile with GCC 4.3, bug #251438.
+ Desktop file fix.
14 Apr 2007; Alin Năstac <mrness@gentoo.org> komport-0.5.9.ebuild:
Stable on amd64.
diff --git a/net-dialup/komport/files/komport-0.5.9-desktop-file.diff b/net-dialup/komport/files/komport-0.5.9-desktop-file.diff
new file mode 100644
index 000000000000..82a8073bbf21
--- /dev/null
+++ b/net-dialup/komport/files/komport-0.5.9-desktop-file.diff
@@ -0,0 +1,19 @@
+--- ./work/komport-0.5.9/komport/komport.desktop.orig 2009-02-11 00:22:03.000000000 +0100
++++ ./work/komport-0.5.9/komport/komport.desktop 2009-02-11 00:22:03.000000000 +0100
+@@ -1,12 +1,11 @@
+ # KDE Config File
+ [Desktop Entry]
+-Encoding=UTF-8
+ Type=Application
+-Exec=komport -caption "%c" %i %m
+-Icon=komport.png
+-DocPath=komport/index.html
++Exec=komport -caption "%c" %i
++Icon=komport
++X-DocPath=komport/index.html
+ Comment=
+ Comment[de]=
+-Terminal=0
++Terminal=false
+ Name=Komport
+ Name[de]=Komport
diff --git a/net-dialup/komport/files/komport-0.5.9-gcc43.diff b/net-dialup/komport/files/komport-0.5.9-gcc43.diff
new file mode 100644
index 000000000000..abfc189452b3
--- /dev/null
+++ b/net-dialup/komport/files/komport-0.5.9-gcc43.diff
@@ -0,0 +1,29 @@
+--- komport-0.5.9b/komport/komportview.h 2009-01-23 03:41:00.000000000 -0400
++++ komport-0.5.9/komport/komportview.h 2009-01-23 03:42:06.000000000 -0400
+@@ -74,7 +74,7 @@
+ /** Re-draw a cell given and _x, _y coordinate. */
+ void updateCell(QPainter* _p, int _x,int _y);
+ /** Re-draw a cell given a QPoint coordinate. */
+- void updateCell(QPainter* _p, QPoint _p);
++ void updateCell(QPainter* _paint, QPoint _p);
+ /** Get a pointer to the serial port object. */
+ KomportSerial* getSerial();
+ /** clear selection */
+--- komport-0.5.9b/komport/settingsdialog.h 2009-01-23 03:56:23.000000000 -0400
++++ komport-0.5.9/komport/settingsdialog.h 2009-01-23 03:56:38.000000000 -0400
+@@ -11,6 +11,7 @@
+ #define SETTINGSDIALOG_H
+
+ #include <qvariant.h>
++#include <qlayout.h>
+ #include <qdialog.h>
+
+ class QVBoxLayout;
+@@ -78,6 +79,7 @@
+ QPushButton* buttonHelp;
+ QPushButton* buttonOk;
+ QPushButton* buttonCancel;
++ QSpacerItem* Horizontal_Spacing2;
+
+ public slots:
+ virtual void FlowControlComboBox_highlighted( int _i );
diff --git a/net-dialup/komport/komport-0.5.9-r1.ebuild b/net-dialup/komport/komport-0.5.9-r1.ebuild
new file mode 100644
index 000000000000..63df407e7b59
--- /dev/null
+++ b/net-dialup/komport/komport-0.5.9-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/komport/komport-0.5.9-r1.ebuild,v 1.1 2009/02/10 23:32:37 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+DESCRIPTION="Komport - Serial port communications and vt102 terminal emulator for KDE"
+HOMEPAGE="http://komport.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/kde-admindir-3.5.5.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/komport-0.5.9-gcc43.diff"
+ "${FILESDIR}/komport-0.5.9-desktop-file.diff"
+ )