summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-03-12 17:38:07 +0000
committerAlin Năstac <mrness@gentoo.org>2006-03-12 17:38:07 +0000
commit5647c2f1a2a36e7dd19296d84a568c8129baeb04 (patch)
tree48049f4fa816010f2aa9d05b1e692195cd3eb6bb /net-dialup/mgetty/mgetty-1.1.34.ebuild
parentMarked 2.0.3 ppc stable for bug #125828. (diff)
downloadgentoo-2-5647c2f1a2a36e7dd19296d84a568c8129baeb04.tar.gz
gentoo-2-5647c2f1a2a36e7dd19296d84a568c8129baeb04.tar.bz2
gentoo-2-5647c2f1a2a36e7dd19296d84a568c8129baeb04.zip
Quote various env vars and mark 1.1.34 as stable on x86. Version bump.
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup/mgetty/mgetty-1.1.34.ebuild')
-rw-r--r--net-dialup/mgetty/mgetty-1.1.34.ebuild53
1 files changed, 27 insertions, 26 deletions
diff --git a/net-dialup/mgetty/mgetty-1.1.34.ebuild b/net-dialup/mgetty/mgetty-1.1.34.ebuild
index 613334d1f9f8..8879a324229b 100644
--- a/net-dialup/mgetty/mgetty-1.1.34.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.34.ebuild,v 1.1 2006/01/09 09:08:41 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.34.ebuild,v 1.2 2006/03/12 17:38:07 mrness Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -17,7 +17,7 @@ DEPEND="doc? ( virtual/tetex )
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
IUSE="doc"
pkg_setup() {
@@ -27,43 +27,44 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
# fix deprecate warnings
- epatch ${FILESDIR}/${P}-strerror.patch
+ epatch "${FILESDIR}/${P}-strerror.patch"
# add callback install to Makefile
- epatch ${FILESDIR}/${P}-callback.patch
+ epatch "${FILESDIR}/${P}-callback.patch"
# Lucent modem CallerID patch - bug #80366
- epatch ${FILESDIR}/Lucent.c.patch
+ epatch "${FILESDIR}/Lucent.c.patch"
#Avoid "is setXid, dynamically linked and using lazy bindings" QA notices
append-ldflags $(bindnow-flags)
- sed -i 's: \$(CFLAGS) -o faxq-helper faxq-helper.o: $(LDLAGS) '$(bindnow-flags)' -o faxq-helper faxq-helper.o:' ${S}/fax/Makefile
+ sed -i 's: \$(CFLAGS) -o faxq-helper faxq-helper.o: $(LDLAGS) '$(bindnow-flags)' -o faxq-helper faxq-helper.o:' "${S}/fax/Makefile"
sed -e 's:var/log/mgetty:var/log/mgetty/mgetty:' \
-e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
-e 's:\/\* \(\#define CNDFILE "dialin.config"\) \*\/:\1:' \
-e 's:\(\#define FAX_NOTIFY_PROGRAM\).*:\1 "/etc/mgetty+sendfax/new_fax":' \
- ${S}/policy.h-dist > ${S}/policy.h
+ "${S}/policy.h-dist" > "${S}/policy.h"
#Set proper owner:group
- sed -i -e "s:uucp:fax:g" ${S}/mgetty.cfg.in
+ sed -i -e "s:uucp:fax:g" "${S}/mgetty.cfg.in"
sed -i -e "s:phone_group phone:phone_group fax:g" \
-e "s:phone_owner root:phone_owner fax:g" \
- -e "s/root.phone/fax:fax/g" ${S}/voice/voice.conf-dist
+ -e "s/root.phone/fax:fax/g" "${S}/voice/voice.conf-dist"
# bug 44231 and remove move warning
sed -e 's:ECHO="echo":ECHO="echo -e":' \
-e "/mv -f \$(SBINDIR)/d" \
- -i ${S}/Makefile
+ -i "${S}/Makefile"
sed -e "/^doc-all:/s/mgetty.asc mgetty.info mgetty.dvi mgetty.ps/mgetty.info/" \
- -i ${S}/doc/Makefile
+ -i "${S}/doc/Makefile"
if use doc; then
sed -e "s:dvips -o mgetty.ps:dvips -M -o mgetty.ps:" \
-e "s/^doc-all:/doc-all: mgetty.ps/" \
- -i ${S}/doc/Makefile
+ -i "${S}/doc/Makefile"
fi
}
@@ -84,22 +85,22 @@ src_install () {
dodir /var/log/mgetty
dodir /usr/share/info
- make prefix=${D}/usr \
- INFODIR=${D}/usr/share/info \
- CONFDIR=${D}/etc/mgetty+sendfax \
- MAN1DIR=${D}/usr/share/man/man1 \
- MAN4DIR=${D}/usr/share/man/man4 \
- MAN5DIR=${D}/usr/share/man/man5 \
- MAN8DIR=${D}/usr/share/man/man8 \
- SBINDIR=${D}/usr/sbin \
- BINDIR=${D}/usr/bin \
- VOICE_DIR=${D}/var/spool/voice \
+ make prefix="${D}/usr" \
+ INFODIR="${D}/usr/share/info" \
+ CONFDIR="${D}/etc/mgetty+sendfax" \
+ MAN1DIR="${D}/usr/share/man/man1" \
+ MAN4DIR="${D}/usr/share/man/man4" \
+ MAN5DIR="${D}/usr/share/man/man5" \
+ MAN8DIR="${D}/usr/share/man/man8" \
+ SBINDIR="${D}/usr/sbin" \
+ BINDIR="${D}/usr/bin" \
+ VOICE_DIR="${D}/var/spool/voice" \
PHONE_GROUP=fax \
PHONE_PERMS=755 \
- spool=${D}/var/spool \
+ spool="${D}/var/spool" \
install vgetty-install install-callback || die "make install failed."
- cd ${S}
+ cd "${S}"
dodoc BUGS ChangeLog README.1st Recommend THANKS TODO \
doc/*.txt doc/modems.db || die "dodoc failed."
doinfo doc/mgetty.info || die "doinfo failed."