summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-26 13:33:22 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-26 13:33:22 +0000
commitca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf (patch)
tree02768704f22ff3144221becd01936b118c7d679d /net-dialup/pppconfig/pppconfig-2.3.21.ebuild
parentUpdate bug number in a comment. Pretty useless commit, but some users were co... (diff)
downloadgentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.tar.gz
gentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.tar.bz2
gentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.zip
Version bump. Use mirror:// (bug #413341). Rewrite LINGUAS support using strip-linguas (maybe bug #403633).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-dialup/pppconfig/pppconfig-2.3.21.ebuild')
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.21.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
new file mode 100644
index 000000000000..184ed16795b0
--- /dev/null
+++ b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.21.ebuild,v 1.1 2014/05/26 13:33:22 jer Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A text menu based utility for configuring ppp"
+HOMEPAGE="http://packages.qa.debian.org/p/pppconfig.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="net-dialup/ppp
+ dev-util/dialog
+ dev-lang/perl"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i po/
+ fi
+}
+
+src_compile() {
+ default
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ msgfmt -o po/${lang}.{m,p}o || die
+ done
+ fi
+}
+
+src_install () {
+ dodir /etc/chatscripts /etc/ppp/resolv
+ dosbin 0dns-down 0dns-up dns-clean
+ newsbin pppconfig pppconfig.real
+ dosbin "${FILESDIR}/pppconfig"
+ doman man/pppconfig.8
+ dodoc debian/{copyright,changelog}
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ insinto /usr/share/locale/${lang}/LC_MESSAGES
+ newins po/${lang}.mo pppconfig.mo
+ done
+ fi
+}