summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-20 10:16:54 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-20 10:16:54 +0000
commit92de0f2f158bcd7c2cda3d2cbe748439f496e1c0 (patch)
tree5c3d2f130f4a5986548b3005c2f861a3b107cdc0 /net-dialup/rp-l2tp
parentCorrect makefile to use our CXXFLAGS and mark it stable on x86. (Manifest rec... (diff)
downloadgentoo-2-92de0f2f158bcd7c2cda3d2cbe748439f496e1c0.tar.gz
gentoo-2-92de0f2f158bcd7c2cda3d2cbe748439f496e1c0.tar.bz2
gentoo-2-92de0f2f158bcd7c2cda3d2cbe748439f496e1c0.zip
cleanups & mark stable on x86
Diffstat (limited to 'net-dialup/rp-l2tp')
-rw-r--r--net-dialup/rp-l2tp/ChangeLog6
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff214
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff.bz2bin2922 -> 0 bytes
-rw-r--r--net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild16
4 files changed, 227 insertions, 9 deletions
diff --git a/net-dialup/rp-l2tp/ChangeLog b/net-dialup/rp-l2tp/ChangeLog
index ff99a27d5721..7b5823c9e416 100644
--- a/net-dialup/rp-l2tp/ChangeLog
+++ b/net-dialup/rp-l2tp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/rp-l2tp
# Copyright 2003-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/ChangeLog,v 1.8 2004/10/17 10:02:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/ChangeLog,v 1.9 2004/11/20 10:16:54 mrness Exp $
+
+ 20 Nov 2004; Alin Nastac <mrness@gentoo.org> +files/rp-l2tp-0.4-gentoo.diff,
+ -files/rp-l2tp-0.4-gentoo.diff.bz2, rp-l2tp-0.4.ebuild:
+ Mark stable on x86.
17 Oct 2004; David Holm <dholm@gentoo.org> rp-l2tp-0.4.ebuild:
Added to ~ppc.
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff
new file mode 100644
index 000000000000..a1e6a49454aa
--- /dev/null
+++ b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff
@@ -0,0 +1,214 @@
+diff -ru rp-l2tp-0.4/Makefile.in rp-l2tp-0.4-gentoo/Makefile.in
+--- rp-l2tp-0.4/Makefile.in 2004-07-01 17:17:11.000000000 +0200
++++ rp-l2tp-0.4-gentoo/Makefile.in 2004-07-13 11:46:46.000000000 +0200
+@@ -81,13 +81,13 @@
+
+ install: all
+ -mkdir -p $(RPM_INSTALL_ROOT)$(DESTDIR)$(sbindir)
+- $(install) -m 755 -s l2tpd $(RPM_INSTALL_ROOT)$(DESTDIR)$(sbindir)
+- -mkdir -p $(RPM_INSTALL_ROOT)$(DESTDIR)/etc/l2tp
+- $(install) -m 644 l2tp.conf $(RPM_INSTALL_ROOT)$(DESTDIR)/etc/l2tp/l2tp.conf.example
++ $(install) -m 755 -s l2tpd $(RPM_INSTALL_ROOT)$(DESTDIR)$(sbindir)/rp-l2tpd
++ -mkdir -p $(RPM_INSTALL_ROOT)$(DESTDIR)/etc/rp-l2tp
++ $(install) -m 644 l2tp.conf $(RPM_INSTALL_ROOT)$(DESTDIR)/etc/rp-l2tp/rp-l2tpd.conf.example
+ -mkdir -p $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man8
+ -mkdir -p $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man5
+- $(install) -m 644 man/l2tpd.8 $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man8
+- $(install) -m 644 man/l2tp.conf.5 $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man5
++ $(install) -m 644 man/l2tpd.8 $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man8/rp-l2tpd.8
++ $(install) -m 644 man/l2tp.conf.5 $(RPM_INSTALL_ROOT)$(DESTDIR)$(mandir)/man5/rp-l2tpd.conf.5
+
+ $(MAKE) -C handlers install
+
+diff -ru rp-l2tp-0.4/handlers/Makefile.in rp-l2tp-0.4-gentoo/handlers/Makefile.in
+--- rp-l2tp-0.4/handlers/Makefile.in 2002-09-30 21:45:00.000000000 +0200
++++ rp-l2tp-0.4-gentoo/handlers/Makefile.in 2004-07-12 20:47:26.000000000 +0200
+@@ -39,7 +39,7 @@
+
+ install: all
+ -mkdir -p $(RPM_INSTALL_ROOT)$(sbindir)
+- -mkdir -p $(RPM_INSTALL_ROOT)$(prefix)/lib/l2tp/plugins
+- $(install) -m 755 -s l2tp-control $(RPM_INSTALL_ROOT)$(sbindir)
+- $(install) -m 755 $(HANDLERS) $(RPM_INSTALL_ROOT)$(prefix)/lib/l2tp/plugins
++ -mkdir -p $(RPM_INSTALL_ROOT)$(prefix)/lib/rp-l2tpd/plugins
++ $(install) -m 755 -s l2tp-control $(RPM_INSTALL_ROOT)$(sbindir)/rp-l2tpd-control
++ $(install) -m 755 $(HANDLERS) $(RPM_INSTALL_ROOT)$(prefix)/lib/rp-l2tpd/plugins
+ distclean: clean
+diff -ru rp-l2tp-0.4/handlers/cmd-control.c rp-l2tp-0.4-gentoo/handlers/cmd-control.c
+--- rp-l2tp-0.4/handlers/cmd-control.c 2002-09-30 21:45:00.000000000 +0200
++++ rp-l2tp-0.4-gentoo/handlers/cmd-control.c 2004-07-12 20:42:44.000000000 +0200
+@@ -52,7 +52,7 @@
+
+ memset(&addr, 0, sizeof(addr));
+ addr.sun_family = AF_LOCAL;
+- strncpy(addr.sun_path, "/var/run/l2tpctrl", sizeof(addr.sun_path) - 1);
++ strncpy(addr.sun_path, "/var/run/rp-l2tpdctrl", sizeof(addr.sun_path) - 1);
+
+ fd = socket(AF_LOCAL, SOCK_STREAM, 0);
+ if (fd < 0) {
+diff -ru rp-l2tp-0.4/handlers/cmd.c rp-l2tp-0.4-gentoo/handlers/cmd.c
+--- rp-l2tp-0.4/handlers/cmd.c 2004-07-01 16:58:56.000000000 +0200
++++ rp-l2tp-0.4-gentoo/handlers/cmd.c 2004-07-12 20:42:28.000000000 +0200
+@@ -162,7 +162,7 @@
+
+ /* We have hit the end of our options. Open command socket */
+ if (!sockname) {
+- sockname = "/var/run/l2tpctrl";
++ sockname = "/var/run/rp-l2tpdctrl";
+ }
+
+ (void) remove(sockname);
+diff -ru rp-l2tp-0.4/main.c rp-l2tp-0.4-gentoo/main.c
+--- rp-l2tp-0.4/main.c 2002-09-30 21:45:00.000000000 +0200
++++ rp-l2tp-0.4-gentoo/main.c 2004-07-13 11:44:50.000000000 +0200
+@@ -27,7 +27,7 @@
+ static void
+ usage(int argc, char *argv[], int exitcode)
+ {
+- fprintf(stderr, "\nl2tpd Version %s Copyright 2002 Roaring Penguin Software Inc.\n", VERSION);
++ fprintf(stderr, "\nrp-l2tpd Version %s Copyright 2002 Roaring Penguin Software Inc.\n", VERSION);
+ fprintf(stderr, "http://www.roaringpenguin.com/\n\n");
+ fprintf(stderr, "Usage: %s [options]\n", argv[0]);
+ fprintf(stderr, "Options:\n");
+@@ -68,7 +68,7 @@
+ l2tp_peer_init();
+ l2tp_debug_set_bitmask(debugmask);
+
+- if (l2tp_parse_config_file(es, "/etc/l2tp/l2tp.conf") < 0) {
++ if (l2tp_parse_config_file(es, "/etc/rp-l2tp/rp-l2tpd.conf") < 0) {
+ l2tp_die();
+ }
+
+diff -ru rp-l2tp-0.4/man/l2tp.conf.5 rp-l2tp-0.4-gentoo/man/l2tp.conf.5
+--- rp-l2tp-0.4/man/l2tp.conf.5 2004-07-01 16:58:56.000000000 +0200
++++ rp-l2tp-0.4-gentoo/man/l2tp.conf.5 2004-07-12 20:51:58.000000000 +0200
+@@ -1,13 +1,13 @@
+-.\" $Id: rp-l2tp-0.4-gentoo.diff,v 1.1 2004/11/20 10:16:54 mrness Exp $
++.\" $Id: rp-l2tp-0.4-gentoo.diff,v 1.1 2004/11/20 10:16:54 mrness Exp $
+ .\" LIC: GPL
+-.TH L2TP.CONF 5 "11 March 2002"
++.TH RP-L2TPD.CONF 5 "11 March 2002"
+ .\""
+ .UC 4
+ .SH NAME
+-l2tp.conf \- L2TP configuration file
++rp-l2tpd.conf \- RP-L2TPD configuration file
+ .SH DESCRIPTION
+-The \fBl2tp.conf\fP file contains the configuration for
+-the L2TP daemon \fBl2tpd\fP(8).
++The \fBrp-l2tpd.conf\fP file contains the configuration for
++the RP-L2TPD daemon \fBrp-l2tpd\fP(8).
+ Each line in the file takes one of the following forms:
+ .\"
+ .IP "# \fIcomment\fR"
+@@ -155,9 +155,9 @@
+ in the global section. The only option available is:
+ .IP "\fBsocket-path\fP \fIpathname\fR"
+ Specifies the path name of the UNIX-domain socket for controlling the
+-daemon. Defaults to \fI/var/run/l2tpctrl\fR.
++daemon. Defaults to \fI/var/run/rp-l2tpdctrl\fR.
+ .PP
+ Even if you do not supply any options to cmd, you \fImust\fR have
+ a \fBsection cmd\fR line to activate the handler.
+ .SH AUTHORS
+-\fBl2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
++\fBrp-l2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
+diff -ru rp-l2tp-0.4/man/l2tpd.8 rp-l2tp-0.4-gentoo/man/l2tpd.8
+--- rp-l2tp-0.4/man/l2tpd.8 2002-09-30 21:45:00.000000000 +0200
++++ rp-l2tp-0.4-gentoo/man/l2tpd.8 2004-07-13 11:45:52.000000000 +0200
+@@ -1,14 +1,14 @@
+-.\" $Id: rp-l2tp-0.4-gentoo.diff,v 1.1 2004/11/20 10:16:54 mrness Exp $
++.\" $Id: rp-l2tp-0.4-gentoo.diff,v 1.1 2004/11/20 10:16:54 mrness Exp $
+ .\" LIC: GPL
+-.TH L2TPD 8 "11 March 2002"
++.TH RP-L2TPD 8 "11 March 2002"
+ .UC 4
+ .SH NAME
+-l2tpd \- user-space L2TP daemon.
++rp-l2tpd \- user-space L2TP daemon.
+ .SH SYNOPSIS
+-.B l2tpd \fR[\fIoptions\fR]
++.B rp-l2tpd \fR[\fIoptions\fR]
+
+ .SH DESCRIPTION
+-\fBl2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
++\fBrp-l2tpd\fR is a user-space L2TP daemon. L2TP is the Layer Two
+ Tunneling Protocol described in RFC 2661. It allows you to tunnel
+ PPP sessions over a network or transport protocol (in this case, UDP.)
+
+@@ -16,50 +16,50 @@
+ .TP
+ .B \-d \fInum\fR
+ Sets the debug level to \fInum\fR. Of interest mostly to
+-\fBl2tpd\fR developers. \fInum\fR is a bitmask; set it to
++\fBrp-l2tpd\fR developers. \fInum\fR is a bitmask; set it to
+ 65535 for maximum debugging information.
+
+ .TP
+ .B \-f
+-Do not fork. Normally, \fBl2tpd\fR forks and puts itself in the
++Do not fork. Normally, \fBrp-l2tpd\fR forks and puts itself in the
+ background. This option causes it to stay running in the foreground.
+
+-.SH L2TPD ARCHITECTURE
++.SH RP-L2TPD ARCHITECTURE
+
+-The \fBl2tpd\fR program itself contains \fIonly\fR code necessary
++The \fBrp-l2tpd\fR program itself contains \fIonly\fR code necessary
+ for processing L2TP datagrams and maintaining L2TP tunnels and
+ sessions. It does \fInot\fR contain code for interacting with
+ \fBpppd\fR or for users to control session establishment and teardown.
+ These functions are performed by \fIhandlers\fR, which are
+ shared-object libraries dynamically loaded at run-time.
+ .PP
+-The handlers currently distributed with \fBl2tpd\fR include:
++The handlers currently distributed with \fBrp-l2tpd\fR include:
+ .TP
+ .B sync-pppd.so
+-A shared-library which interfaces with \fBpppd\fR and allows \fBl2tpd\fR
++A shared-library which interfaces with \fBpppd\fR and allows \fBrp-l2tpd\fR
+ to act as both an LAC and an LNS.
+ .TP
+ .B cmd.so
+ A simple command-interpreter which listens on a UNIX-domain socket
+ and allows you to start and stop L2TP sessions.
+ .PP
+-\fBl2tpd\fR is a single-threaded, event-driven program. It should be
++\fBrp-l2tpd\fR is a single-threaded, event-driven program. It should be
+ fairly lightweight and efficient.
+
+-.SH L2TPD CONFIGURATION
+-On startup, \fBl2tpd\fR reads the configuration file \fB/etc/l2tp/l2tp.conf\fR.
++.SH RP-L2TPD CONFIGURATION
++On startup, \fBrp-l2tpd\fR reads the configuration file \fB/etc/rp-l2tp/rp-l2tpd.conf\fR.
+ This configuration file sets operating parameters, describes peers and loads
+-and configures handlers. See \fBl2tp.conf\fR(5) for configuration
++and configures handlers. See \fBrp-l2tpd.conf\fR(5) for configuration
+ file details.
+
+ .SH FILES
+ .TP
+-.B /etc/l2tp/l2tp.conf
++.B /etc/rp-l2tp/rp-l2tpd.conf
+ Main configuration file.
+ .TP
+-.B /var/run/l2tpctrl
++.B /var/run/rp-l2tpdctrl
+ Control socket for \fBcmd.so\fR handler.
+
+ .SH AUTHORS
+-\fBl2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
++\fBrp-l2tpd\fR was written by David F. Skoll <dfs@roaringpenguin.com>.
+
+diff -ru rp-l2tp-0.4/utils.c rp-l2tp-0.4-gentoo/utils.c
+--- rp-l2tp-0.4/utils.c 2002-09-30 21:45:00.000000000 +0200
++++ rp-l2tp-0.4-gentoo/utils.c 2004-07-12 20:49:56.000000000 +0200
+@@ -196,7 +196,7 @@
+ if (*fname == '/') {
+ handle = dlopen(fname, RTLD_NOW);
+ } else {
+- snprintf(buf, sizeof(buf), "%s/lib/l2tp/plugins/%s", PREFIX, fname);
++ snprintf(buf, sizeof(buf), "%s/lib/rp-l2tpd/plugins/%s", PREFIX, fname);
+ buf[sizeof(buf)-1] = 0;
+ handle = dlopen(buf, RTLD_NOW);
+ }
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff.bz2 b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff.bz2
deleted file mode 100644
index bbc6e05002ac..000000000000
--- a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-gentoo.diff.bz2
+++ /dev/null
Binary files differ
diff --git a/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild b/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild
index 9973ced4928e..1d9ff93f96e7 100644
--- a/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild
+++ b/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild,v 1.2 2004/10/17 10:02:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-l2tp/rp-l2tp-0.4.ebuild,v 1.3 2004/11/20 10:16:54 mrness Exp $
inherit eutils
@@ -9,23 +9,23 @@ HOMEPAGE="http://sourceforge.net/projects/rp-l2tp/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
DEPEND="virtual/libc"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
+KEYWORDS="x86 ~amd64 ~ppc"
SLOT="0"
IUSE=""
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
- epatch ${FILESDIR}/${P}-gentoo.diff.bz2
+ unpack ${A} || die "failed to unpack sources"
+ cd ${S} || die "source dir not found"
+ epatch ${FILESDIR}/${P}-gentoo.diff || die "failed to apply patch"
}
src_compile() {
- econf || die
- emake || die
+ econf || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- make RPM_INSTALL_ROOT=${D} install || die
+ make RPM_INSTALL_ROOT=${D} install || die "make install failed"
dodoc README
newdoc l2tp.conf rp-l2tpd.conf