summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-02-24 03:53:30 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-02-24 03:53:30 +0000
commit7766c7c3b2404321c9e32c5eae2f94d37550e407 (patch)
tree9e0ae7b2d8880e5b6fa6761189a8818f7037071f /net-dialup/rppppoek
parentfixup ChangeLog (diff)
downloadgentoo-2-7766c7c3b2404321c9e32c5eae2f94d37550e407.tar.gz
gentoo-2-7766c7c3b2404321c9e32c5eae2f94d37550e407.tar.bz2
gentoo-2-7766c7c3b2404321c9e32c5eae2f94d37550e407.zip
initial ebuild. fixes bug #16228
Diffstat (limited to 'net-dialup/rppppoek')
-rw-r--r--net-dialup/rppppoek/files/digest-rppppoek-0.331
-rw-r--r--net-dialup/rppppoek/files/rppppoek-0.33-panelicon.patch58
-rw-r--r--net-dialup/rppppoek/rppppoek-0.33.ebuild19
3 files changed, 78 insertions, 0 deletions
diff --git a/net-dialup/rppppoek/files/digest-rppppoek-0.33 b/net-dialup/rppppoek/files/digest-rppppoek-0.33
new file mode 100644
index 000000000000..689a1596b338
--- /dev/null
+++ b/net-dialup/rppppoek/files/digest-rppppoek-0.33
@@ -0,0 +1 @@
+MD5 9cc7ea28b1bda6ba29e9ea7e2058a9f9 rppppoek-0.33.tar.gz 677823
diff --git a/net-dialup/rppppoek/files/rppppoek-0.33-panelicon.patch b/net-dialup/rppppoek/files/rppppoek-0.33-panelicon.patch
new file mode 100644
index 000000000000..16a64f42c36d
--- /dev/null
+++ b/net-dialup/rppppoek/files/rppppoek-0.33-panelicon.patch
@@ -0,0 +1,58 @@
+--- rppppoek/rppppoek.cpp.orig 2003-02-18 02:43:35.000000000 +0900
++++ rppppoek/rppppoek.cpp 2003-02-23 03:08:53.000000000 +0900
+@@ -30,6 +30,15 @@
+ QString script = "rppppoek.sh";
+ KActionCollection* actionCollection = new KActionCollection(this);
+
++ stat = new KProcess;
++ *stat << "ifconfig" << "ppp0";
++ stat->start(KProcess::Block, KProcess::Stdout);
++ if (stat->exitStatus() == 0) {
++ setPixmap(Icon("connect_established"));
++ } else {
++ setPixmap(Icon("connect_no"));
++ }
++
+ start = new KProcess;
+ *start << script << "connect";
+
+@@ -40,7 +49,7 @@
+ *stop << script << "dconnect";
+
+ ipFound=false;
+- setPixmap(Icon("kppp"));
++/* setPixmap(Icon("kppp")); */
+
+ KAction* about = KStdAction::aboutApp(this, SLOT (showAbout()), actionCollection);
+ conToProv = new KAction(i18n("Connect"), Icon("connect_established"), 0, 0, 0, actionCollection, 0);
+@@ -116,7 +125,8 @@
+ void RPPPPoEK::connected(void){
+ if (start->normalExit()){
+ if (start->exitStatus() == 0)
+- KMessageBox::information(this, i18n("Connected successfully"));
++ setPixmap(Icon("connect_established"));
++/* KMessageBox::information(this, i18n("Connected successfully")); */
+ else
+ KMessageBox::sorry(this, i18n("Couldn't connect"));
+ }
+@@ -126,7 +136,8 @@
+ void RPPPPoEK::disconnected(void){
+ if (stop->normalExit()){
+ if (stop->exitStatus() == 0)
+- KMessageBox::information(this, i18n("Disconnected successfully"));
++ setPixmap(Icon("connect_no"));
++/* KMessageBox::information(this, i18n("Disconnected successfully")); */
+ else
+ KMessageBox::sorry(this, i18n("Couldn't disconnect"));
+ }
+--- rppppoek/rppppoek.sh 2002-06-18 23:36:21.000000000 +0200
++++ rppppoek/rppppoek.sh 2003-02-24 04:32:37.000000000 +0100
+@@ -80,7 +80,7 @@
+ ;;
+ status)
+ if [ $2 ]; then
+- $IFCONFIG | $GREP -s -A 1 $2 | $GREP inet | $CUT -f 2 -d : | $CUT -f 1 -d \
++ $IFCONFIG | $GREP -s -A 1 $2 | $GREP inet | $CUT -f 2 -d ":" | $CUT -f 1 -d "\\"
+ else
+ echo "Usage: $0 status device"
+ fi
diff --git a/net-dialup/rppppoek/rppppoek-0.33.ebuild b/net-dialup/rppppoek/rppppoek-0.33.ebuild
new file mode 100644
index 000000000000..04ee79f0ddb9
--- /dev/null
+++ b/net-dialup/rppppoek/rppppoek-0.33.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rppppoek/rppppoek-0.33.ebuild,v 1.1 2003/02/24 03:53:30 hannes Exp $
+
+inherit kde-base
+need-kde 3
+
+IUSE=""
+DESCRIPTION="KDE panel applet for managing (TM)RP-PPPoE"
+SRC_URI="http://download.berlios.de/segfaultskde/${P}.tar.gz"
+HOMEPAGE="http://segfaultskde.berlios.de/index.php?content=rppppoek"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+RDEPEND="${RDEPEND} net-dialup/rp-pppoe
+ app-admin/sudo"
+
+PATCHES="${FILESDIR}/${P}-panelicon.patch"