summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2003-08-08 16:20:25 +0000
committerJohn P. Davis <zhen@gentoo.org>2003-08-08 16:20:25 +0000
commit740f390da7d00557562c061121e48f015d27210c (patch)
tree022e023c4af2e9a1d40f6143dc112c4b57494158 /net-dialup/speedtouch
parentfixed a bunch of small things in the ebuild, as long as the my_p issue relate... (diff)
downloadgentoo-2-740f390da7d00557562c061121e48f015d27210c.tar.gz
gentoo-2-740f390da7d00557562c061121e48f015d27210c.tar.bz2
gentoo-2-740f390da7d00557562c061121e48f015d27210c.zip
fixed a bunch of small things in the ebuild, as long as the my_p issue related to bug 26066; check the changelog.
Diffstat (limited to 'net-dialup/speedtouch')
-rw-r--r--net-dialup/speedtouch/ChangeLog7
-rw-r--r--net-dialup/speedtouch/Manifest4
-rw-r--r--net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1-r11
-rw-r--r--net-dialup/speedtouch/speedtouch-1.2_beta1-r1.ebuild68
4 files changed, 77 insertions, 3 deletions
diff --git a/net-dialup/speedtouch/ChangeLog b/net-dialup/speedtouch/ChangeLog
index c8fa57b00cf7..d91bdb028b30 100644
--- a/net-dialup/speedtouch/ChangeLog
+++ b/net-dialup/speedtouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/speedtouch
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.7 2003/07/28 15:59:10 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/ChangeLog,v 1.8 2003/08/08 16:20:18 zhen Exp $
+
+ 08 Aug 2003; <zhen@gentoo.org> :
+ 1.2_beta1 did not compile due to $S not being set to ${WORKDIR}/${MY_P}. So I
+ fixed that, added an IUSE var, and added brackets around the 'use static' in
+ src_compile(). This closes bug 26066.
*speedtouch-1.2_beta1 (25 May 2003)
diff --git a/net-dialup/speedtouch/Manifest b/net-dialup/speedtouch/Manifest
index f7b4a73189bb..bb4eb8548168 100644
--- a/net-dialup/speedtouch/Manifest
+++ b/net-dialup/speedtouch/Manifest
@@ -1,7 +1,7 @@
-MD5 551060421daf0cb0b31b1594d2a8310b speedtouch-1.2_beta1-r1.ebuild 2237
+MD5 d6cb75f836823289e9672f65ed3be0e4 speedtouch-1.2_beta1-r1.ebuild 2238
MD5 ee915413289d98f927718ddd128f59ef speedtouch-1.1.ebuild 2097
MD5 015c866dd355e8af487a969f3fbce7fe speedtouch-1.2_beta1.ebuild 2195
-MD5 1488da5042945053030daa5d94f88cfd ChangeLog 1182
+MD5 7610f1d43605e54f3b4b0f02ea9a7629 ChangeLog 1415
MD5 c877ec28583dc934867e0f83bdcce5b0 files/speedtouch.rc6 2217
MD5 9c89baff861a43250255b1db0e5c1f6f files/speedtouch.confd 355
MD5 95f539c58595e5274cd5a8f57873d497 files/digest-speedtouch-1.2_beta1-r1 73
diff --git a/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1-r1 b/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1-r1
new file mode 100644
index 000000000000..6264e90614b1
--- /dev/null
+++ b/net-dialup/speedtouch/files/digest-speedtouch-1.2_beta1-r1
@@ -0,0 +1 @@
+MD5 a59dc82461ab170e1a55d08461bd895a speedtouch-1.2-beta1.tar.bz2 168793
diff --git a/net-dialup/speedtouch/speedtouch-1.2_beta1-r1.ebuild b/net-dialup/speedtouch/speedtouch-1.2_beta1-r1.ebuild
new file mode 100644
index 000000000000..bce5c0a5f5df
--- /dev/null
+++ b/net-dialup/speedtouch/speedtouch-1.2_beta1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.2_beta1-r1.ebuild,v 1.1 2003/08/08 16:20:18 zhen Exp $
+
+inherit flag-o-matic
+filter-flags -mpowerpc-gfxopt -mpowerpc-gpopt
+
+MY_P=${P/_/-}
+DESCRIPTION="GPL Driver for the Alcatel Speedtouch USB under *nix"
+HOMEPAGE="http://speedtouch.sf.net/"
+SRC_URI="mirror://sourceforge/speedtouch/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha hppa amd64"
+IUSE="debug static"
+
+DEPEND=""
+RDEPEND=">=net-dialup/ppp-2.4.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ [ `use debug` ] && myconf="--enable-debug"
+ [ `use static` ] && myconf="${myconf} --enable-static"
+
+ sed 's/^C$/#&/' < configure > configure.new
+ mv -f configure.new configure && chmod u+x configure
+
+ econf --enable-syslog \
+ ${myconf} || die "./configure failed"
+
+ #sed '90,104d' < Makefile > Makefile.new
+ #mv --force Makefile.new Makefile
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die
+
+ echo $(find ${D}/usr/share/doc/speedtouch/ -type f) | xargs dodoc
+ rm -rf ${D}/usr/share/doc/speedtouch/
+ dodoc AUTHORS COPYING ChangeLog INSTALL TODO VERSION
+ rm -r ${D}/etc/init.d/speedtouch
+ exeinto /etc/init.d ; newexe ${FILESDIR}/speedtouch.rc6 speedtouch
+ insinto /etc/conf.d ; newins ${FILESDIR}/speedtouch.confd speedtouch
+ insopts -m 600 ; insinto /etc/ppp/peers ; doins ${FILESDIR}/adsl.sample
+}
+
+pkg_postinst() {
+ echo ""
+ ewarn "Make sure you have kernel support for USB, HDCL and PPP"
+ ewarn "NB: kernels >= 2.4.18 include the hdlc patch"
+ echo ""
+ ewarn "Read and subscribe vendor's licence to download the microcode"
+ ewarn "You can get it from: "
+ ewarn " 1) vendor's site: http://www.speedtouchdsl.com/dvrreg_lx.htm"
+ ewarn " 2) a windows system: c:\windows\system\alcaudsl.sys"
+ ewarn " 3) the CD provided: X:\Driver\alcaudsl.sys"
+ ewarn "Then you should set its path in the /etc/conf.d/speedtouch file"
+ ewarn "edit and rename 'adsl.sample' to 'adsl' in /etc/ppp/peers/adsl and"
+ ewarn "bring up your adsl line using the /etc/init.d/speedtouch script"
+ echo ""
+ einfo "More info in the documentation in /usr/share/doc/${P}"
+ echo ""
+}