summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-30 13:05:47 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-30 13:05:47 +0000
commit3d01f4c7edcad86becb14c36c8d7347cc977222c (patch)
treeac1b7e873e36e0e4c89da2fe6460cbbe7f961ef6 /net-dialup
parentVersion bump, 1.01.00 stable on x86. (diff)
downloadgentoo-2-3d01f4c7edcad86becb14c36c8d7347cc977222c.tar.gz
gentoo-2-3d01f4c7edcad86becb14c36c8d7347cc977222c.tar.bz2
gentoo-2-3d01f4c7edcad86becb14c36c8d7347cc977222c.zip
Initial version, created for fixing bug #131693.
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ueagle-atm/ChangeLog10
-rw-r--r--net-dialup/ueagle-atm/Manifest4
-rw-r--r--net-dialup/ueagle-atm/files/README234
-rw-r--r--net-dialup/ueagle-atm/files/digest-ueagle-atm-1.11
-rw-r--r--net-dialup/ueagle-atm/metadata.xml7
-rw-r--r--net-dialup/ueagle-atm/ueagle-atm-1.1.ebuild80
6 files changed, 336 insertions, 0 deletions
diff --git a/net-dialup/ueagle-atm/ChangeLog b/net-dialup/ueagle-atm/ChangeLog
new file mode 100644
index 000000000000..048d3ee8ea19
--- /dev/null
+++ b/net-dialup/ueagle-atm/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/ueagle-atm
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ueagle-atm/ChangeLog,v 1.1 2006/04/30 13:05:47 mrness Exp $
+
+*ueagle-atm-1.1 (30 Apr 2006)
+
+ 30 Apr 2006; Alin Nastac <mrness@gentoo.org> +files/README, +metadata.xml,
+ +ueagle-atm-1.1.ebuild:
+ Initial version, created for fixing bug #131693.
+
diff --git a/net-dialup/ueagle-atm/Manifest b/net-dialup/ueagle-atm/Manifest
new file mode 100644
index 000000000000..9b32468de4b2
--- /dev/null
+++ b/net-dialup/ueagle-atm/Manifest
@@ -0,0 +1,4 @@
+MD5 0cf8405a4993538a941f235f6410b15f files/README 8766
+MD5 0d747d791cf20ab224f960ab892c767d files/digest-ueagle-atm-1.1 72
+MD5 7bb58ae97db72c0e60691f42e245e6ba metadata.xml 312
+MD5 218bf4f50f312c476b79599d79173193 ueagle-atm-1.1.ebuild 2536
diff --git a/net-dialup/ueagle-atm/files/README b/net-dialup/ueagle-atm/files/README
new file mode 100644
index 000000000000..9af58f9da03f
--- /dev/null
+++ b/net-dialup/ueagle-atm/files/README
@@ -0,0 +1,234 @@
+Introduction
+============
+
+This ebuild installs firmware files necessary for ADI 930/Eagle USB ADSL
+Modem driver which first appeared in kernel 2.6.16 as a replacement for
+the user-space driver. For earlier kernels, the net-dialup/eagle-usb package
+must be emerged instead.
+
+
+Configuration
+=============
+
+Most ADSL modems are connected via the ATM protocol, rather
+than Ethernet. For ATM, run the following:
+ euse -E atm && emerge net-dialup/ppp net-dialup/ueagle-atm
+
+It is necessary to choose an interface number for the connection. This
+is arbitrary - the only requirement is that the connection number is
+not already in use. The first available number is 0, and it is usual to
+choose the lowest unused number. For the purposes of this document, 0
+will be chosen.
+
+Add the following lines from the appropriate section below to
+/etc/conf.d/net, then customize them as per the inline comments.
+
+
+a) PPPoATM configuration:
+
+config_ppp0=( 'ppp' ) # Runs /lib/rcscripts/net.modules.d/pppd.sh
+link_ppp0='/dev/null' # Not required by PPPoA links, but must be specified
+# The 2 numbers represent the VPI & VCI of your ISP, and they are separated
+# by a dot. Ask your ISP about those numbers.
+plugins_ppp0=( 'pppoa 0.38' )
+# 'man pppd' shows other options. Compression is disabled because it is
+# rarely taken advantage of, and may interfere with the connection.
+# Add option 'usepeerdns' to populate /etc/resolv.conf
+pppd_ppp0=( updetach noauth debug defaultroute noaccomp nobsdcomp noccp
+ nodeflate nopcomp novj novjccomp )
+username_ppp0='username@isp.com' # E.g. 'fredbloggs@hg5.btclick.com'
+password_ppp0='password' # ADSL password, assigned by your ISP
+
+# If the kernel modules are not built-in, then they must be loaded
+# before starting the PPP daemon:
+function preup() {
+ if [[ "$1" = "ppp0" ]] ; then
+ modprobe -q ueagle-atm
+ return 0
+ fi
+}
+
+
+b) PPPoE configuration:
+
+config_nas0=( null )
+# Use "-e 0" for LLC mux or "-e 1" for VC mux.
+# The 2 numbers after "-a" represent the VPI & VCI of your ISP, and
+# they are separated by a dot. Ask your ISP about those numbers.
+br2684ctl_nas0="-a 0.38 -e 0"
+depend_ppp0() {
+ need net.nas0
+}
+
+# If the kernel modules are not built-in, then they must be loaded
+# before starting the PPP daemon:
+function preup() {
+ if [[ "$1" = "nas0" ]] ; then
+ modprobe -q ueagle-atm
+ fi
+}
+
+config_ppp0=( 'ppp' ) # Runs /lib/rcscripts/net.modules.d/pppd.sh
+# The name of the Ethernet interface over which PPPoE links
+link_ppp0='nas0' # Must correspond to the -c option of the br2684ctl utility
+plugins_ppp0=( pppoe )
+# 'man pppd' shows other options. Compression is disabled because it is
+# rarely taken advantage of, and may interfere with the connection.
+# Add option 'usepeerdns' to populate /etc/resolv.conf
+pppd_ppp0=( updetach noauth debug defaultroute noaccomp nobsdcomp noccp
+ nodeflate nopcomp novj novjccomp )
+username_ppp0='username@isp.com' # E.g. 'fredbloggs@hg5.btclick.com'
+password_ppp0='password' # ADSL password, assigned by your ISP
+
+
+
+Configuration continued
+=======================
+
+Create a symlink for the new network interface, for it to be enabled by
+baselayout:
+ cd /etc/init.d && ln -sfn net.lo net.ppp0
+
+The "debug" option adds some extra commentary from pppd regarding the
+connection to /var/log/messages, e.g.:
+"sent [LCP ConfReq id=0x1 <magic 0x7bea6ef1>]". It is wise to keep the
+option on permanently, due to its usefulness when debugging.
+
+Set RC_NET_STRICT_CHECKING="yes" in /etc/conf.d/rc, to prevent Internet
+services in /etc/init.d/ from starting before the Internet connection
+is established. Other options are to start/stop programs in
+/etc/ppp/ip-{up,down}.local, and to customize initscript dependencies
+as described in:
+ http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=4
+
+
+Starting the Connection
+=======================
+
+To start manually, with the modem connected:
+ /etc/init.d/net.ppp0 start
+
+To start automatically when the PC boots:
+ rc-update add net.ppp0 default
+
+
+Kernel Configuration
+====================
+
+The ebuild, during an emerge, checks that the required kernel modules
+are present.
+
+Note that in the list below, "[*]" means that the option is compiled
+into the kernel, whereas "[M]" means that the option can either be
+compiled into the kernel, or as a module. Compiling them into the
+kernel is recommended, to guarantee that the modules are already loaded
+when they are needed, and it will improve the bootup time by a couple
+of seconds.
+
+In "make menuconfig", you can press "/" and search on e.g. "eagle"
+to see exactly where an option is - the location of an option and its
+dependencies can change between kernel versions.
+
+Check that the following kernel options are configured as shown (this
+list includes the prerequisites, e.g. USB_UEAGLEATM depends on USB):
+
+ Code maturity level options --->
+ [*] Prompt for development and/or incomplete code/drivers
+ - CONFIG_EXPERIMENTAL
+
+ Device Drivers --->
+ Generic Driver Options --->
+ [ ] Select only drivers that don't need compile-time external
+ firmware (*unselected*) - CONFIG_STANDALONE
+ [*] Hotplug firmware loading support - CONFIG_FW_LOADER
+
+ Networking --->
+ [*] Networking support - CONFIG_NET
+ Networking options --->
+ [*] Packet socket - CONFIG_PACKET
+ [M] Asynchronous Transfer Mode (ATM) - CONFIG_ATM
+ [M] RFC1483/2684 Bridged protocols - CONFIG_ATM_BR2684 (only needed for PPPoE)
+
+ Device Drivers --->
+ Network device support --->
+ [*] Network device support - CONFIG_NETDEVICES
+ [*] PPP (point-to-point protocol) support - CONFIG_PPP
+ [M] PPP Deflate compression - CONFIG_PPP_DEFLATE (only useful if
+ compression is supported - rare)
+ [M] PPP BSD-Compress compression - CONFIG_PPP_BSDCOMP (only useful
+ if compression is supported - rare)
+ [M] PPP over Ethernet - CONFIG_PPPOE (only needed for PPPoE)
+ [M] PPP over ATM - CONFIG_PPPOATM (only needed for PPPoATM)
+ USB support --->
+ [*] Support for Host-side USB - CONFIG_USB
+ [*] USB device filesystem - CONFIG_USB_DEVICEFS
+ [M] (O or U)HCI HCD support
+ USB DSL modem support --->
+ [M] USB DSL modem support - CONFIG_USB_ATM
+ [M] ADI 930 and eagle USB DSL modem - CONFIG_USB_UEAGLEATM
+
+
+
+Troubleshooting
+===============
+
+Try "emerge ueagle-atm" again, because the ebuild checks that the
+required kernel modules are present (showing a warning message if
+appropriate), and creates the firmware files in /lib/firmware/ueagle-atm.
+
+If the modem is unresponsive, then run "/etc/init.d/net.ppp0 stop" and
+unplug the modem for 30 seconds, to drain its memory. Then reconnect
+the modem to the PC and run "/etc/init.d/net.ppp0 start"
+
+To check the modem's connection progress, run:
+ tail -f /var/log/messages
+/var/log/messages should show e.g.:
+
+pppd[nnn]: Plugin pppoatm.so loaded.
+pppd[nnn]: pppd n.n.n started by root, uid 0
+pppd[nnn]: Using interface ppp0
+pppd[nnn]: Connect: ppp0 <--> n.nn
+ADSL line is synchronising
+DSL line goes up
+ADSL line is up (nnn Kib/s down | nnn Kib/s up)
+pppd[nnn]: CHAP authentication succeeded
+pppd[nnn]: local IP address nnn.nnn.nnn.nnn
+pppd[nnn]: remote IP address nnn.nnn.nnn.nnn
+
+
+If the authentification fails, then check username_ppp0 and
+password_ppp0.
+
+If the ADSL connection is not established, then check the options in
+pppd_ppp0. "man pppd" explains all the options in that file.
+
+If the ADSL connection seems to have worked, but no websites can be
+contacted, then check that /etc/resolv.conf is populated, and possibly
+add the "usepeerdns" option (to use the ISP's DNS) to pppd_ppp0 in
+/etc/conf.d/net .
+
+If the problem is still not resolved, post to the Gentoo Forums at
+http://forums.gentoo.org/ and ultimately, if there is no answer,
+file a bug at http://bugs.gentoo.org/ .
+
+
+Compression
+===========
+
+Some ISPs require compression to be disabled in order for the
+connection to work, so the default configuration described above
+disables compression. Few ISPs support ADSL compression anyway. If you
+are lucky enough to have an ISP which *does* support compression
+(Google is your best friend for determining this), then compression can
+be enabled by following these steps:
+
+* Compile the kernel modules CONFIG_PPP_DEFLATE and CONFIG_PPP_BSDCOMP
+(only one is strictly necessary - pppd prefers "deflate" compression).
+Add them to /etc/modules.autoload.d/kernel-2.6 or /etc/conf.d/net above
+the "pppoatm" line, if they are not built-in.
+* Remove the following options in pppd_ppp0:
+ noaccomp nobsdcomp noccp nodeflate nopcomp novj novjccomp
+* Ensure that "debug" is in the pppd_ppp0 options, to check that
+compression is being utilized. Note that "module registered" in
+/var/log/messages only confirms that the kernel module is loaded -
+it does not indicate that the connection is compressed.
diff --git a/net-dialup/ueagle-atm/files/digest-ueagle-atm-1.1 b/net-dialup/ueagle-atm/files/digest-ueagle-atm-1.1
new file mode 100644
index 000000000000..224202223d37
--- /dev/null
+++ b/net-dialup/ueagle-atm/files/digest-ueagle-atm-1.1
@@ -0,0 +1 @@
+MD5 06dc13f3588ad963d1e6f94916271e93 ueagle-data-src-1.1.tar.gz 1270515
diff --git a/net-dialup/ueagle-atm/metadata.xml b/net-dialup/ueagle-atm/metadata.xml
new file mode 100644
index 000000000000..a8d7ab325f28
--- /dev/null
+++ b/net-dialup/ueagle-atm/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>Firmware and configuration instructions for ADI 930/Eagle USB ADSL Modem driver
+available in kernels >= 2.6.16.</longdescription>
+</pkgmetadata>
diff --git a/net-dialup/ueagle-atm/ueagle-atm-1.1.ebuild b/net-dialup/ueagle-atm/ueagle-atm-1.1.ebuild
new file mode 100644
index 000000000000..ec43d1d6ebfb
--- /dev/null
+++ b/net-dialup/ueagle-atm/ueagle-atm-1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ueagle-atm/ueagle-atm-1.1.ebuild,v 1.1 2006/04/30 13:05:47 mrness Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="Firmware and configuration instructions for ADI 930/Eagle USB ADSL Modem driver"
+HOMEPAGE="https://gna.org/projects/ueagleatm/"
+SRC_URI="http://eagle-usb.org/ueagle-atm/non-free/ueagle-data-src-${PV}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-dialup/ppp-2.4.3-r14
+ !net-dialup/eagle-usb"
+
+S="${WORKDIR}/ueagle-data-src-${PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 16 ; then
+ eerror "The kernel-space driver exists only in kernels >= 2.6.16."
+ eerror "Please emerge net-dialup/eagle-usb instead or upgrade the kernel."
+ die "Unsupported kernel version"
+ fi
+
+ if ! has_version '>=sys-apps/baselayout-1.12.0_pre18' ; then
+ ewarn "The best way of using this driver is through the pppd net module of"
+ ewarn ">=sys-apps/baselayout-1.12.0_pre18, which is also the only"
+ ewarn "documented mode of using ${CATEGORY}/${PN}."
+ ewarn "Please install baselayout-1.12.0_pre18 or else you will be on your own!"
+ ebeep
+ fi
+}
+
+src_compile() {
+ make generate
+}
+
+src_install() {
+ # Copy to the firmware directory
+ insinto /lib/firmware/ueagle-atm
+ insopts -m 600
+ doins build/* || die "doins firmware failed"
+
+ # Documentation necessary to complete the setup
+ dodoc "${FILESDIR}/README" || die "dodoc failed"
+}
+
+pkg_postinst() {
+ # Check kernel configuration
+ CONFIG_CHECK="~FW_LOADER ~NET ~PACKET ~ATM ~NETDEVICES ~USB_DEVICEFS ~USB_ATM ~USB_UEAGLEATM \
+ ~PPP ~PPPOATM ~PPPOE ~ATM_BR2684"
+ check_extra_config
+ einfo "Note: All the above kernel configurations are required except the following:"
+ einfo " - CONFIG_PPPOATM is needed only for PPPoA links, while"
+ einfo " - CONFIG_PPPOE and CONFIG_ATM_BR2684 are needed only for PPPoE links."
+ echo
+
+ # Check user space for PPPoA support
+ if ! built_with_use net-dialup/ppp atm ; then
+ eerror "PPPoA support: net-dialup/ppp should be built with 'atm' USE flag enabled!"
+ ewarn "Run the following command if you need PPPoA support:"
+ einfo " euse -E atm && emerge net-dialup/ppp"
+ echo
+ fi
+ # Check user space PPPoE support
+ if ! has_version net-misc/br2684ctl ; then
+ eerror "PPPoE support: net-misc/br2684ctl is not installed!"
+ ewarn "Run the following command if you need PPPoE support:"
+ einfo " emerge net-misc/br2684ctl"
+ echo
+ fi
+
+ ewarn "To complete the installation, you must read the documentation available in"
+ ewarn " ${ROOT}usr/share/doc/${PF}"
+}