summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-01-05 08:46:38 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-01-05 08:46:38 +0000
commita57e65485cf974e522939371a59e063e3c333594 (patch)
treef199445b6d9928f5c8a1705f4407261bc99218ff /net-dialup
parentFixed encoding in ChangeLog (diff)
downloadgentoo-2-a57e65485cf974e522939371a59e063e3c333594.tar.gz
gentoo-2-a57e65485cf974e522939371a59e063e3c333594.tar.bz2
gentoo-2-a57e65485cf974e522939371a59e063e3c333594.zip
Version bump for kernel 2.6.28.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/dgcmodem/ChangeLog9
-rw-r--r--net-dialup/dgcmodem/dgcmodem-1.09.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-dialup/dgcmodem/ChangeLog b/net-dialup/dgcmodem/ChangeLog
index e92ecd26093e..7f4098d21afb 100644
--- a/net-dialup/dgcmodem/ChangeLog
+++ b/net-dialup/dgcmodem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/dgcmodem
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/dgcmodem/ChangeLog,v 1.2 2008/10/18 08:26:17 calchan Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/dgcmodem/ChangeLog,v 1.3 2009/01/05 08:46:38 calchan Exp $
+
+*dgcmodem-1.09 (05 Jan 2009)
+
+ 05 Jan 2009; Denis Dupeyron <calchan@gentoo.org> +dgcmodem-1.09.ebuild:
+ Version bump for kernel 2.6.28.
*dgcmodem-1.08 (18 Oct 2008)
diff --git a/net-dialup/dgcmodem/dgcmodem-1.09.ebuild b/net-dialup/dgcmodem/dgcmodem-1.09.ebuild
new file mode 100644
index 000000000000..2b2fea4db474
--- /dev/null
+++ b/net-dialup/dgcmodem/dgcmodem-1.09.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/dgcmodem/dgcmodem-1.09.ebuild,v 1.1 2009/01/05 08:46:38 calchan Exp $
+
+inherit linux-info
+
+DESCRIPTION="Driver for Connexant DGC modems"
+HOMEPAGE="http://www.linuxant.com/drivers/dgc/"
+SRC_URI="http://www.linuxant.com/drivers/dgc/archive/${P}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="USB_ACM"
+ERROR_USB_ACM="${PN} requires USB modem (CDC ACM) support in your kernel (module name: USB_ACM)".
+
+src_compile() {
+ cd "${S}"/scripts
+ emake dgcconfig dgcdcpd dgcmodconflicts dgcstop || die "Failed to make scripts"
+}
+
+src_install() {
+ rm -f modules/GPL/COPYING
+ rm -rf modules/binaries
+ insinto /usr/lib/dgcmodem
+ doins -r modules config.mak || die "Failed to install module files"
+ fperms u+x /usr/lib/dgcmodem/modules/kernelcompiler.sh
+
+ cd "${S}"/scripts
+ dosbin dgcconfig dgcdcpd dgcmodconflicts dgcstop || die "Failed to install scripts"
+
+ echo 'KERNEL=="ttyACM0", SYMLINK="modem"' > "${D}"/etc/udev/rules.d/90-dgcmodem.rules
+
+ keepdir /etc/dgcmodem
+}
+
+pkg_postinst() {
+ ewarn "Users need to be in the uucp group to use this driver."
+ ewarn
+ ewarn "Do not set the baud rate to a value higher than 115200, or it will not work."
+ elog
+ elog "Please run:"
+ elog " emerge --config ${PN}"
+ elog "now and every time you update your kernel."
+ elog
+ elog "Note that using dgcconfig with default options may install an undesirable"
+ elog "rc script, so it is advised you always use the above command instead."
+}
+
+pkg_config(){
+ dgcconfig --kernel --serial --info
+}
+
+pkg_prerm() {
+ dgcconfig --remove
+ rm -f /etc/dgcmodem/.serial_configured
+}