summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-05-19 21:58:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-05-19 21:58:45 +0000
commitabe03f0298fc9a6f1c7b5f74168c41c21d6ec9ef (patch)
tree16471d93a4f86a1e521e9696935424be65f47b9b /net-dialup
parentAdd missing dependency over rack, without this, applications using mod_passen... (diff)
downloadgentoo-2-abe03f0298fc9a6f1c7b5f74168c41c21d6ec9ef.tar.gz
gentoo-2-abe03f0298fc9a6f1c7b5f74168c41c21d6ec9ef.tar.bz2
gentoo-2-abe03f0298fc9a6f1c7b5f74168c41c21d6ec9ef.zip
Add glibc name conflict fix, thanks to Conrad Kostecki in bug #270452
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/minicom/ChangeLog8
-rw-r--r--net-dialup/minicom/files/minicom-2.3-getline-rename.patch111
-rw-r--r--net-dialup/minicom/minicom-2.3-r1.ebuild7
3 files changed, 122 insertions, 4 deletions
diff --git a/net-dialup/minicom/ChangeLog b/net-dialup/minicom/ChangeLog
index aebb6a7a51a5..730918d478ac 100644
--- a/net-dialup/minicom/ChangeLog
+++ b/net-dialup/minicom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/minicom
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.67 2008/11/18 22:32:03 mrness Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.68 2009/05/19 21:58:44 jokey Exp $
+
+ 19 May 2009; Markus Ullmann <jokey@gentoo.org> minicom-2.3-r1.ebuild,
+ +files/minicom-2.3-getline-rename.patch:
+ Add glibc name conflict fix, thanks to Conrad Kostecki in bug #270452
18 Nov 2008; Alin Năstac <mrness@gentoo.org> minicom-2.2-r1.ebuild,
minicom-2.3-r1.ebuild:
diff --git a/net-dialup/minicom/files/minicom-2.3-getline-rename.patch b/net-dialup/minicom/files/minicom-2.3-getline-rename.patch
new file mode 100644
index 000000000000..5ea6c7622a9a
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.3-getline-rename.patch
@@ -0,0 +1,111 @@
+--- minicom-2.3.orig/src/minicom.c 2008-02-02 23:49:53.000000000 +0100
++++ minicom-2.3/src/minicom.c 2009-05-19 22:09:13.121029740 +0200
+@@ -167,7 +167,7 @@
+ #endif /*SIGTSTP*/
+
+ /* Get a line from either window or scroll back buffer. */
+-static ELM *getline(WIN *w, int no)
++static ELM *_getline(WIN *w, int no)
+ {
+ int i;
+ static ELM outofrange[MAXCOLS] = {{0,0,0}};
+@@ -205,7 +205,7 @@
+
+ w->direct = 0;
+ for (f = 0; f < w->ys; f++)
+- mc_wdrawelm(w, f, getline(w, y++));
++ mc_wdrawelm(w, f, _getline(w, y++));
+ if (r)
+ mc_wredraw(w, 1);
+ w->direct = 1;
+@@ -227,7 +227,7 @@
+ tmp_line[0]='\0';
+ w->direct = 0;
+ for (f = 0; f < w->ys; f++) {
+- tmp_e = getline(w, y++);
++ tmp_e = _getline(w, y++);
+
+ /* First we "accumulate" the line into a variable */
+ mc_wdrawelm_var(w, tmp_e, tmp_line);
+@@ -324,7 +324,7 @@
+
+ for (next_line = hit_line; next_line <= all_lines; next_line++) {
+ /* we do 'something' here... :-) */
+- tmp_e = getline(w_hist, next_line);
++ tmp_e = _getline(w_hist, next_line);
+
+ /*
+ * First we "accumulate" the line into a variable.
+@@ -379,9 +379,9 @@
+ static void drawcite(WIN *w, int y, int citey, int start, int end)
+ {
+ if (y+citey >= start && y+citey <= end)
+- mc_wdrawelm_inverse(w, y, getline(w, y+citey));
++ mc_wdrawelm_inverse(w, y, _getline(w, y+citey));
+ else
+- mc_wdrawelm(w, y, getline(w, y+citey));
++ mc_wdrawelm(w, y, _getline(w, y+citey));
+ }
+
+ static void drawcite_whole(WIN *w, int y, int start, int end)
+@@ -400,7 +400,7 @@
+ for (y=start; y<=end; y++) {
+ vt_send('>');
+ vt_send(' ');
+- tmp_e = getline(w, y);
++ tmp_e = _getline(w, y);
+ mc_wdrawelm_var(w, tmp_e, tmp_line);
+ tmp_line[w->xs] = 0;
+ for (x = w->xs-1; x >= 0; x--) {
+@@ -600,7 +600,7 @@
+ if (citemode) {
+ inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
+ } else {
+- tmp_e = getline(b_us, y);
++ tmp_e = _getline(b_us, y);
+ if (wcslen(look_for) > 1) {
+ /* quick scan for pattern match */
+ mc_wdrawelm_var(b_us, tmp_e, tmp_line);
+@@ -611,9 +611,9 @@
+ }
+
+ if (inverse)
+- mc_wdrawelm_inverse(b_us, 0, getline(b_us, y));
++ mc_wdrawelm_inverse(b_us, 0, _getline(b_us, y));
+ else
+- mc_wdrawelm(b_us, 0, getline(b_us, y));
++ mc_wdrawelm(b_us, 0, _getline(b_us, y));
+ if (citemode)
+ mc_wlocate(b_us, 0, cite_y);
+ mc_wflush();
+@@ -648,7 +648,7 @@
+ if (citemode) {
+ inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
+ } else {
+- tmp_e = getline(b_us, y + b_us->ys - 1);
++ tmp_e = _getline(b_us, y + b_us->ys - 1);
+ if (wcslen(look_for) > 1) {
+ /* quick scan for pattern match */
+ mc_wdrawelm_var(b_us, tmp_e, tmp_line);
+@@ -660,10 +660,10 @@
+
+ if (inverse)
+ mc_wdrawelm_inverse(b_us, b_us->ys - 1,
+- getline(b_us, y + b_us->ys - 1));
++ _getline(b_us, y + b_us->ys - 1));
+ else
+ mc_wdrawelm(b_us, b_us->ys - 1,
+- getline(b_us, y + b_us->ys - 1));
++ _getline(b_us, y + b_us->ys - 1));
+ if (citemode)
+ mc_wlocate(b_us, 0, cite_y);
+ mc_wflush();
+@@ -753,7 +753,7 @@
+ mc_wlocate(b_st, 0, 0);
+ mc_wprintf(b_st, hline);
+ mc_wredraw(b_st, 1);
+- mc_wdrawelm_inverse(b_us, cite_y, getline(b_us, cite_ystart));
++ mc_wdrawelm_inverse(b_us, cite_y, _getline(b_us, cite_ystart));
+ mc_wlocate(b_us, 0, cite_y);
+ break;
+ case K_ESC:
diff --git a/net-dialup/minicom/minicom-2.3-r1.ebuild b/net-dialup/minicom/minicom-2.3-r1.ebuild
index 2b810d73420c..a6e1f15ed11a 100644
--- a/net-dialup/minicom/minicom-2.3-r1.ebuild
+++ b/net-dialup/minicom/minicom-2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.3-r1.ebuild,v 1.6 2008/11/18 22:32:03 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.3-r1.ebuild,v 1.7 2009/05/19 21:58:44 jokey Exp $
inherit eutils
@@ -29,6 +29,9 @@ IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${P}-gentoo-runscript.patch
+
+ #glibc name conflict
+ epatch "${FILESDIR}"/${P}-getline-rename.patch
}
src_compile() {