summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-04-15 11:29:58 +0000
committerAlin Năstac <mrness@gentoo.org>2007-04-15 11:29:58 +0000
commitb7630fe762ff1305ba3dba4196fb9cf659a31382 (patch)
tree117fb10e24c1c0af81e829986e16884f9005b42e /net-dialup
parentStable on ppc wrt bug 174390 (diff)
downloadgentoo-2-b7630fe762ff1305ba3dba4196fb9cf659a31382.tar.gz
gentoo-2-b7630fe762ff1305ba3dba4196fb9cf659a31382.tar.bz2
gentoo-2-b7630fe762ff1305ba3dba4196fb9cf659a31382.zip
Fix implicit declaration warning
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/vbox3/ChangeLog8
-rw-r--r--net-dialup/vbox3/files/vbox3-0.1.9-implicit-decl.patch11
-rw-r--r--net-dialup/vbox3/vbox3-0.1.9.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/net-dialup/vbox3/ChangeLog b/net-dialup/vbox3/ChangeLog
index 9c545a6fa304..a4a8af6cf200 100644
--- a/net-dialup/vbox3/ChangeLog
+++ b/net-dialup/vbox3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/vbox3
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/vbox3/ChangeLog,v 1.4 2006/03/16 22:15:48 mrness Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/vbox3/ChangeLog,v 1.5 2007/04/15 11:29:58 mrness Exp $
+
+ 15 Apr 2007; Alin Năstac <mrness@gentoo.org>
+ +files/vbox3-0.1.9-implicit-decl.patch, vbox3-0.1.9.ebuild:
+ Fix implicit declaration warning.
16 Mar 2006; Alin Nastac <mrness@gentoo.org> vbox3-0.1.9.ebuild:
Remove virtual/libc dependency.
diff --git a/net-dialup/vbox3/files/vbox3-0.1.9-implicit-decl.patch b/net-dialup/vbox3/files/vbox3-0.1.9-implicit-decl.patch
new file mode 100644
index 000000000000..a132f4565ed1
--- /dev/null
+++ b/net-dialup/vbox3/files/vbox3-0.1.9-implicit-decl.patch
@@ -0,0 +1,11 @@
+diff -Nru vbox3-0.1.9.orig/vboxgetty/lock.c vbox3-0.1.9/vboxgetty/lock.c
+--- vbox3-0.1.9.orig/vboxgetty/lock.c 2001-01-14 15:50:20.000000000 +0200
++++ vbox3-0.1.9/vboxgetty/lock.c 2007-04-15 14:27:35.000000000 +0300
+@@ -10,6 +10,7 @@
+
+ #include <stdio.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <signal.h>
+ #include <errno.h>
diff --git a/net-dialup/vbox3/vbox3-0.1.9.ebuild b/net-dialup/vbox3/vbox3-0.1.9.ebuild
index b0dc4fb5d136..f82f2287dbbe 100644
--- a/net-dialup/vbox3/vbox3-0.1.9.ebuild
+++ b/net-dialup/vbox3/vbox3-0.1.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/vbox3/vbox3-0.1.9.ebuild,v 1.4 2006/03/16 22:15:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/vbox3/vbox3-0.1.9.ebuild,v 1.5 2007/04/15 11:29:58 mrness Exp $
inherit eutils libtool
@@ -21,7 +21,8 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/makefile-${PV}.patch" || die "failed to patch makefile"
+ epatch "${FILESDIR}/makefile-${PV}.patch"
+ epatch "${FILESDIR}/${P}-implicit-decl.patch"
elibtoolize
}